hilfdirselbst.ch
Facebook Twitter gamper-media
Tipps und Tricks zu Adobe GoLive von Dirk Levy, GoLive FAQ's von Randolph Sterna
Hanü
Beiträge: 219
16. Feb 2002, 04:29
Beitrag #1 von 6
Bewertung:
(1516 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

[Problem] Tabellen in NN


Ich bin von Frames auf Tabellen umgestiegen, um mehr Browserkompatibiliät (*megalangeswort*) zu erreichen. Ich dachte, dann können auch Leute mit älteren Browser meine Seiten besser betrachten.

Jetzt hab ich mir mal NN4.7 und NN6.2 runtergeladen, um zu testen, wie damit meine Seiten aussehen, und muss sagen, ich bin schwer enttäuscht. Bei mir sehen in NN die Seiten absolut nicht aus, wie sie eigentlich sollten. Die Tabellen sind total verschoben...

Aber seht selbst unter:
[Link entfernt, da Seite nicht mehr vorhanden]

Ich dachte immer, GoLive produziert einen Quellcode, der von den meisten Browsern (und da gehören NN-Versionen wohl unweigerlich auch dazu) unterstützt und richtig interpretiert wird!?

Oder hab ich da einen gewaltigen Fehler bei den Voreinstellungen von GL gemacht???

Bin für Hilfe seeeehhhrr dankbar!!!
Und falls mir einer erzählen will, dass die Seiten in NN genauso wie im IE aussehen, glaub ich das erst, wenn ich Screenshots davon gesehen habe...

Gruß Andreas


[ Diese Nachricht wurde geändert von: Hanü am 2002-03-31 18:47 ] Top
 
X
gudrun
Beiträge: 48
16. Feb 2002, 15:20
Beitrag #2 von 6
Beitrag ID: #737
Bewertung:
(1516 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

[Problem] Tabellen in NN


Hast Du ein Layoutraster darunter?
Tabellen besser ohne erstellen.
Hatte früher ähnliches Problem.
Jetzt sind meine Tabellen fast gleich in allen Browsern.
als Antwort auf: [#733] Top
 
pedrito
Beiträge: 10
16. Feb 2002, 23:02
Beitrag #3 von 6
Beitrag ID: #747
Bewertung:
(1516 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

[Problem] Tabellen in NN


Hi, Hanü,
das Erste, das mir entgegenkommt, ist eine Fehlermeldung im IE. Das liegt wahrscheinlich daran, das du den Tag </csactions> nicht geöffnet hast. Ich würde bei jeder Seite, die rausgeht, einen Syntax-Check machen. Nutze die guten dinge von GoLive aus.
Für die Netzkappe musst du &nbsp; in allen leeren Zellen   einfügen, um die Tabellen zu stabilisieren.
Das Design bringst du pixelgenau ohne über 40 Blind-Gifs hin.Hier liegt eventuell eine Fehlerquelle, die möglicherweise auch Performance kostet.Würde mich langsam mit Layern beschäftigen, mit ein wenig Tricks kommt es auch in NS4.75 zu stimmen.
mfG
Pedrito

[ Diese Nachricht wurde geändert von: pedrito am 2002-02-16 23:03 ]
als Antwort auf: [#733] Top
 
heizfrosch
Beiträge: 67
16. Feb 2002, 23:24
Beitrag #4 von 6
Beitrag ID: #748
Bewertung:
(1516 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

[Problem] Tabellen in NN


Huhu!

Für die korrekte Ansicht im Netscape ist es ebenfalls wichtig, daß man allen (und ich meine allen!) Tabellenzellen für Höhe und Breite irgendeinen Wert zuweist, entweder Pixel oder %. Wenn Du einen Wert partout nicht vorher weißt, dann schreib zum Testen wenigstens 1 Pixel oder so rein, der Browser nimmt sich dann schon den Platz, den er braucht.

Versuchs mal, vielleicht hilfts ja.
heizfrosch
als Antwort auf: [#733] Top
 
Hanü
Beiträge: 219
17. Feb 2002, 03:06
Beitrag #5 von 6
Beitrag ID: #754
Bewertung:
(1516 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

[Problem] Tabellen in NN


Hallo allerseits!


zunächst mal @ gudrun: nein, ich verwende kein Layoutraster. @ pedrito: die Blindgifs sind volle absicht, aber ich hab sie inzwischen reduziert. Layer (meinst du Layoutraster?) möchte ich eigentlich nicht verwenden, davon bin ich abgekommen, da gibts Probleme mit dem Anpassen an die jeweilige Fenstergröße. und schließlich noch @ heinzfrosch: hab ich jetzt mal versucht, aber siehe selbst:


Ich habe mal ganz von vorne mit einer neuen Datei angefangen, in der ich mich mal nur auf das obere Menü konzentriere (zu finden unter [Link entfernt, da Seite nicht mehr vorhanden] ). Und ich weiß jetzt auch endlich, warum meine Tabellen im NN so verschoben sind:

Für die gesamte Tabelle habe ich als Breite 100% angegeben, damit sich die Seite automatisch an das Browserfenster anpasst. Soweit so gut. Dann habe ich der Einfachheit halber die Tabelle von 6x8 auf 4x5 Zellen optimiert und die Grafiken entsprechend neu erstellt. Für 4 der 5 Spalten habe ich eine feste Größe in Pixeln angegeben, die 5. Spalte soll sich eigentlich automatisch an die restliche Fenstergröße anpassen. Das klappt ja im IE wunderbar, aber der NN streikt genau an dieser Stelle. Der NN (in meinem Testfalle NN4.7) kapiert nicht, dass er genau diese eine Spalte in der Breite anpassen soll. Stattdessen macht er die anderen Spalten entweder breiter oder schmäler, wie’s ihm passt.

Ich habe dann mal etwas rumprobiert und festgestellt, dass das Problem nicht auftritt, wenn ich normalen Text in der Spalte ohne Breitenangabe eingebe. Dann habe ich mal für die Breite der Spalte 100% angegeben, was aber natürlich nicht funktioniert hat. Wobei ich dazu sagen muss, dass ich die Seite im Moment soweit habe, dass sie im NN6 (noch) richtig angezeigt wird.

Außerdem hab ich mal euren Rat befolgt und diese Syntaxprüfung durchgeführt, mit den Voreinstellungen für HTML 4.0, NN 4.x und IE 4.x, 5.x. Da kommen bei der momentanen Seite folgende Warnungen: Die Attribute TEXT, ALINK, LINK, VLINK, LEFTMARGIN, MARGINWIDTH, TOPMARGIN, MARGINHEIGHT, BACKGROUND werden in HTML 4.0 nicht unterstützt (die fetten werden in NN 4.x nicht unterstützt und das kursive nicht im IE 4.x/5.x)

Das Seltsame daran: die Meisten dieser Angaben stehen in der BODY-Zeile und werden in GoLive bei den Seiteneinstellungen gemacht. Da frag ich mich doch, warum kann ich so was in GL einstellen, wenn es von HTML4.0 nicht unterstützt wird?!?! Oder stimmt nur die Syntaxprüfung nicht, weil eigentlich werden diese Dinge vom IE/NN 6 richtig interpretiert!? Und was mich am Meisten wundert: warum wird BACKGROUND nicht unterstützt (z.B. für die Zellen)? Eigentlich funktioniert es doch, und da bin ich auch sehr froh drüber! Ich lege die eigentlichen Bilddateien im Hintergrund der Zellen ab und lege in die Zellen ein transparentes GIF, damit die Dateien nicht ganz so einfach zu kopieren sind (hab ich mal wo gelesen und find ich nicht schlecht) bzw. sich automatisch der Fenstergröße anpassen können.

In der GoLive-Hilfedatei, die mitgeliefert wurde, habe ich einen Eintrag zum „Überschreiben der standardmäßigen Syntaxfehlerüberprüfung“ gefunden (unter GoLive 5.0 Hilfe c17ws10.htm) Sollte ich vielleicht da was ändern oder anpassen, damit diese (irrtümlichen???) Fehlermeldungen verschwinden?

Und hat jemand ne Idee, wie ich es hinkriege, dass der NN das mit dieser einen Spalte, die sich automatisch in der Breite anpassen soll, auch noch richtig interpretiert?

THX for all!
Gruß Andreas


[ Diese Nachricht wurde geändert von: Hanü am 2002-03-31 18:48 ]
als Antwort auf: [#733] Top
 
Hanü
Beiträge: 219
17. Feb 2002, 04:30
Beitrag #6 von 6
Beitrag ID: #755
Bewertung:
(1516 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

[Problem] Tabellen in NN


So, hab jetzt nochmal ne ganze Weile rumexperimentiert, hier das Ergebnis:

[Link entfernt, da Seite nicht mehr vorhanden]

Könnt ihr mir sagen, ob ich meinem Ziel jetzt etwas näher bin? Bei mir wird der rechte obere Rand, der eigentlich ca. 20 Pixel breit weiß sein sollte, zu ca. 40 Pixeln vergrößert. aber sonst schein alles wie gewünscht zu funktionieren.

Ich hab jetzt vorerst die Schnauze voll und geh jetzt ins Bett. Gute Nacht!


[ Diese Nachricht wurde geändert von: Hanü am 2002-03-31 18:49 ]
als Antwort auf: [#733] Top
 
X