hilfdirselbst.ch
Facebook Twitter gamper-media

www.quarkuser.net | AppleScript von Hans Haesler | QXP-Fachbücher | Publishing-Events

« « 1 2 » »  
Manfred Löwe
Beiträge: 7
26. Mai 2003, 13:33
Beitrag #1 von 17
Bewertung:
(2220 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hallo liebe Leute,

bei einem Kundensystem mit diversen Macs tritt bei zwei Macs ein Problem beim Laden eines Docs aus dem Netzwerk auf. Der Zugriff erfolgt auf einen Mac OS-X Server Ver. 10.1.3. Die Systeme der Macs haben 9.1.0 und 9.2, mit ATM 4.6.1/ATR 2.6. Installiert ist XPress 4.10r1.
Der User öffnet eine Datei aus einem Netzwerkordner per Doppelklick. Dann dauert es ca. 2 min., bis die Datei in einem Fenster erscheint (links oben blinken ab und zu die Pfeile für'n Netzwerktraffic). Wenn man XPress schliesst und die selbe Datei oder eine andere per Doppelklick öffnet, dauert es nur noch wenige Sekunden! Öffnet man als Erstes eine Datei vom Desktop, dann gehts auch aus dem Netz "ratz fatz"!
Hat da jemand eine Idee, woran das liegt?

Grüsse, Manfred Top
 
X
Thomas Richard  M  p
Beiträge: 17211
26. Mai 2003, 14:13
Beitrag #2 von 17
Beitrag ID: #36973
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hallo Manfred,

vielleicht kann ich dir beim Denken helfen.

Also schaun wir mal:

>Der User öffnet eine Datei aus einem Netzwerkordner per Doppelklick.

Doppelklick bedeutet, suche ine Programm das mit dieser Datei was Anfangen kann und öffne es mit ihr. bzw. starte erst dieses Programm und öffne dann die Datei in dem Programm.

>Wenn man XPress schliesst und die selbe Datei oder eine andere per Doppelklick öffnet, dauert es nur noch wenige Sekunden!

... bis Quark gestartet wird, oder bis das Dokument geöffnet wird.

> Öffnet man als Erstes eine Datei vom Desktop, dann gehts auch aus dem Netz "ratz fatz"!
Wie wird die geöffnet und wie dann die im Netz?

>Hat da jemand eine Idee, woran das liegt?

Für die oben genannten Automatismen sind in erster Linie die Desktop DB und die Ressourcen der Datien zuständig. Wenn die nicht konsistent sind, also nicht mehr genau wissen, wer zu wem gehört, dann geht u.U. die Suche auf der HD oder dem ganzen Server nach geeigneten Kandidaten los.


HTH & MfG

Thomas
als Antwort auf: [#36958] Top
 
Jens Naumann  M 
Beiträge: 5108
26. Mai 2003, 14:18
Beitrag #3 von 17
Beitrag ID: #36978
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Auf einen ähnlichen Gedanken bin ich auch noch gekommen. XPress 4 ist ja Dongle-geschützt. Ich habe mich gefragt, ob dieser sofort gefunden wird, da ja dann alles reibungslos funktioniert, sobald das Programm einmal gestartet ist.

Grüßle,
Jens

---
j.naumann@verlag-straubinger.de
als Antwort auf: [#36958] Top
 
Manfred Löwe
Beiträge: 7
26. Mai 2003, 15:14
Beitrag #4 von 17
Beitrag ID: #37001
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hallo Thomas, hallo Jens,

danke für die rasche Antwort.
Ich werde das Vorgehen etwas präzisieren:

* 1. Versuch: Öffnen des Netzwerkordners, Doppelklick auf die XPress-Datei. Dann wird erst XPress gestartet (dauert ca. 30 sec), dann das Doc geöffnet. Dieses Öffnen des Docs benötigt dann etwa 2 min.

* 2. Versuch: Netzwerkordner immer noch offen. XPress-Programm wieder geschlossen.
Doppelklick auf die XPress-Datei. XPress wird gestartet (ca. 30 sec), dann das Doc geöffnet. Dieses Öffnen braucht jetzt nur wenige Sekunden!

* 3. Versuch: Neustart des Powermac, dann Anmelden am Server und Öffnen des Netzwerkordners.
Jetzt wird erst Programm XPress gestartet (ca. 30 sec), dann erfolgt Doppelklick auf die Datei im Netzwerkordner. Wieder dauert es ca. 2 Min. Diese Datei schliessen (Programm ist noch geladen), per Doppelklick nochmal in das bereits geöffnete XPress laden: benötigt nur wenige Sekunden.

Was ich noch nicht getestet habe: Erst Xpress öffnen, dann Doc mit dem Öffnen-Dialog des Programmes laden.

Noch ein paar Infos:
Der Netzwerkordner liegt auf einem RAID-System des OS-X Servers. Die Größe beträgt 50 GB, die Hälfte davon ist bereits belegt mit Userdaten (vorwiegend Xpress-Docs, Tiffs, Freehand-Docs).

Der Trick mit dem Doc vom Desktop ist: Erst Doppelklick darauf, XPress braucht 30 sec., die Datei erscheint danach nahezu sofort in einem XPressfenster. Ein Doppelklick auf eine Datei aus dem Netzwerk verursacht dann keine 2-Min-Verzögerung mehr!

Mfg, Manfred

als Antwort auf: [#36958] Top
 
Thomas Richard  M  p
Beiträge: 17211
26. Mai 2003, 15:27
Beitrag #5 von 17
Beitrag ID: #37004
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hallo Manfred,

das war mir eigentlich alles soweit klar...

also nochmal
[beim denken helf]
Wenn Quark läuft, aber vom sServer noch keine Datei per eindeutiger zuordnuung (Menue öffnen oder Drag& Drop) geöffnet wurde, versucht der Rechner audf der HD oder im Netz ein Programm zu finden. Wenn erst mal eine Datei des entsprechenden Typs geöffnet wurde, geht's schnell.

Das bedeutet für mich, das die aktuelle Desktop DB im RAM um die entsprechenden Einträge erweitert wird, sie aber nbbeim ausschalten nicht aktualisiert wird.
Daher erstmal Dekstop neu anlegen!
[/beim denken helf]

MfG

Thomas
als Antwort auf: [#36958] Top
 
Oliver Wendtland S
Beiträge: 726
26. Mai 2003, 15:28
Beitrag #6 von 17
Beitrag ID: #37005
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Kann es irgentwas mit Schriften zutun haben, die beim ersten Mal von XPress und der Suitcase XT geöffnet werden?

Oliver Wendtland
Druckerei und Verlag
H. Bösmann GmbH
Detmold
_________________________________
Ich habe mich nicht verirrt. Ich bin nur ... richtungsmäßig herausgefordert.
als Antwort auf: [#36958] Top
 
Manfred Löwe
Beiträge: 7
26. Mai 2003, 18:16
Beitrag #7 von 17
Beitrag ID: #37054
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hallo zusammen,

das mit der Desktopdatei leuchtet ein, habe ich noch nicht neu aufgebaut. Beim nächsten Kundenbesuch werde ich das mal testen.

Insofern auch eine mögliche Fehlerquelle, hatte mal das Problem, dass beim Doppelklick auf ein Doc immer etwas aus dem Netz gestartet wurde (bei einem anderen Kunden). Das war dann tatsächlich ein Backup von einem Xpress-Ordner, aus dem heraus das Programm geöffnet wurde (statt vom lokalen Programmordner). Ein Desktop-Neuaufbau und Öffnen einer lokalen Datei behob den Fehler. Aus diesem Grund sollte man solche Backups in ein Archiv packen, da der Mac "sehr selbständig" beim Suchen von Programmen ist.

Ob das an den Schriften auch liegen kann, konnte ich nicht nachvollziehen. Bei dem aktuellen Mac waren aber nur relativ wenige geladen (ca. 50 Schnitte), und der Schriftenordner ist lokal abgelegt.

Noch eine andere Frage: Gibt es etwas Ähnliches für den Mac wie den "Filemonitor" von Sysinternals für Windows? Mit diesem könnte man doch derlei Dateiaktivitäten im Netz verfolgen und evtl. Rückschlüsse ziehen!

Mfg Löwe
als Antwort auf: [#36958] Top
 
Conny
Beiträge: 2914
28. Mai 2003, 10:25
Beitrag #8 von 17
Beitrag ID: #37304
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hi Leute,

ich sehe da noch weitere Punkte. Grundsätzlich ist es nicht der goldene Weg eine Datei mit Doppelklick zu öffnen. Der Computer greift sich denn unkontrolliert irgendein Programm und ich als User kann nicht wissen welches, im Fall von Quark ist das bei mehreren Versionen immer die jüngste.
Wie ist denn die Netzwerkkonfiguration des Rechners geartet. Es könnte nämlich auch sein, dass die ersten Netzwerkpakete "aneinander vorbeirauschen". Bei DHCP-Konfigurationen passieren solche Missgeschicke manchmal. Auch kann es sein, dass der Rechner zuerst versucht über IP zu verbinden, das aber dann nicht realisieren kann und somit per AppleTalk verbindet. Das dauert dann ein wenig, aber in der Folge steht die Verbindung und somit funzt das Netzwerk zwar langsamer, aber ohne längere Wartezeiten.
Ich denke mal das solltest Du als erstes überprüfen.

Gruß
Conny
--
mailto
cornelius.hoffmann@cicero-point.net
web
http://www.cicero-point.net
als Antwort auf: [#36958] Top
 
Manfred Löwe
Beiträge: 7
28. Mai 2003, 15:05
Beitrag #9 von 17
Beitrag ID: #37358
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hallo Conny,

der Powermac bekommt seine IP-Adresse per DHCP von einem Router von ELSA (Microlink DSL/I-10). Laut Symbol und Eigenschaften der Netzwerkvolumes ist er verbunden über TCP/IP (was bei einem Mac OS-X Server ja auch die einzige Möglichkeit ist; anders wie bei Apple Share IP 6).
Eine Alternative wäre noch, dass man den DHCP-Server vom ELSA-Router auf den OS-X Server "verlagert". Auch das müsste ich noch testen.

Grüsse,
Manfred
als Antwort auf: [#36958] Top
 
Conny
Beiträge: 2914
1. Jun 2003, 13:35
Beitrag #10 von 17
Beitrag ID: #37739
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hi Manfred,

wenn DHCP funzt brauchst Du sicherlich nichts umstellen. Ich würde eher probieren, wie die Kiste sich mit einer manuell vergebenen IP verhält. Genauso würde ich in diesem Moment die Laufwerke neu mounten und dann das ganze noch einmal ausprobieren.
Das was Du beschrieben hast, deutet einfach darauf hin, dass der Clientrechner den Server unter dem angegebenen Pfad nicht findet und dann quasi einen anderen Weg sucht und in Deinem Fall auch findet. Das ist das, was dann dauert. Später ist der Pfad vorhanden und deswegen läuft die Kommunikation zwischen Server und Client in einem angemessenen Zeitansatz.
Sorry - das alles ist jetzt ein wenig flapsig erklärt, aber anders wusste ich mir gerade nicht zu helfen.
Ich hoffe das Dich das jetzt etwas weiter bringt.

Gruß
Conny
--
mailto
cornelius.hoffmann@cicero-point.net
web
http://www.cicero-point.net
als Antwort auf: [#36958] Top
 
Dave Uhlmann
Beiträge: 1938
2. Jun 2003, 11:27
Beitrag #11 von 17
Beitrag ID: #37834
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Eine kleine Anmerkung zum Thema Schreibtischdatei neu anlgenen:

Wenn man die Apple-eigene Version beim Starten Alt-Apfel drücken benutzt, werden fehlende Ressourcen nur HINZUGEFÜGT. Will man die Schreibtischdatei komplett neu anlegen lassen, hilft der Einsatz von Techtool Lite (http://www.micromat.com), das nichts anderes macht, als die Desktop DB und DF löscht. Ist auf jeden Fall der Apple-eigenen Variante vorzuziehen. Ich habe damit aber dann die Erfahrung gemacht, dass man dann das ganze zwei-dreimal machen kann, wenn u.U. Symbole noch immer generisch erscheinen, also mit der systemeigenen Ikone für Programme usw.


-- David Uhlmann (david@wissen-wie.ch)

[Mac OS X Integration & Schulung]
als Antwort auf: [#36958] Top
 
Manfred Löwe
Beiträge: 7
5. Jun 2003, 08:45
Beitrag #12 von 17
Beitrag ID: #38297
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hallo David,

war gestern wieder beim Kunden, da nach einer Woche einwandfreiem Betrieb auf einmal wieder dieser Delay auftritt. Kunde startet XPress, öffnet aus dem XPress eine Datei,....dann kommt die Sanduhr und auch nach 5 Min. hat sich nix geändert. Den Mac kann man dann nur noch abwürgen und neu starten.
Mit Techtool habe ich die Desktop DB und DF gelöscht und auf beiden Volumes (eins fürs System ["System und Programme"] und ein zweites als Working-Vol ["Anwendungsdaten"]) nach jeweils einem Neustart die Desktopdateien neu anlegen lassen. Habe ausserdem im Ordner "Systemordner:Server" die angelegten Links für die autom. Anmeldung an den Servervolumes gelöscht. Ein erster Test verlief dann erfolgreich.
Was mir noch auffiel: Für Backupzwecke habe ich auf dem zweiten lokalen Volume "Anwendungsdaten" einen Systemordner. Dessen Datum/Uhrzeit der letzten Änderung hatte immer einen aktuellen Wert, heisst für mich also, das das System irgendetwas darin verändert hat. Es ist aber nicht der aktive Systemordner! Habe ihn dann in ein Stuffit-Archiv verpackt und anschl. gelöscht. Kann ein zweiter Systemordner auf einem anderen als dem aktiven Volume auch Fehler verursachen?

Sonnige Grüsse, Manfred
als Antwort auf: [#36958] Top
 
Anonym
Beiträge: 22827
6. Jun 2003, 10:02
Beitrag #13 von 17
Beitrag ID: #38485
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hi Leuts,

ich hatte das gleiche Problem mit dem lahmen laden einer ersten QX-Datei.

Aber seit QSX Server 10.2 (mittlerweile 10.2.5) gibts das nicht mehr. Alle QX-Docs laden, egal wie geöffnet, "ratz fatz" ;-))

Ursache unter 10.1.x konnte mir damals auch keiner beantworten. Unser Händler stand ebenfalls auf dem Schlauch. Dafür hat er uns dann 10.2 spendiert, und siehe da: Prima.

Joachim Potdevin
als Antwort auf: [#36958] Top
 
Dave Uhlmann
Beiträge: 1938
6. Jun 2003, 10:27
Beitrag #14 von 17
Beitrag ID: #38491
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hallo Manfred

Nun, ein zweiter Systemordner macht dem System eigentlich nichts, es sei denn, die Programme greifen kreuz und quer auf Komponenten der verschiedenen Ordner zu. Ist aber eigentlich NUR bei PPDs möglich alle anderen haben, wenn der Systemordner nicht aktiv ist, keine weitere Bedeutung für den Mac, sind ganz normale Ordner. Ich würde vorschlagen, dass Du von den alten Systemen eine Disk-Image machst, am Besten mit Disk Copy, dann sind die Bestandteile "verpackt" und man kann sie trotzdem per Doppelklick aktivieren und gleich durchforsten.



-- David Uhlmann (david@wissen-wie.ch)

[Mac OS X Integration & Schulung] http://www.wissen-wie.ch
als Antwort auf: [#36958] Top
 
Conny
Beiträge: 2914
6. Jun 2003, 13:34
Beitrag #15 von 17
Beitrag ID: #38553
Bewertung:
(2216 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

2 min Verzögerung beim Laden eines Docs aus dem Netz


Hallo nochmal,

das erneute Auftreten des Fehlers nun nur mit einer längeren Wartezeit macht für mich meine Theorie eigentlich immer wahrscheinlicher.
Hast Du denn irgendetwas in diese Richtung probiert Manfred?

@Joachim
ich könnte mir gut vorstellen, dass Du mit 10.1 ein Problem in der Userstruktur hattest, genau das ist nämlich in "Jaguar" deutlich verbessert worden.

Ich hoffe ich konnte ein wenig positives zu dieser Diskussion beitragen.

Gruß
Conny
--
mailto
cornelius.hoffmann@cicero-point.net
web
http://www.cicero-point.net
als Antwort auf: [#36958] Top
 
« « 1 2 » »  
X