hilfdirselbst.ch
Facebook Twitter gamper-media

"Geht nicht" ist keine gültige Fehlermeldung!

mc-schmitz
Beiträge: 91
15. Jul 2002, 13:14
Beitrag #1 von 8
Bewertung:
(1331 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht


Hallo

Ich habe ein Perl Script im einsatz, das läuft auf meinem Account leider nicht, aber auf einem anderen Server läuft es
ohne Probleme.

Was kannd as Problem sein??? Kann es an der Perl Version auf dem Server liegen???

Gruß Mc-Schmitz Top
 
X
SabineP  M 
Beiträge: 7586
15. Jul 2002, 13:48
Beitrag #2 von 8
Beitrag ID: #7268
Bewertung:
(1331 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht


Hallo Mc-Schmitz, das kann viele verschiedene Gründe haben:
unterschiedliche Webserverkonfiguration, Perl-Versionen, installierte Perl-Module, Pfade, Ausführungsrechte.
Wie äußert sich denn der Fehler? Gibts eine Fehlermeldung?
als Antwort auf: [#7262] Top
 
mc-schmitz
Beiträge: 91
15. Jul 2002, 14:24
Beitrag #3 von 8
Beitrag ID: #7272
Bewertung:
(1331 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht


Das ist der Fehler

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, root@linux.local and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Es ist übrigens das Kalenderwochenscript von dir. AUf meinem Testserver ist es wunderbar gelaufen, aber auf meiner Homepage läuft es überhaupt nicht, rechte sollten aber passen. 755 sollte doch ausreichen.

Danke für deine schnelle Antwort

Mc-Schmitz
als Antwort auf: [#7262] Top
 
SabineP  M 
Beiträge: 7586
15. Jul 2002, 15:08
Beitrag #4 von 8
Beitrag ID: #7279
Bewertung:
(1331 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht


Teste mal folgendes Script:

#!/usr/bin/perl
print "Content-type: text/html\n\n";
print "Hello world";

Im Browser muß nach Aufruf "Hello world" erscheinen.
als Antwort auf: [#7262] Top
 
mc-schmitz
Beiträge: 91
15. Jul 2002, 15:16
Beitrag #5 von 8
Beitrag ID: #7281
Bewertung:
(1331 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht


Hi

Da kommt genau der gleiche Fehler

Gruß Mc-Schmitz
als Antwort auf: [#7262] Top
 
SabineP  M 
Beiträge: 7586
15. Jul 2002, 15:26
Beitrag #6 von 8
Beitrag ID: #7286
Bewertung:
(1331 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht


Ich nehme an, Du hast das Testscript im Ascii-Modus übertragen und mit chmod 755 die Rechte gesetzt.
Wie lautet denn der Pfad zu Perl bei Deinem Provider?
Vielleicht ist der Pfad so eingerichtet:
#!/usr/local/bin/perl


[ Diese Nachricht wurde geändert von: SabineP am 2002-07-15 15:28 ]
als Antwort auf: [#7262] Top
 
oesi50  A  S
Beiträge: 2315
15. Jul 2002, 15:29
Beitrag #7 von 8
Beitrag ID: #7287
Bewertung:
(1331 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht


hi,
speicher mal in dem Verzeichnis eine
.htaccess Datei mit folgendem Inhalt
----schnipp--------------
Options +ExecCGI
AddHandler cgi-script pl cgi
----schnapp--------------

Fragen:
Wer hat den Webserver configuriert?
Läßt sich da noch was machen?


[ Diese Nachricht wurde geändert von: oesi50 am 2002-07-15 15:31 ]
als Antwort auf: [#7262] Top
 
mc-schmitz
Beiträge: 91
16. Jul 2002, 08:05
Beitrag #8 von 8
Beitrag ID: #7329
Bewertung:
(1331 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht


Hallo

mitlerweile funktioniert es wunderbar, ich mußte meinen Account auf dem Server löschen und neu erstellen. Komisch, nicht mal der Provider konnte mir sagen an was es lag.

Gruß Mc-Schmitz

Danke für eure Hilfe
als Antwort auf: [#7262] Top
 
X