hilfdirselbst.ch
Facebook Twitter gamper-media

Linkliste für Browser und CSS zusammengetragen von ganesh

Anonym
Beiträge: 22827
29. Mai 2004, 20:11
Beitrag #1 von 6
Bewertung:
(1206 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Browser-Problem: Netscape 7.1 interpretiert meine Seite anders als Explorer.


Wer weiss wie ich dieses Problem lösen kann? Ist das mit CSS möglich?

Dann habe ich noch ein 2. Problem:
Auflösung: Meine Auflösung ist 1280x1024. Ich habe gehört, dass viele aber noch die Auflösung 1024x768 benutzen. Habe deshalb versucht die Margins wie folgt zu definieren:

body {background-color:#FFFFCC;
margin-left:12%;margin-right:12%;}

Funktioniert aber nicht....der Shop ist nur bei 1024x768 zentriert...je höher die Auflösung desto mehr verschiebt sich der Shop nach links....(d.h. beim Explorer....bei Netscape ist eh nur die 1. Seite zentriert...die anderen Seiten sind alle Links...ausserdem kann Netscape offenbar meine "background-color" nicht lesen....

Probleme über Probleme....bin ein Greenhorn, ich weiss.....kann mir jemand helfen?



Top
 
X
Anonym
Beiträge: 22827
29. Mai 2004, 20:15
Beitrag #2 von 6
Beitrag ID: #88007
Bewertung:
(1206 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Browser-Problem: Netscape 7.1 interpretiert meine Seite anders als Explorer.


PS: hier meine Webseite für den Browsertest (Explorer+Netscape 7.1)

http://www.stamptrader.ch
als Antwort auf: [#88006] Top
 
Dirk Levy  A 
Beiträge: 9235
29. Mai 2004, 20:45
Beitrag #3 von 6
Beitrag ID: #88009
Bewertung:
(1206 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Browser-Problem: Netscape 7.1 interpretiert meine Seite anders als Explorer.


Dein Quellcode ist auch murks....

Z.B.:
<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
und weiter unten:
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">

Ja was denn nun, welchen Zeichensatz soll es denn benutzen?

Dann fehlt der Doctype des Hauptframes, sollte z.B. so sein
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN">

Und was soll das sein:
<frame name="header" scrolling="no" noresize target="main" src="briefmarken.htm">
Ein Framebestandteil mit dem Namen header und einem target auf
main, das gehört da nicht hin und ist falsch.

<frame name="main" src="http://www.stamptrader.ch/default.html">

Schau mal bei Selfhtml vorbei und lass Deine Seite
im Internet checken, dann wirst Du dem Problem auf die
Schliche kommen.

Gruß
Dirk

[Adobe GoLive Tipps & Tricks]
http://www.gltipps.de
als Antwort auf: [#88006] Top
 
SabineP  M 
Beiträge: 7586
29. Mai 2004, 20:54
Beitrag #4 von 6
Beitrag ID: #88011
Bewertung:
(1206 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Browser-Problem: Netscape 7.1 interpretiert meine Seite anders als Explorer.


Hallo Anonym,

in Deinem Quellcode befinden sich zahlreiche Fehler.http://www.stamptrader.ch/projuventute/index.html

Tabellen kann man sehr einfach zentrieren mit dem Attribut align="center".

Deine CSS-Datei enthält auch Fehler
http://www.stamptrader.ch/assets/s.css

Das gehört da nicht rein:

<link rel="stylesheet" href="/style.css" type="text/css">
<style type="text/css">
<!--
</style>
</head>
<body>

Gruß Sabine
als Antwort auf: [#88006]
(Dieser Beitrag wurde von SabineP am 29. Mai 2004, 20:55 geändert)
Top
 
Anonym
Beiträge: 22827
29. Mai 2004, 21:22
Beitrag #5 von 6
Beitrag ID: #88014
Bewertung:
(1206 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Browser-Problem: Netscape 7.1 interpretiert meine Seite anders als Explorer.


Dirk

Habe den Doctype der anderen Seiten ins Frame eingefügt. Ebenfalls habe ich ein Charset gelöscht. Das andere, wo du gefragt hast, was das sein soll….kann ich dir auch nicht genau sagen…nur, wenn es gelöscht wird, dann kann ich meine Seite nicht mehr laden……

Sabine

Wenn ich <style type="text/css"> <!-- dann werden die folgeseiten nicht mehr zentriert dargestellt und die backgroundcolor fällt dann raus…(es sieht dann beim Explorer aus wie bei Netscape 7.1) Also darf ich es vorerst nicht löschen….

</head> <body> habe ich gelöscht. Danke für den Hinweis. Werde jetzt noch eure Links studieren….
als Antwort auf: [#88006] Top
 
SabineP  M 
Beiträge: 7586
29. Mai 2004, 21:41
Beitrag #6 von 6
Beitrag ID: #88015
Bewertung:
(1206 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Browser-Problem: Netscape 7.1 interpretiert meine Seite anders als Explorer.


>> Wenn ich <style type="text/css"> <!-- dann werden die folgeseiten nicht mehr zentriert dargestellt und die
>> backgroundcolor fällt dann raus…(es sieht dann beim Explorer aus wie bei Netscape 7.1) Also darf ich es vorerst nicht
>> löschen….

Hallo Anonym,

dann wirst Du weiterhin in allen anderen Browsern über diesen Fehler stolpern.
Der IE sollte nicht als Referenzbrowser verwendet werden, da er selbständig versucht Deine Fehler zu korrigieren.

Gruß Sabine
als Antwort auf: [#88006] Top
 
X