hilfdirselbst.ch
Facebook Twitter gamper-media
Tipps und Tricks zu Adobe GoLive von Dirk Levy, GoLive FAQ's von Randolph Sterna
Anonym
Beiträge: 22827
18. Mär 2002, 23:09
Beitrag #1 von 7
Bewertung:
(1059 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Fehler 500 nach Aktualisierung des Formmailers


Nabend!

...Was habe ich getan???

Ich habe eigentlich nur das bestehende Skript um weitere Domains ergänzt,
die den Formmailer unter http://www.raute-media.de/specials/email.pl ebenfalls
nutzen können - danach kommt nur noch der Fehler 500. (Skript kann nicht
fehlerfrei ausgeführt werden)

Beispiel: http://www.plake-baumaschinen.de (rechter Button)

Das Skript liegt bei Puretec und ist als Ascii hochgeladen worden. Rechte
liegen für Eigentümer "lesen, schreiben, ausführen" und für Gruppe und
andere bei "lesen, ausführen". Die jeweiligen Formulare sind nicht verändert
worden und verweisen richtig auf die Datei.

Könnt Ihr mir bitte helfen? Ich habe schon versucht, das Original der Datei
hochzuladen - aber auch das kann nicht ausgeführt werden.

Wo liegt mein Fehler???

Vielen Dank für Eure Hilfe.

PHIL-le Grüße und besten Dank.

Top
 
X
Ollli
Beiträge: 458
18. Mär 2002, 23:42
Beitrag #2 von 7
Beitrag ID: #1671
Bewertung:
(1059 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Fehler 500 nach Aktualisierung des Formmailers


du musst das script im cgi-bin liegen haben und außerdem auch eigene CGIs benutzen dürfen.
Es werden nur im CGI-BIN CGI/Perl-Skripte ausgeführt und natürlich auch nur, wenn du eigene CGI/Perl-Scripte ausführen darfst.
Ob du darfst hängt von deinem Paket ab.
Es müssen "Eigene CGIs" enthalten sein -> schau einfach mal in deine Paketbeschreibung!

Ollli
als Antwort auf: [#1669] Top
 
Dirk Levy  A 
Beiträge: 9214
18. Mär 2002, 23:52
Beitrag #3 von 7
Beitrag ID: #1673
Bewertung:
(1059 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Fehler 500 nach Aktualisierung des Formmailers


Hi,

soweit ich weiß sollen solche Sachen
binär übertragen werden.
Versuch es mal....

Gruß
Dirk
als Antwort auf: [#1669] Top
 
Anonym
Beiträge: 22827
19. Mär 2002, 06:58
Beitrag #4 von 7
Beitrag ID: #1676
Bewertung:
(1059 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Fehler 500 nach Aktualisierung des Formmailers


Wie gesagt: ... es hat ja eigentlich alles vorher schon funktioniert!

Natürlich darf ich bei meinem Puretec-Paket nach wie vor eigene Skripte ausführen, die Übertragungsart habe ich zwischenzeitlich auch schon geändert - ohne Erfolg.

Wenn ich mich recht entsinne, muß bei Puretec nicht zwingend dieser "cgi-bin"-Ordner liegen. Ein 'normaler' Ordner ist da schon ok.

Trotzdem versuche ich den Lösungsvorschlag gerne auch noch.....
Hat jemand denn noch eine andere Lösung? - Ich glaube nämlich nicht, dass da der Fehler ist.

Vielen Dank für Eure Hilfe.

PHIL
als Antwort auf: [#1669] Top
 
Ollli
Beiträge: 458
19. Mär 2002, 17:18
Beitrag #5 von 7
Beitrag ID: #1721
Bewertung:
(1059 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Fehler 500 nach Aktualisierung des Formmailers


!-- BBCode Quote Start -->
Zitat:
soweit ich weiß sollen solche Sachen
binär übertragen werden.
Versuch es mal....
Das wäre was ganz neues für mich, ich arbeite schon länger mit Perl & Co. und übertrage immer mit ASCII.
Das hatte ich noch vergessen zu sagen, immer ASCII übertragen, nicht binär!

Ollli

[ Diese Nachricht wurde geändert von: Ollli am 2002-03-19 17:22 ]
als Antwort auf: [#1669] Top
 
Ollli
Beiträge: 458
19. Mär 2002, 17:24
Beitrag #6 von 7
Beitrag ID: #1724
Bewertung:
(1059 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Fehler 500 nach Aktualisierung des Formmailers


Haste die Scripte auch ausführbar gemacht, sprich auf 0755 gesetzt und beteiligte Dateien wenn nötig auf 0777?

Und dann schau mal hier, fals du es noch nicht getan hast
http://faq.puretec.de/skripte/perl/4.html

Ollli

[ Diese Nachricht wurde geändert von: Ollli am 2002-03-19 17:26 ]
als Antwort auf: [#1669] Top
 
Kusi
Beiträge: 1398
23. Mär 2002, 11:29
Beitrag #7 von 7
Beitrag ID: #1859
Bewertung:
(1059 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Fehler 500 nach Aktualisierung des Formmailers


Hier vielleicht noch ein kleiner Hinweis:

* One of the .cgi files returns 500 Internal Server Error
* Make sure you've changed the first line of the file to #! and
then the path to perl on your system
* Make sure you've uploaded the file as ascii, not binary.
* Make sure you've set the permissions for the file to 755.
als Antwort auf: [#1669] Top
 
X