hilfdirselbst.ch
Facebook Twitter gamper-media
Tipps und Tricks zu Adobe GoLive von Dirk Levy, GoLive FAQ's von Randolph Sterna
Siggi BW
Beiträge: 10
20. Mär 2004, 18:25
Beitrag #1 von 8
Bewertung:
(2074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Frameset Navigation: Neue Seite öffnet im falschen Frame


GL 6.0
Halo,

ich bin gerade dabei, ein neue HP zu erstellen.

!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>

<head>
<meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
<meta name="generator" content="Adobe GoLive 6">
<title>big fashion and art</title>
</head>

<frameset cols="130,*">
<frame name="Menue" noresize src="menue.html">
<frameset rows="130,*">
<frame name="Banner" noresize src="banner.html">
<frame name="Start" noresize src="start.html">
</frameset>
<noframes>

<body bgcolor="#ffffff">
<p></p>
</body>

</noframes>
</frameset>
</html>

Die menue.html soll die Navigationsspalte sein. Die dort eingesetzten Links öffnen sich aber alleine (verlasse den Frameset) und nicht im Tausch mit der start.html. Was mache ich falsch?

Grüße vom Ländle Top
 
X
Kusi
Beiträge: 1398
20. Mär 2004, 18:36
Beitrag #2 von 8
Beitrag ID: #76036
Bewertung:
(2074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Frameset Navigation: Neue Seite öffnet im falschen Frame


Hi Siggi
so lässt sich nicht viel sagen, da ja die Links in der menue.html Seite sind und diesen Code müsste ich (und wohl auch die anderen) sehen. Eines vorweg, der Doc Type sollte:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN">

so sein. Und nimm doch bitte den Meta Tag.
<meta name="generator" content="Adobe GoLive 6">
raus. Das finde ich immer so schlimm.....

Also zeig mal den Code von menue.html

Gruss
Kusi

http://www.k-k.ch
als Antwort auf: [#76035]
(Dieser Beitrag wurde von Kusi am 20. Mär 2004, 18:37 geändert)
Top
 
Siggi BW
Beiträge: 10
20. Mär 2004, 18:55
Beitrag #3 von 8
Beitrag ID: #76038
Bewertung:
(2074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Frameset Navigation: Neue Seite öffnet im falschen Frame


Hallo Kusi,

danke für den Tipp,
ich habe die Quelltext von Webbook kopiert, aber ich habe wohl nicht alles richtig gemacht.

<html>
<head><base target="main">
<title>Menue</title>
</head>



<body bgcolor="#ffffff">
<p><img src="logo.gif" alt="" height="167" width="100" border="0"><br>
<br>
<br>


<script language="JavaScript" type="text/javascript">
<!--

Normal1 = new Image();
Normal1.src = "BtStartseite.gif.";
Hover1 = new Image();
Hover1.src = "BtStartseite1.gif";


Normal2 = new Image();
Normal2.src = "BtSortiment.gif";
Hover2 = new Image();
Hover2.src = "BtSortiment1.gif";

Normal3 = new Image();
Normal3.src = "BtEvents.gif";
Hover3 = new Image();
Hover3.src = "BtEvents1.gif";


Normal4 = new Image();
Normal4.src = "BtKontakt.gif";
Hover4 = new Image();
Hover4.src = "BtKontakt1.gif";

Normal5 = new Image();
Normal5.src = "GuV.gif";
Hover5 = new Image();
Hover5.src = "GuV.gif";



function Bildwechsel(Bildnr,Bildobjekt)
{
window.document.images[Bildnr].src = Bildobjekt.src;
}
//-->
</script>


<a href="start.html" onMouseOver="Bildwechsel(1,Hover1)" onMouseOut="Bildwechsel(1,Normal1)" target="start"><img src="BtStartseite.gif" border=0 alt="Start"></a><br>

<a href="sortiment.html" onMouseOver="Bildwechsel(2,Hover2)" onMouseOut="Bildwechsel(2,Normal2)" target="start"><img src="BtSortiment.gif" border=0 alt="Starke Marken"></a><br>


<a href="produkte.html" onMouseOver="Bildwechsel(3,Hover3)" onMouseOut="Bildwechsel(3,Normal3)" target="start"><img src="BtEvents.gif" border=0 alt="Veranstaltungen und mehr"></a><br>


<a href="kontakt.html" onMouseOver="Bildwechsel(4,Hover4)" onMouseOut="Bildwechsel(4,Normal4)" target="start"><img src="BtKontakt.gif" border=0 alt="Kontaktseite"></a><br>

<a href="gloriaundvolker.html" onMouseOver="Bildwechsel(5,Hover5)" onMouseOut="Bildwechsel(5,Normal5)" target="start"><img src="GuV.gif" border=0 alt="Musik"></a><br>

</p>
</body>

</html>
Grüße vom Ländle
als Antwort auf: [#76035] Top
 
Kusi
Beiträge: 1398
20. Mär 2004, 19:00
Beitrag #4 von 8
Beitrag ID: #76039
Bewertung:
(2074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Frameset Navigation: Neue Seite öffnet im falschen Frame


Hi
Gib mal dem Link Start, statt target="start" Gross- und Kleinschreibung beachten.....
Kusi

http://www.k-k.ch
als Antwort auf: [#76035] Top
 
Siggi BW
Beiträge: 10
20. Mär 2004, 19:05
Beitrag #5 von 8
Beitrag ID: #76040
Bewertung:
(2074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Frameset Navigation: Neue Seite öffnet im falschen Frame


Die start.html öffnet sich immer noch alleine
Grüße vom Ländle
als Antwort auf: [#76035] Top
 
SabineP  M 
Beiträge: 7586
20. Mär 2004, 20:18
Beitrag #6 von 8
Beitrag ID: #76044
Bewertung:
(2074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Frameset Navigation: Neue Seite öffnet im falschen Frame


Siggi,
lösche mal noch <base target="main">
aus dem <head>

Gruß Sabine
als Antwort auf: [#76035] Top
 
Siggi BW
Beiträge: 10
20. Mär 2004, 20:27
Beitrag #7 von 8
Beitrag ID: #76045
Bewertung:
(2074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Frameset Navigation: Neue Seite öffnet im falschen Frame


ohne Erfolg brr
Grüße vom Ländle
als Antwort auf: [#76035] Top
 
SabineP  M 
Beiträge: 7586
20. Mär 2004, 20:31
Beitrag #8 von 8
Beitrag ID: #76047
Bewertung:
(2074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Frameset Navigation: Neue Seite öffnet im falschen Frame


Siggi, dann poste mal die URL.
Gruß Sabine
als Antwort auf: [#76035] Top
 
X