hilfdirselbst.ch
Facebook Twitter gamper-media
Skripte-Sammlung zu HELIOS von Axel Rose
jenzibenzi
Beiträge: 5
17. Mär 2017, 14:54
Beitrag #1 von 8
Bewertung:
(1482 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Helios wirft Volumes unter OSX aus - Windows Netzwerkpfad nicht gefunden


Hallo zusammen,

ich habe ein eingenartiges Problem.

Zur Situation:
2 Server mit Helios, einmal UB2(Hostsystem RHEL 6) und einmal UB64 (Hostsystem CentOS7). Wir haben Macclients und auch Windows7 Clients.

1. Server mit RHEL 6 und UB2 läuft einwandfrei
2. Server mit CentOS und UB64 ist mit den gleichen Einstellungen installiert. Benutzer können sich von beiden Systemem (Windows und MacOS) mit beiden Servern verbinden (per DNS Name oder IP)

Nun kommt das Problem (ist nur auf dem CentOS/UB64 Server), wenn ich unter Windows ein Netzlaufwerk erstelle, dann funktioniert es auch zuerst. Starte ich den Rechner neu, dauert es eine Weile bis der Windows Explorer angesprochen werden kann -> Fehler: "Netzwerkpfad kann nicht gefunden werden" oder "Der lokale Gerätename wird schon verwendet" (das tritt bei beiden Varianten auf einmal DNS-Name und einmal IP).

Unter MacOS werden die Volumes noch unbestimmter Zeit ausgeworfen.

Hat jemand eine Idee wo ich nach dem Fehler suchen kann? Oder hat jemand schon einmal den gleichen Fehler gehabt und ihn gelöst bekommen?

Oder einfach eine zweite RHEL Instanz installieren?
(Dieser Beitrag wurde von jenzibenzi am 17. Mär 2017, 14:59 geändert)
Top
 
X
GreatOm
Beiträge: 366
20. Mär 2017, 10:13
Beitrag #2 von 8
Beitrag ID: #556418
Bewertung:
(1425 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Helios wirft Volumes unter OSX aus - Windows Netzwerkpfad nicht gefunden


Moin!

Ich denke mal das Linux ist hier unschuldig, da CentOS doch auch RedHat basierend ist…

Ansonsten kann man mit dieser Fehlerbeschreibung nicht viel anfangen.

Ich würde mal folgendes prüfen:
- sind die aktuellen UB64 Updates installiert?
- gibt es irgendwelche Systemmeldungen von den HELIOS Diensten?

Gruß,

GreatOm
--
Five exclamation marks, the sure sign of an insane mind. -- (Terry Pratchett, Reaper Man)
als Antwort auf: [#556390] Top
 
jenzibenzi
Beiträge: 5
20. Mär 2017, 13:08
Beitrag #3 von 8
Beitrag ID: #556423
Bewertung:
(1399 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Helios wirft Volumes unter OSX aus - Windows Netzwerkpfad nicht gefunden


Hi, danke erstmal für die Antwort.

updates sind alle installiert.

Systemmeldungen der letzten Stunde:
Mon Mar 20 12:10:01 CET 2017 cron helios2 CROND[30135]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Mon Mar 20 12:10:10 CET 2017 messages helios2 pcshare[2680]: unauthorized request SMBecho($2b) from client 192.168.0.211 rejected; state: 2
Mon Mar 20 12:10:10 CET 2017 messages helios2 pcshare[2680]: unauthorized request SMBtconX($75) from client 192.168.0.211 rejected; state: 2
Mon Mar 20 12:20:01 CET 2017 cron helios2 CROND[30291]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Mon Mar 20 12:25:01 CET 2017 cron helios2 CROND[30349]: (pcp) CMD ( /usr/libexec/pcp/bin/pmlogger_check -C)
Mon Mar 20 12:28:01 CET 2017 cron helios2 CROND[30426]: (pcp) CMD ( /usr/libexec/pcp/bin/pmie_check -C)
Mon Mar 20 12:30:01 CET 2017 cron helios2 CROND[30493]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Mon Mar 20 12:40:01 CET 2017 cron helios2 CROND[30595]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Mon Mar 20 12:43:02 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:43:58 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:44:57 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:45:52 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:46:51 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:47:47 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:48:37 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:49:41 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:50:01 CET 2017 cron helios2 CROND[30695]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Mon Mar 20 12:50:40 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:51:26 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:52:25 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:53:30 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:54:21 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:55:01 CET 2017 cron helios2 CROND[30752]: (pcp) CMD ( /usr/libexec/pcp/bin/pmlogger_check -C)
Mon Mar 20 12:55:25 CET 2017 messages helios2 avahi-daemon[975]: server.c: Packet too short or invalid while reading response record. (Maybe a UTF-8 problem?)
Mon Mar 20 12:58:01 CET 2017 cron helios2 CROND[30827]: (pcp) CMD ( /usr/libexec/pcp/bin/pmie_check -C)
Mon Mar 20 13:00:01 CET 2017 cron helios2 CROND[30898]: (root) CMD (/usr/lib64/sa/sa1 1 1)
Mon Mar 20 13:00:01 CET 2017 cron helios2 CROND[30899]: (root) CMD ("/usr/local/helios"/sbin/helios.daily hourly)
Mon Mar 20 13:01:01 CET 2017 cron helios2 CROND[30930]: (root) CMD (run-parts /etc/cron.hourly)
Mon Mar 20 13:01:01 CET 2017 cron helios2 run-parts(/etc/cron.hourly)[30930]: starting 0anacron
Mon Mar 20 13:01:01 CET 2017 cron helios2 run-parts(/etc/cron.hourly)[30942]: finished 0anacron

Wobei die avahi-daemon Meldung auch beim UB2 Server in den Meldungen erscheint, er wirft die Volumes nicht aus.

Vielleicht hilft das? Ich denke ich muss einmal einen Linux/Red Hat Lehrgang besuchen.
als Antwort auf: [#556418]
(Dieser Beitrag wurde von jenzibenzi am 20. Mär 2017, 13:10 geändert)
Top
 
GreatOm
Beiträge: 366
20. Mär 2017, 13:37
Beitrag #4 von 8
Beitrag ID: #556424
Bewertung:
(1384 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Helios wirft Volumes unter OSX aus - Windows Netzwerkpfad nicht gefunden


Antwort auf: Ich denke ich muss einmal einen Linux/Red Hat Lehrgang besuchen.


Lohnt sich immer ;-)

Zu den Meldungen:
Wenn man
Code
/usr/local/helios/bin/srvutil status 

aufruft, bekommt man alle aktiven HELIOS Dienste aufgelistet. In den vorliegenden Meldungen gibt es nur zwei Meldungen, bei denen pcshare zweimal "unauthorized request" meldet.
Was es damit auf sich hat kann ich auch nicht sagen. Allerdings sollte man mal einen Blick auf die dort angegebene IP-Adresse "192.168.0.211" werfen. Vielleicht spinnt da ein Client rum?!?

PS. Es sollte auch sichergestellt werden, das alle Macs sich per AFP und nicht per SMB an den Server anmelden!

Gruß,

GreatOm
--
Five exclamation marks, the sure sign of an insane mind. -- (Terry Pratchett, Reaper Man)
als Antwort auf: [#556423] Top
 
jenzibenzi
Beiträge: 5
20. Mär 2017, 14:05
Beitrag #5 von 8
Beitrag ID: #556426
Bewertung:
(1377 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Helios wirft Volumes unter OSX aus - Windows Netzwerkpfad nicht gefunden


Hi,

die Systemmeldungen von srvutil sehen so aus:
Service Status PID When Restarts
srvsrv Running 2585 Fri 15:35
notifysrv Running 2593 Fri 15:35
desksrv Running 2594 Fri 15:35
indexsrv Running 2595 Fri 15:35
mdnssrv Running 2596 Fri 15:35
authsrv Running 2597 Fri 15:35
afpsrv Running 2677 Fri 15:35
dhcpsrv Running 2598 Fri 15:35
heladmsrv Running 2678 Fri 15:35
mdnsproxysrv Running 2599 Fri 15:35
monitorsrv Running 2786 Fri 15:35
papsrv Running 2679 Fri 15:35
pcshare Running 2680 Fri 15:35
lpd Running 2787 Fri 15:35
[admin@helios2 ~]$

Also alles in Ordnung. Eigenartig ist das, bei den Macs alle Volumes bei einem Client ausgeworfen werden. Allerdings nicht alle Clients gleichzeitig.
als Antwort auf: [#556424] Top
 
jenzibenzi
Beiträge: 5
20. Mär 2017, 14:28
Beitrag #6 von 8
Beitrag ID: #556427
Bewertung:
(1365 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Helios wirft Volumes unter OSX aus - Windows Netzwerkpfad nicht gefunden


Ich sehe gerade, 192.168.0.211 ist ein Windows Terminal Server, an dem sich unsere Windowsclients anmelden. Erst mal unseren Windows Admin fragen.
als Antwort auf: [#556426] Top
 
GreatOm
Beiträge: 366
20. Mär 2017, 14:38
Beitrag #7 von 8
Beitrag ID: #556428
Bewertung:
(1345 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Helios wirft Volumes unter OSX aus - Windows Netzwerkpfad nicht gefunden


Vielleicht hatte ich mich missverständlich ausgedrückt.

Die Liste aus "srvutil" zeigt die laufenden HELIOS Prozesse.

Dann kann man in den Systemmeldungen schauen, ob dort Meldungen von dieses Prozessen auftauchen, um damit einen Hinweis auf die Fehlerursache zu finden.

Gruß,

GreatOm
--
Five exclamation marks, the sure sign of an insane mind. -- (Terry Pratchett, Reaper Man)
als Antwort auf: [#556426] Top
 
jenzibenzi
Beiträge: 5
20. Mär 2017, 15:11
Beitrag #8 von 8
Beitrag ID: #556430
Bewertung:
(1300 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Helios wirft Volumes unter OSX aus - Windows Netzwerkpfad nicht gefunden


Langsam bin ich echt überfragt, und es zeigt das ich wohl weniger Ahnung habe als ich dachte.
Was genau macht /usr/libexec/pcp/?

Eine Ahnung was diese Systemmeldung bedeutet:
Mon Mar 20 14:45:49 CET 2017 messages helios2 kernel: perf: interrupt took too long (2652 > 2500), lowering kernel.perf_event_max_sample_rate to 75000

Ich verstehe nur nicht weshalb das mit dem alten Server läuft und mit neuen nicht.
Der einzige Unterschied ist, das eine ist eine Standard-Installation von RHEL 6 und das andere eine Standard-Installation von CentOS 7.

Ziehe mir gerade die Developer Suite von RHEL7 und versuche es damit.

Welche guten Lehrgänge für Linux/RHEL gibt eigentlich?
als Antwort auf: [#556428] Top
 
X