hilfdirselbst.ch
Facebook Twitter gamper-media
Anonym
Beiträge: 22827
30. Aug 2002, 17:09
Beitrag #1 von 2
Bewertung:
(390 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

PHP mit Apache auf SuSE 8.0 installieren


Hallo Leute !

Ich schlag mich jetzt hier schon eine Weile rum und schaff es einfach nicht PHP zusammen mit Apache zu installieren. Apache nur für sich ist kein Problem und geht schnell ....
Ich habe den Apache 1.3.26 mit dem Befehl
./configure --prefix=pfad/zum/Apache-Verzeichnis ,make ,make install
installiert.

Der Befehl für PHP 4

./configure --with-mysql --enable-trans-sid --enable-trackvars
funktioniert auch. Ich bekomme nur zusätzlich noch diese Warnung im Anschluß :

*** WARNING ***


| You will be compiling the CGI version of PHP without any
| redirection checking. By putting this cgi binary somewhere in
| your web space, users may be able to circumvent existing .htaccess
| security by loading files directly through the parser. See
| http://www.php.net/manual/security.php for more details.

Anschließend make & make install gibt keine Fehlermeldungen

Wenn ich nun aber das PHP-Modul in den Apache einbinden möchte funktioniert dieser Befehl NICHT :
jobst@linux:~/Apacheverzeichnis> ./configure --prefix=/Apacheverzeichnis -active-module=/src/modules/php4/libphp4.a

Auch dieser Befehl funktioniert nicht :
jobst@linux:~/Apacheverzeichnis> ./configure --prefix=/Apacheverzeichnis -active-module=/Apacheverzeichnis/src/modules/php4/libphp4.a

Die Fehlermeldung lautet :

configure:Error: invalid option '-active-module=/src/modules/php4/libphp4.a'

(Dabei fällt mir auf, daß es im Verzeichnis /src/modules/ kein Verzeichnis 'php4/libphp4.a' gibt.)

Versuche ich über Mozilla PHP-Scripte aufzurufen so klappt das über
http://localhost/phpscript.php
nicht. HTML läßt sich aber aufrufen. Ich denke das Problem ist hier, daß ich PHP noch nicht in den Apache eingebunden habe, oder ? Mir wird vom Browser immer "The connection was refused when attempting to contact localhost" als Fehler gegeben.

'AddType application/x-httpd-php .php' habe ich auch bereits in die Datei 'httpd.conf' eingefügt.

Hat Jemand eine Ahnung oder Idee wie ich hier weiterkomme bzw. dieses Problem gelöst bekomme ?


Besten Dank im Voraus !!!

Grüße, Jobst ;-) Top
 
X
hmaus  M 
Beiträge: 692
21. Sep 2002, 17:31
Beitrag #2 von 2
Beitrag ID: #11904
Bewertung:
(390 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

PHP mit Apache auf SuSE 8.0 installieren


Hi,

sag mal, warum benutzt Du denn nicht die vorkompilierten Pakete von der SUSE-CD?

Helge
HelgeMaus@iPartner.de
als Antwort auf: [#10378] Top