hilfdirselbst.ch
Facebook Twitter gamper-media
Pozor  M 
Beiträge: 892
5. Aug 2003, 23:17
Beitrag #1 von 9
Bewertung:
(1973 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit fopen


hallo,

ich habe folgendes problem:

Warning: fopen(/test.php) [function.fopen]: failed to create stream: Permission denied

ist das eine einstellung in .htaccsess oder wo kann dieses problem gefixt werden, liegt das an der konfiguration des servers?


gruss Pozor

PS: der code sieht so aus:

$filecontent = "blabla";
$filename = "test.php";

$handle = fopen("/".$filename,"w+");
fwrite($handle,$filecontent);
fclose($handle);
(Dieser Beitrag wurde von Pozor am 5. Aug 2003, 23:21 geändert)
Top
 
X
Baschi3
Beiträge: 294
5. Aug 2003, 23:29
Beitrag #2 von 9
Beitrag ID: #46283
Bewertung:
(1973 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit fopen


hi pozor

um in eine Datei zu schreiben, brauchst Du die entsprechende Berechtigung.
Mit chmod 644 (glaube ich) sollte es klappen.

Franz
als Antwort auf: [#46280] Top
 
Pozor  M 
Beiträge: 892
5. Aug 2003, 23:34
Beitrag #3 von 9
Beitrag ID: #46284
Bewertung:
(1973 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit fopen


hallo,

das phpfile (das mit dem ich ein anderes erzeugen will?) sollte diese berechtigungen besitzen?

->

das geht bei mir nicht...???
habs mal getestet.

leider wird momentan gerade mein server von genf nach zürich gezügelt... darum kann ich erst morgen weiter testen

gruss pozor
als Antwort auf: [#46280] Top
 
Miro Dietiker
Beiträge: 699
5. Aug 2003, 23:34
Beitrag #4 von 9
Beitrag ID: #46285
Bewertung:
(1973 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit fopen


Es kann sein, dass PHP auf deinem Server im "SafeMode" läuft..
Ein komplexes Konfigurationsding, mit welchem man die Sicherheit
auf einem Server erhöhen kann..
Die Standardeinstellungen erlauben dann nur das öffnen von Files
im Scriptordner selbst und in allen unterordnern...
Allerdings sollte dann auch sowas von "SafeMode" in der Fehlermeldung
stehen. Ein Anruf genügt bei den meistne Providern um den SafeMode
abzustellen für deinen Server ,) (Verlegenheitslösung!!!)

Etwas einfacher wäre das Problem, wenn es von den Berechtigungen
her kommt. (Das kannst du selber einstellen/bestimmen)
Telnet / SSH Zugang vorhanden?
Im Zusammenhang mit File uploads und Read/Write geschichten kommt es
immer wieder zu Problemen auf dem Unix-Filesystem wegen den
Berechtigungen. Je nach Installationsart des PHP-Modules verhält sich
das auch anders (PHP als externes CGI-Modul oder in Apache integriert
als Modul?)

Bitte um Informationen zu:
- Was für Parameter verwendest du bei fopen?
(Öffnen mit Schreiben, usw)
- Weisst du wie PHP integriert ist?
- Was für ein user hat das File als owner?

PS: Auch in PHP gibt es eine Reihe Routinen, mit welchen man die
Berechtigungen von Files auslesen kann...

GrEeZ: Miro Dietiker
als Antwort auf: [#46280] Top
 
Miro Dietiker
Beiträge: 699
5. Aug 2003, 23:37
Beitrag #5 von 9
Beitrag ID: #46286
Bewertung:
(1973 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit fopen


Das PHP-Script das die Datei öffnet muss keine Rechte besitzen!
Es wird nur ausgeführt (Im Webserver als Modul ist das nur das
Attribut "READ" - Als CGI-Version zusätzlich noch das "EXECUTE")

Das File welches bearbeitet werden soll muss entsprechende Rechte
gesetzt haben! (Je nachdem was du willst)


GrEeZ: Miro Dietiker
als Antwort auf: [#46280] Top
 
Pozor  M 
Beiträge: 892
5. Aug 2003, 23:38
Beitrag #6 von 9
Beitrag ID: #46287
Bewertung:
(1973 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit fopen


hallo,

>Telnet / SSH Zugang vorhanden?
nein

>PHP als externes CGI-Modul oder in Apache integriert
>als Modul?
in apache integriert

mehr weiss ich nicht... (momentan)

ich probiers morgen nochmals...

gruss Pozor

PS: teilweise existiert das file noch nicht teilweise existiert es wird aber überschrieben (ist so meine idee)

als Antwort auf: [#46280]
(Dieser Beitrag wurde von Pozor am 5. Aug 2003, 23:40 geändert)
Top
 
Anonym
Beiträge: 22827
6. Aug 2003, 08:59
Beitrag #7 von 9
Beitrag ID: #46311
Bewertung:
(1973 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit fopen


hallo,

ich habe das problem noch nicht gelöst, aber ich habe mein ziel auf andere weise erreicht. meine idee war dass ich code über ein webinterface in eine beliebige datei in dem test ordner hineinschreiben kann, da ich in gewissen umgebungen nicht auf die ports meines servers zugreifen kann (ist nötig um ne datei hinaufzuladen mit dem Controlpanel). Billiboy sei dank gibt ein cmd und ein hardcore ftpprog.

falls jemand die lösung des problems dennoch hatt oder dasselbe problem auch schon mal hatte, bin ich weiterhin sehr an der/den lösungsansätzen interessiert.

gruss Pozor
als Antwort auf: [#46280] Top
 
Miro Dietiker
Beiträge: 699
6. Aug 2003, 09:24
Beitrag #8 von 9
Beitrag ID: #46320
Bewertung:
(1973 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit fopen


Hab' ich's mir doch gedacht! (erwischt!!!)

... willst du doch das heikelste Problem angehen und deinen Server
völlig unsicher machen ...

Es ist sehr gut möglich, dass der webserver die Ausführung
jeglichen codes der über den Webserver selbst raufgeladen wurde
(Owner-User ist httpd anstelle deines ftp-users) verweigert
und das ist gut so!
Willst du dass jeder andere auch anstelle eines bildes irgendwo
ein php-file raufladen kann und den code auf dem Server
ausführen kann indem er das "bild" aus dem Zielordner öffnen kann..

Ja man kann das machen, aber dafür musst du gewaltig würgen
und es ist ungesund ;)

GrEeZ: Miro Dietiker
als Antwort auf: [#46280] Top
 
Pozor  M 
Beiträge: 892
6. Aug 2003, 12:46
Beitrag #9 von 9
Beitrag ID: #46353
Bewertung:
(1973 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit fopen


hallo,

jaja ich weiss... ich arbeite hinter einer firewall die keine zugriffe auf ports zulässt... darum diese idee... aber wie gesagt ich nehme einach die ftpfunktion des systems selber...

aber wiso funktioniert denn das fopen ned??

gruss Pozor
als Antwort auf: [#46280] Top
 
X