hilfdirselbst.ch
Facebook Twitter gamper-media
Tipps und Tricks zu Adobe GoLive von Dirk Levy, GoLive FAQ's von Randolph Sterna
Momo
Beiträge: 48
30. Mär 2004, 22:51
Beitrag #1 von 6
Bewertung:
(1074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit iframe


Zuerst mal Hallo, ist meine erste frage hier im forum...

Es geht um diesen Versuch:
/////edit////// (existiert nicht mehr!!

Weiss irgendjemand, wie ich das machen kann, dass sich die Links der Navigation in dem von mir definierten iframe öffnen??
Direkt im Inspektor beim Ziel kommt mein iframe nicht als auswahlmöglichkeit.

Oder kann man das ganze auch anders Lösen? Also ohne iframe (Der Rest der Seite sollte jedoch nicht jedesmal neu laden und das der zentrierte "Hauptkasten" sollte auch beibehalten werden, also müssen da doch frams in irgendeiner weise drin sein).

Besten Dank schon mal
Momo
(Dieser Beitrag wurde von Momo am 2. Apr 2004, 17:05 geändert)
Top
 
X
Dirk Levy  A 
Beiträge: 9244
31. Mär 2004, 09:23
Beitrag #2 von 6
Beitrag ID: #77672
Bewertung:
(1074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit iframe


Erstmal hast Du das iFrame _main genannt,
das ist nicht erlaubt. Benenne es um,
dann kannst Du den neuen Namen als Linkziel
für Deine Links eingeben und alles geht
wie von selbst.

Gruß
Dirk

[Adobe GoLive Tipps & Tricks]
http://www.gltipps.de
als Antwort auf: [#77649] Top
 
Momo
Beiträge: 48
31. Mär 2004, 16:54
Beitrag #3 von 6
Beitrag ID: #77796
Bewertung:
(1074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit iframe


Danke für die antwort, aber es scheint immer noch nicht zu klappen...
Im Inspektor kann ich für die Links doch ein Ziel eingeben, dort ist jetzt _self,_bank,_,_top,... drin, aber nicht der name vom e-frame!!

MfG
Momo
als Antwort auf: [#77649]
(Dieser Beitrag wurde von Momo am 31. Mär 2004, 16:56 geändert)
Top
 
SabineP  M 
Beiträge: 7586
31. Mär 2004, 17:04
Beitrag #4 von 6
Beitrag ID: #77797
Bewertung:
(1074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit iframe


Hallo Momo, das kann so auch nicht klappen.

<a href="http://www.yahoo.de">Navigation</a>

Woher soll Dein Link wissen, daß er die Seite im Frame "hauptinhalt" öffnen soll.

Versuchs mal so:
<a href="http://www.yahoo.de" target="hauptinhalt">Navigation</a>

Übrigens brauchst Du natürlich auch eine Erlaubnis von
yahoo, bluewin und msn um deren Seiten in Deinen Frame einzubinden.

Gruß Sabine


als Antwort auf: [#77649] Top
 
randy S
Beiträge: 436
31. Mär 2004, 17:07
Beitrag #5 von 6
Beitrag ID: #77798
Bewertung:
(1074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit iframe


hier die def von selfhtml



<iframe src="../../../index.htm" width="90%" height="400" name="SELFHTML_in_a_box">
<p>Ihr Browser kann leider keine eingebetteten Frames anzeigen:
Sie k&ouml;nnen die eingebettete Seite &uuml;ber den folgenden Verweis
aufrufen: <a href="../../../index.htm">SELFHTML</a></p>
</iframe>

bei mir wird übrigens msn angezeigt

gruss randy
<adobe promotor>
als Antwort auf: [#77649] Top
 
Momo
Beiträge: 48
2. Apr 2004, 17:04
Beitrag #6 von 6
Beitrag ID: #78183
Bewertung:
(1074 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit iframe


So, ich habs:
Ich hab dummerweiise das iFrame mit "src http://www....de" quasi belegt, und so konnten sich keine anderen Websites darin öffnen...
Trotzdem vielen Dank für die schnellen Antworten...

Viele Grüsse Momo

PS:@ SabineP: klar müsst ich die um erlaubniss fragen, doch es handelte sich nur um eine Testseite, die wie du siehst, schon wieder offline ist... waren hald die einzigen, die mir spontan eingefallen sind ;-)
als Antwort auf: [#77649] Top
 
X