hilfdirselbst.ch
Facebook Twitter gamper-media
Tipps und Tricks zu Adobe GoLive von Dirk Levy, GoLive FAQ's von Randolph Sterna
max
Beiträge: 111
25. Feb 2002, 09:10
Beitrag #1 von 12
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


Hallo,
bei dem Layouten mit Tabellen tritt bei mir folgendes Problem auf:
1 Tabelle ist mein grundlayout. Da hinein lege ich ein Layoutraster, wo ich dann später Bilder und Grafiken platzieren möchte. Unter Ns 4.7 ergibt sich das Problem, daß der Hintergrund der "Haupttabelle" auch in dem Layoutraster dargestellt wird (also quasi doppelt und versetzt). Im IE ist alles wunderbar. Was muß ich tun, damit das Layoutraster ohne Hintergrund erscheint.
Danke für tipps, Max

Top
 
X
Urs Gamper  A  p
Beiträge: 3653
25. Feb 2002, 09:52
Beitrag #2 von 12
Beitrag ID: #978
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


erstelle eine zweite tabelle, gleiche grösse und lege diese in die erste hinein. gib der inneren tabelle einen transparenten hintergrund. so kachelt es den transparenten hg - ist aber logischerweise nicht sichtbar.
als Antwort auf: [#977] Top
 
max
Beiträge: 111
25. Feb 2002, 12:33
Beitrag #3 von 12
Beitrag ID: #985
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


ich glaube das ist nicht das Problem. habe noch was vergessen zu erwähnen:
Ich lege ja in die Tabelle ein Layoutraster (ohne Hintergrund) Darein lege ich einen Textrahmen und dann habe ich das Problem, daß sich auf der gesamten Breite dieses Textrahmens bis nach ganz unten auf der Seite das HG-Bild kachelt.
Hier mein code:
_____________________________
<html>
<head>
<meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
<meta name="generator" content="Adobe GoLive 5">
<title>Willkommen bei Adobe GoLive 5</title>
<csactions>
<csaction name="262DED0" class="Target 2 Frames" type="onevent" val0="" val1="(Empty Reference!)" val2="" val3="(Empty Reference!)">
</csactions>
</head>

<body bgcolor="#ffffff">
<table border="1" cellpadding="0" cellspacing="2" width="928" height="526" background="file:///C:/irgendeinfoto.jpg">
<tr height="516">
<td height="516"></td>
<td width="434" height="516">
<table cool width="434" height="516" usegridx usegridy showgridy gridx="16" gridy="16" border="0" cellpadding="0" cellspacing="0" showgridx>
<tr height="128">
<td width="433" height="128" colspan="3"></td>
<td width="1" height="128"><spacer type="block" width="1" height="128"></td>
</tr>
<tr height="387">
<td width="96" height="387"></td>
<td width="176" height="387" align="left" xpos="96" content valign="top" csheight="88">bxcvbxcvbxcvb
<p>xcvbxcvbxcvb</p>
<p>xcvbxcvbxcvbxcvbxcvb</p>
</td>
<td width="161" height="387"></td>
<td width="1" height="387"><spacer type="block" width="1" height="387"></td>
</tr>
<tr height="1" cntrlrow>
<td width="96" height="1"><spacer type="block" width="96" height="1"></td>
<td width="176" height="1"><spacer type="block" width="176" height="1"></td>
<td width="161" height="1"><spacer type="block" width="161" height="1"></td>
<td width="1" height="1"></td>
</tr>
</table>
</td>
<td height="516"></td>
</tr>
</table>
<p></p>
</body>
</html>
_________________________________

hast Du dazu ne Idee? Denn wenn das so nicht geht wäre das Layouten mit Tabellen ja sehr umständlich.
als Antwort auf: [#977] Top
 
Urs Gamper  A  p
Beiträge: 3653
25. Feb 2002, 12:56
Beitrag #4 von 12
Beitrag ID: #986
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


hallo max
ich habe dich schon recht verstanden. da du beim layoutraster nur eine farbe als hintergrund definieren kannst, habe ich dir geschrieben, dass du in die bereits bestehende tabelle noch eine zweite legen musst, welcher du einen transpartenten hintergrund verpasst.
es spielt da keine rolle, ob in der tabelle ein layoutraster oder eine weitere tabelle ist. nn verhält sich genau gleich.
als Antwort auf: [#977] Top
 
max
Beiträge: 111
25. Feb 2002, 14:47
Beitrag #5 von 12
Beitrag ID: #1002
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


danke soweit!
mit transparent meinst Du sicher ein blindes gif, oder? Nun habe ich folgendes merkwürdiges Problem. Sobald ich das blindgif als Hintergrund der inneren Tabelle definiere wir GoLive plötzlich fürchterlich langsam. jeder rechenschritt dauert ca. 1 min. Habe auch noch einmal ein anderes gif genommen, auch damit kam das gleiche problem. Was kann denn das nur sein?
als Antwort auf: [#977] Top
 
Urs Gamper  A  p
Beiträge: 3653
25. Feb 2002, 15:35
Beitrag #6 von 12
Beitrag ID: #1004
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


du wirst ein blindgif vo 1x1 px gemacht haben. das ist der grund. erstelle es in der grösse von ca. 50 x 50 px.
als Antwort auf: [#977] Top
 
max
Beiträge: 111
25. Feb 2002, 17:04
Beitrag #7 von 12
Beitrag ID: #1011
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


jau, genau das war das Problem! Danke.
Habe trotzdem noch eine Frage. Jetzt kachelt zwar nicht mehr der HG im Layout-Textrahmen, aber: meine Tabelle hat 3 Spalten und in jeder Spalte erscheint das Bild gekachelt, was mach ich denn da? Hast Du noch einen Tipp?
als Antwort auf: [#977] Top
 
Urs Gamper  A  p
Beiträge: 3653
25. Feb 2002, 17:14
Beitrag #8 von 12
Beitrag ID: #1012
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


du hast die erste tabelle mit hg-bild, welche eine zeile und eine spalte aufweist. die zweite tabelle, mit dem transparenten gif kann x zeilen und auch x spalten aufweisen, darf aber schlussendlich nicht grösser sein, als die erste tabelle.

sollte dies nicht möglich sein, musst du das hg-bild via css definieren. dazu findest du bereits beiträge in diesem forum, oder allenfalls auch im alten forum, welches auf der startseite von hilfdirselbst.ch (unten rechts) verlinkt ist.
als Antwort auf: [#977] Top
 
max
Beiträge: 111
26. Feb 2002, 09:58
Beitrag #9 von 12
Beitrag ID: #1038
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


Hallo Urs,
1000 Dank für die Tipps, es klappt und ich bin wie immer begeistert von diesem Forum!!!
als Antwort auf: [#977] Top
 
Franky
Beiträge: 68
3. Mär 2002, 21:10
Beitrag #10 von 12
Beitrag ID: #1269
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


Hatte vor kurzem auch das Problem.
Es gibt aber eine einfachere Abhilfe. Einfach bei den inneren Tabellen folgenden Tag einfügen: backround=""
Dann klappts auch...
als Antwort auf: [#977] Top
 
heizfrosch
Beiträge: 67
3. Mär 2002, 22:05
Beitrag #11 von 12
Beitrag ID: #1271
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


Das klappt totsicher nicht, denn es müßte mindestens "background" heißen...

heizfrosch
als Antwort auf: [#977] Top
 
Franky
Beiträge: 68
3. Mär 2002, 23:18
Beitrag #12 von 12
Beitrag ID: #1273
Bewertung:
(1734 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme beim Layouten mit Tabellen


da hast du wohl recht

aber wenn man es dann richtisch tippen tut, dann gehts.
man hat dann im site-fenster zwar lauter link-fehler, abe dass
soll einen nicht weiter stören...
als Antwort auf: [#977] Top
 
X