hilfdirselbst.ch
Facebook Twitter gamper-media
Santscho
Beiträge: 37
30. Dez 2003, 23:12
Beitrag #1 von 2
Bewertung:
(294 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme mit Apache. Wer kann mir helfen?


ich habe mich bei no-ip.com registriert und das funktioniert auch wunderbar. nur schickt der "uptdater client" die ip meines roots und nicht die des users an no-ip.com. es erscheint eine apache-seite mit dem hinweis:

"If you can see this, it means that the installation of the Apache web server software on this system was successful. You may now add content to this directory and replace this page."

ich finde aber dieses "directory" nirgends und diese html-seite leider auch nicht. ich bin mir sicher, dass dieses verzeichnis nicht der "web-sites"-ordner meines hauptbenutzer-verzeichnisses ist, denn diese index.html hat einen deutschen Inhalt.

entferne ich den ordner "documents" aus dem verzeichnis: mac - library - webserver, und mache einen refresh im browser, bekomme ich die meldung "site not found". kopiere ich den ordner wieder zurück, erhalte ich wieder die hinweisseite nach einem refresh im browser.

weiss jemand, wo ich das richtige directory finde? oder muss ich irgendwie was am apache-server schrauben? ich kenne mich da nicht aus und die dokumentation ist nur auf englisch. Top
 
X
GoeGG-ArT  M 
Beiträge: 2531
31. Dez 2003, 01:20
Beitrag #2 von 2
Beitrag ID: #63861
Bewertung:
(291 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme mit Apache. Wer kann mir helfen?


das "home" verzeichniss
ist in der "httpd.conf" datei gespeichert.
(zu finden im /etc/httpd/ ordner.)
da heisst es (ca)etwas weiter unten:
#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "/Library/WebServer/Documents"

#
# Each directory to which Apache has access, can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# permissions.
#
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

#
# Note that from this point forward you must specifically allow
# particular features to be enabled - so if something's not working as
# you might expect, make sure that you have specifically enabled it
# below.
#

#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/Library/WebServer/Documents">
///....usw.

Die 2 "/Library/WebServer/Documents" pfade musst Du bei bedarf
ändern.

Apache neustarten z.B. im Terminal mit:
apachectl graceful

gruess
GöGG
**************************
http://www.goegg-art.ch
**************************
als Antwort auf: [#63858] Top