hilfdirselbst.ch
Facebook Twitter gamper-media
Tipps und Tricks zu Adobe GoLive von Dirk Levy, GoLive FAQ's von Randolph Sterna
shadowhand35
Beiträge: 4
8. Jul 2003, 14:44
Beitrag #1 von 8
Bewertung:
(793 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Rahmen lassen sich nicht richtig positioniert


Hallo,
hab eine Seite(Navigation) mit mehreren Rahmen (mit Bildern als Inhalt)gestaltet - die Bilder überlappen sich zum Teil.
Im Vorschaumodus und Explorer ist alles perfekt aber---- wenn ich nun die Seite z.B. auf meiner Hauptseite einfüge(link) sind plötzlich alle vorher richtig positionierten Bilder völlig falsch angeordnet.

Was ist mein Fehler???

LG Gerald Top
 
X
SabineP  M 
Beiträge: 7586
8. Jul 2003, 14:50
Beitrag #2 von 8
Beitrag ID: #42971
Bewertung:
(793 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Rahmen lassen sich nicht richtig positioniert


Hallo shadowhand35,

>>Was ist mein Fehler???

Das kann hier niemand feststellen ohne den Quellcode Deiner Seite.

Gruß Sabine
als Antwort auf: [#42970] Top
 
shadowhand35
Beiträge: 4
8. Jul 2003, 15:50
Beitrag #3 von 8
Beitrag ID: #42992
Bewertung:
(793 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Rahmen lassen sich nicht richtig positioniert


Das Problem hat scheinbar mit "Komponenten" zu tun. Selbst wenn ich eine von Adobe eine Musterseite mit mehreren Rahmen als Inhalt hernehme und eine Komponente daraus erstelle, und diese in eine andere Seite einfüge zerstört es mir die richtige Positionierung der Rahmen (alle Rahmen werden in der neuen Seite am rechten Rand untereinander angeordnet)
als Antwort auf: [#42970] Top
 
SabineP  M 
Beiträge: 7586
8. Jul 2003, 16:03
Beitrag #4 von 8
Beitrag ID: #42999
Bewertung:
(793 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Rahmen lassen sich nicht richtig positioniert


Die "Rahmen" von Golive werden mit CSS positioniert. Die CSS-Angaben befinden sich im <head>.
Der <head> Bereich wird wahrscheinlich nicht in der Komponente gespeichert.
Das ist auch so in Ordnung, da eine HTML-Seite nur einen <head> Bereich haben darf.
Kopiere doch einfach mal die CSS-Angaben
(alles zwischen <style> und </style>)
in den <head> der Seite in der die Komponente eingefügt wird.
Gruß Sabine
als Antwort auf: [#42970]
(Dieser Beitrag wurde von SabineP am 8. Jul 2003, 16:03 geändert)
Top
 
Urs Gamper  A  p
Beiträge: 3689
8. Jul 2003, 21:05
Beitrag #5 von 8
Beitrag ID: #43041
Bewertung:
(793 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Rahmen lassen sich nicht richtig positioniert


oder wenn du mit golive 6 arbeitest - versuche es mit einer musterseite.
--------------------------------------
http://www.gamper.ch
Gamper Internet-Auftritte und Schulung
als Antwort auf: [#42970] Top
 
shadowhand35
Beiträge: 4
9. Jul 2003, 09:57
Beitrag #6 von 8
Beitrag ID: #43093
Bewertung:
(793 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Rahmen lassen sich nicht richtig positioniert


Mein Problem mit den Rahmen+Komponenten konnte ich noch immer nicht lösen.
Hie die Seite wie sie aussehen soll:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>

<head>
<meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
<meta name="generator" content="Adobe GoLive 6">
<title>Willkommen bei Adobe GoLive 6</title>
<style type="text/css" media="screen"><!--
#Ebene1 { position: absolute; top: 138px; left: 211px; width: 100px; height: 100px; visibility: visible; display: block }
#Ebene2 { position: absolute; top: 103px; left: 299px; width: 100px; height: 100px; visibility: visible; display: block }
--></style>
</head>

<body bgcolor="#ffffff">
<div id="Ebene1">
<img src="file:///C:/Temp/Site04%20ordner/Site04/images/fl_icon_b2.jpg" alt="" width="131" height="132" border="0"></div>
<div id="Ebene2">
<img src="file:///C:/Temp/Site04%20ordner/Site04/images/fl_icon_b3.jpg" alt="" width="131" height="132" border="0"></div>
<p></p>
</body>

</html>



und nach dem Ablegen als Komponente und einfügen in eine neue leere Seite:



<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

<html>

<head>
<meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
<meta name="generator" content="Adobe GoLive 6">
<title>Willkommen bei Adobe GoLive 6</title>
<csimport user="file:///C:/Temp/Site04%20ordner/Site04.data/Komponenten/Test%207.html" occur="59">
<style type="text/css" media="screen"><!--
#Ebene1 { position: absolute; top: 138px; left: 211px; width: 100px; height: 100px; visibility: visible; display: block }
#Ebene2 { position: absolute; top: 103px; left: 299px; width: 100px; height: 100px; visibility: visible; display: block }
--></style>
</csimport>
</head>

<body bgcolor="#ffffff">
<csobj occur="59" w="730" h="295" t="Component" csref="file:///C:/Temp/Site04%20ordner/Site04.data/Komponenten/Test%207.html">
<div id="Ebene1">
<img src="file:///C:/Temp/Site04%20ordner/Site04/images/fl_icon_b2.jpg" alt="" width="131" height="132" border="0"></div>
<div id="Ebene2">
<img src="file:///C:/Temp/Site04%20ordner/Site04/images/fl_icon_b3.jpg" alt="" width="131" height="132" border="0"></div>
<p></p>
</csobj>
<p></p>
</body>

</html>


Was muss ich im Quellcode ändern (noch besser als Befehl- da ich wenig Ahnung von HTML hab)?
als Antwort auf: [#42970] Top
 
SabineP  M 
Beiträge: 7586
9. Jul 2003, 10:28
Beitrag #7 von 8
Beitrag ID: #43102
Bewertung:
(793 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Rahmen lassen sich nicht richtig positioniert


Hallo Gerald,

ich kann zwischen beiden Dateien keinen Unterschied bei der Bildanordnung erkennen.

Allerdings sind beide Dateien für einen Webserver unbrauchbar.

Die Referenzen, die auf Deine Festplatte verweisen können online natürlich nicht funktionieren:
file:///C:/Temp/Site04%20ordner/Site04/images/fl_icon_b2.jpg

so wäre es richtig

/images/fl_icon_b2.jpg

Du solltest mit einer Site-Datei arbeiten, damit Golive die Referenzen und Links richtig anlegen kann.

Gruß Sabine
als Antwort auf: [#42970] Top
 
shadowhand35
Beiträge: 4
9. Jul 2003, 11:16
Beitrag #8 von 8
Beitrag ID: #43110
Bewertung:
(793 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Rahmen lassen sich nicht richtig positioniert


Hallo Sabine,
das mit den Bildern die auf die Festplatte verweisen war nur der Schnelligkeit halber- ich werde wohl das Problem mit den sch*** Rahmen umgehen müssen, trotzdem vielen Dank

LG Gerald
als Antwort auf: [#42970] Top
 
X