hilfdirselbst.ch
Facebook Twitter gamper-media

Linkliste für Browser und CSS zusammengetragen von ganesh

MNeuroth
Beiträge: 7
1. Okt 2003, 21:51
Beitrag #1 von 10
Bewertung:
(3895 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Safari 1.0 / Internet Explorer 5.2.3 -----Internet Explorer 5.5 bzw. 6.0


Hallo zusammen,
ich arbeite in einem größeren Konzern und bilde mit 2 Macs eine kleine Insel (G4 Max OS X allerneueste Version mit allen Updates).
In meiner Abteilung haben wir einige webgesteuerte Datenbanken zu füttern. Wenn ich diese Links aufrufe bekomme ich neuerdings als Meldung, dass ich den IE 5.5 oder 6 benötige. Bedauerlicherweise hat Micosoft bei 5.2.3 Schluß mit der Programmierung für die Macs gemacht. Mit dem Safari bekomme ich die selbe Meldung.
Der Safari-Enhancer hat auch keine Wirkung gezeigt. Hat jemand eine andere Idee (Netscape, Morzilla gehen auch nicht!!)

Top
 
X
SabineP  M 
Beiträge: 7586
2. Okt 2003, 08:52
Beitrag #2 von 10
Beitrag ID: #53142
Bewertung:
(3895 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Safari 1.0 / Internet Explorer 5.2.3 -----Internet Explorer 5.5 bzw. 6.0


Hallo,
dafür ist derjenige verantwortlich, der die webgesteuerten Datenbanken entwickelt hat.
Wahrscheinlich enthalten die HTML-Seiten die Du im Browser aufrufts ein Javascript das die Browserversion prüft.
Das Javascript müßte so geändert werden, daß Dein Browser akzeptiert wird.
Ich weiß nicht, ob man im Safari 1.0 eine eigene Browserkennung einstellen kann.
Oder Du schaltest im Safari Javascript einfach ab und schaust mal was passiert.

Gruß Sabine
als Antwort auf: [#53115] Top
 
MNeuroth
Beiträge: 7
2. Okt 2003, 13:43
Beitrag #3 von 10
Beitrag ID: #53185
Bewertung:
(3895 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Safari 1.0 / Internet Explorer 5.2.3 -----Internet Explorer 5.5 bzw. 6.0


Hallo Sabine,
vielen Dank für Deinen Tipp. Ich hab's ausprobiert ohne Java. Leider ohne Erfolg. Das Problem in meinem Konzern ist, dass PC's Vorgabe für alle Arbeiplätze sind. Durch einen glücklichen Umstand darf ich mir 2 Mac's halten :-)(2 Macs unter zigtausend PC's) Daher kann ich die Klappe nicht so weit aufreissen (...sonst würde ich dem Programmierer schon einen kleinen Hinweis geben). Kennst Du vielleicht noch eine andere Möglichkeit?
Vorab schon einmal vielen Dank für Deine Hilfe
Gruß
Marcus

P.S. Hier die Fehlermeldung im Originaltext.

SG01
This application requires Internet Explorer 5.5 to login.
als Antwort auf: [#53115] Top
 
SabineP  M 
Beiträge: 7586
2. Okt 2003, 14:32
Beitrag #4 von 10
Beitrag ID: #53194
Bewertung:
(3895 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Safari 1.0 / Internet Explorer 5.2.3 -----Internet Explorer 5.5 bzw. 6.0


Hallo Markus,
JavaScript abschalten, Java ist etwas anderes.

Die Fehlermeldung kann natürlich auch von einem serverseitigen Script kommen.
Dann hilft wirklich nur ein Browser, in dem man die Browserkennung ändern kann.
Mit der geänderten Browserkennung kannst Du dem Webserver vorschwindeln, daß Du einen IE 5.5 hast.

Ob dann die Webanwendung noch funktioniert ist eine andere Frage.

Ich habe nur einen PC, vielleicht kann ja ein MAC-Fachmann noch etwas dazu sagen.

Gruß Sabine
als Antwort auf: [#53115] Top
 
loethelm  M 
Beiträge: 5950
2. Okt 2003, 15:20
Beitrag #5 von 10
Beitrag ID: #53203
Bewertung:
(3895 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Safari 1.0 / Internet Explorer 5.2.3 -----Internet Explorer 5.5 bzw. 6.0


In Opera kannst du einstellen, welchen Browser Opera dem Server vorgaukeln soll.
als Antwort auf: [#53115] Top
 
MNeuroth
Beiträge: 7
2. Okt 2003, 15:47
Beitrag #6 von 10
Beitrag ID: #53208
Bewertung:
(3895 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Safari 1.0 / Internet Explorer 5.2.3 -----Internet Explorer 5.5 bzw. 6.0


Hi,
kann ich in Opera dem Server auch IE 5.5 vorgaukeln?
Und wo unter Opera?
Schon mal schönen Dank für die Hilfe....
als Antwort auf: [#53115] Top
 
loethelm  M 
Beiträge: 5950
3. Okt 2003, 19:20
Beitrag #7 von 10
Beitrag ID: #53339
Bewertung:
(3895 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Safari 1.0 / Internet Explorer 5.2.3 -----Internet Explorer 5.5 bzw. 6.0


Das weiß ich nicht 100pro. Du findest das in den Preferences
als Antwort auf: [#53115] Top
 
MNeuroth
Beiträge: 7
4. Okt 2003, 12:22
Beitrag #8 von 10
Beitrag ID: #53364
Bewertung:
(3895 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Safari 1.0 / Internet Explorer 5.2.3 -----Internet Explorer 5.5 bzw. 6.0


Der Tipp ist nicht schlecht. Aber man kann leider nur bis IE 5.0 einstellen.
als Antwort auf: [#53115] Top
 
MNeuroth
Beiträge: 7
9. Okt 2003, 22:52
Beitrag #9 von 10
Beitrag ID: #54005
Bewertung:
(3895 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Safari 1.0 / Internet Explorer 5.2.3 -----Internet Explorer 5.5 bzw. 6.0


Hallo an Alle!
Die Lösung habe ich auf einem Workshop gefunden! Der Safari Enhancer ist wirklich die Lösung. Wenn mann den "Safari Enhancer" bei eingeschaltetem Safari(wichtig!!) startet, und das "Debugging" anklickt, dann wird der Safari um den Menüpunkt "Debug" erweitert.
Dort muss mann dann unter "User Agent" das Untermenü Windows "MSIE 6.0" aktiviereb. Dann verhält sich der Safari nahezu wie ein Internet Explorer 6.0. Viel Spaß beim Ausprobieren...

Viele Grüße aus Essen..

Marcus Neuroth
als Antwort auf: [#53115] Top
 
Dr. Gonzo
Beiträge: 2993
14. Okt 2003, 11:55
Beitrag #10 von 10
Beitrag ID: #54423
Bewertung:
(3895 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Safari 1.0 / Internet Explorer 5.2.3 -----Internet Explorer 5.5 bzw. 6.0


> verhält sich der Safari nahezu wie ein Internet Explorer 6.0
tut er ja eigentlich nicht. vehält sich genau wie safari. er gibt sich einfach als IE 6.0 zu erkennen. (der freche lügner :-)
Allerdings muss das auch ein kompletter vollidot erstellt haben, mit dieser überflüssigen beschränkung auf IE 6.

gruss säsch
---------
http://www.saesch.ch
als Antwort auf: [#53115] Top
 
X