hilfdirselbst.ch
Facebook Twitter gamper-media
Philyra
Beiträge: 509
9. Mär 2004, 06:08
Beitrag #1 von 10
Bewertung:
(1956 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Una problema


Hi,
habe ein Problem, das ich trotz Handbuch und Rumprobieren nicht lösen kann: Habe eine Tabelle mit zwei Spalten. Links eine Bilddatei, rechts ein Text. Der Text ist etwas länger als das Bild hoch und mit css formatiert.

Beide Zelleninhalte sollen an der oberkante abschließen. Das klappt beim text auch, das Bild ist jedoch vertikal zentriert. Hab schon alle möglichen Einstellungen vorgenommen, im Browser hat das nichts geholfen.

Danke.

Gruß, Daniel Top
 
X
Baschi3
Beiträge: 294
9. Mär 2004, 08:57
Beitrag #2 von 10
Beitrag ID: #74234
Bewertung:
(1956 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Una problema


Eigendlich müsste

<table>
<tr>
<td valign="top">
Bild
</td>
<td valign="top">
Text
</td>
</tr>
</table>

den gewünschten Effekt erzielen.
Sonst poste mal deinen Code und nenne den Browser mit Problemen.

Franz
als Antwort auf: [#74220] Top
 
Philyra
Beiträge: 509
9. Mär 2004, 16:05
Beitrag #3 von 10
Beitrag ID: #74331
Bewertung:
(1956 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Una problema


Hi Franz,

vielen Dank. hab gleich mal nachgeschaut. Es ist schon "top" eingestellt. Im IE erscheinen die beiden Zelleninhalte jedoch vertikal auf Mittelachse. Ich hatte dieses Problem schon diverse Male, konnte es in der Vergangenheit immer wieder durch ewiges Rumprobieren lösen. Das will diesmal nicht klappen.

Gruß, Daniel

<table width="669" border="0" cellspacing="80" cellpadding="0">
<tr>
<td width="252"><p><img src="logo.png" alt="blabla" width="250" height="110" align="top" /></p>
</td>
<td width="187" class="text"><p class="head01">blabla</p>
</td>
</tr>
</table></td>
als Antwort auf: [#74220] Top
 
Kusi
Beiträge: 1398
9. Mär 2004, 17:28
Beitrag #4 von 10
Beitrag ID: #74350
Bewertung:
(1956 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Una problema


Hi
Hast du schon mal den Cache vom Browser gelöscht?

Gruss
Kusi

http://www.k-k.ch
als Antwort auf: [#74220] Top
 
jrandi
Beiträge: 791
9. Mär 2004, 18:50
Beitrag #5 von 10
Beitrag ID: #74367
Bewertung:
(1956 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Una problema


probier mal das : align in den td.tag und vorallem das <p> raus vor dem bild, denn dies macht dir abstand :

<td width="252" align="top"><img src="logo.png" alt="blabla" width="250" height="110">

have a lot of fun
jurg
als Antwort auf: [#74220] Top
 
SabineP  M 
Beiträge: 7586
9. Mär 2004, 19:25
Beitrag #6 von 10
Beitrag ID: #74374
Bewertung:
(1956 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Una problema


Das war fast richtig :-)

align="top" gibt es nicht für Zellen, es heißt valign="top"

<td width="252" valign="top"><img src="logo.png" alt="blabla" width="250" height="110">

Horizontale und vertikale Ausrichtung in Tabellen:
http://www.edition-w3.de/...tables.html#h-11.3.2

Gruß Sabine
als Antwort auf: [#74220]
(Dieser Beitrag wurde von SabineP am 9. Mär 2004, 19:27 geändert)
Top
 
Philyra
Beiträge: 509
9. Mär 2004, 19:29
Beitrag #7 von 10
Beitrag ID: #74376
Bewertung:
(1956 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Una problema


hey jurg,
<p> raus, that's the spirit!
Vielen Dank.
Daniel
als Antwort auf: [#74220] Top
 
Philyra
Beiträge: 509
11. Mär 2004, 00:02
Beitrag #8 von 10
Beitrag ID: #74557
Bewertung:
(1956 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Una problema


Das Thema nervt mich. Es hat erst geklappt. Nun habe ich die Bilder tauschen müssen. Die align/valign-Parameter haben in Dreamweaver nicht die geringste Wirkung. Auch css-Einstellungen helfen nichts.

Ich habe jetzt mal eine neue Datei angelegt ohne css. Da ist es genau das gleiche. align="top" hat überhaupt keine Auswirkungen. Es wird immer zentriert.

Ich machs jetzt mit Ebenen. Gibts bei der Ebenenposition Unabwägbarkeiten bei den veschiedenen Browsern?

Gruß, Daniel
als Antwort auf: [#74220]
(Dieser Beitrag wurde von Philyra am 11. Mär 2004, 00:28 geändert)
Top
 
jrandi
Beiträge: 791
11. Mär 2004, 10:29
Beitrag #9 von 10
Beitrag ID: #74595
Bewertung:
(1956 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Una problema


sorry, habe mich geirrt, sieh nochmals nach was Sabine gepostet hat :

valign="top"

ansonsten stell mal wieder den quellcode ins forum, sonst können wir dir nicht gut helfen.

gruss
jurg
als Antwort auf: [#74220] Top
 
Philyra
Beiträge: 509
28. Mär 2004, 17:55
Beitrag #10 von 10
Beitrag ID: #77271
Bewertung:
(1956 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Una problema


Hallo, vielen Dank für Eure Hilfe. Habe das Problem lösen können: Die vertikale Ausrichtung muß eingestellt sein, bevor die Elemente in die Zellen eingefügt werden. Ich verstehe das zwar nicht, aber jetzt kann ich wenigstens vertikalisieren :)
Gruß, Daniel
als Antwort auf: [#74220] Top
 
X