hilfdirselbst.ch
Facebook Twitter gamper-media
Anonym
Beiträge: 22827
22. Jun 2004, 15:43
Beitrag #1 von 10
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

automatische Softwareaktualisierung funktioniert nicht mehr


Hallo Leute,

seit ca. 1 Woche bricht die autom. Softwareaktualisierung ab und ich bekomme etwa folgende Fehlermeldung: "Netzwerkfehler, Ressource mit 0 Bytes (-1014). Verbindung zum Internet überprüfen."
Also, die Verbindung zum Internet ist einwandfrei.
Diese Meldung taucht auf unseren G5-Rechnern (OSX 10.3.4) auf. Ging die ganze Zeit einwandfrei.
Hat jemand eine Idee? Wäre für Hilfe sehr dankbar!

Gruß, Sabine Top
 
X
Dr. Gonzo
Beiträge: 2989
22. Jun 2004, 15:51
Beitrag #2 von 10
Beitrag ID: #92591
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

automatische Softwareaktualisierung funktioniert nicht mehr


taucht die meldung denn auf meheren macs auf? vielleicht eine firewall oder so...?

gruss säsch
---------
http://www.saesch.ch
als Antwort auf: [#92587] Top
 
Anonym
Beiträge: 22827
22. Jun 2004, 16:15
Beitrag #3 von 10
Beitrag ID: #92603
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

automatische Softwareaktualisierung funktioniert nicht mehr


Hallo Säsch,
wir haben 2 Rechner mit OS 10.3.4 im Netz. Bei beiden Rechnern tritt der Fehler auf. Die Softwareaktualisierung lief allerdings vorher auch schon mit Firewall.

Gruß Sabine
als Antwort auf: [#92587] Top
 
Dr. Gonzo
Beiträge: 2989
22. Jun 2004, 16:52
Beitrag #4 von 10
Beitrag ID: #92613
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

automatische Softwareaktualisierung funktioniert nicht mehr


hi sabine

ich kann mir nur schwer vorstellen, dass bei beiden g5-macs rein zufällig die software-aktualisierung zeitgleich nicht mehr geht. ein software-fehler scheint mir da recht unwahrscheinlich... es müsste also fast etwas anderes sein (was beide macs betrifft...)

gruss säsch
---------
http://www.saesch.ch
als Antwort auf: [#92587] Top
 
Thomas Kaiser  M 
Beiträge: 1299
22. Jun 2004, 17:11
Beitrag #5 von 10
Beitrag ID: #92616
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

automatische Softwareaktualisierung funktioniert nicht mehr


Hallo,

mal Terminal.app (Dienstprogramme) aufreißen und dort -- auch als normaler Benutzer --

softwareupdate --list

eingeben. Der Software Update-Mechanismus versucht, eine Verbindung mit zwei Apple-Servern aufzubauen. Vielleicht läuft dabei etwas schief (selbst kleine Änderungen im Netzwerk können oft große Wirkung haben) und das Kommandozeilen-Werkzeug gibt sich einen Tuck gesprächiger als das bunte GUI-Pendant?

Gruss,

Thomas Kaiser
als Antwort auf: [#92587] Top
 
Anonym
Beiträge: 22827
22. Jun 2004, 17:29
Beitrag #6 von 10
Beitrag ID: #92620
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

automatische Softwareaktualisierung funktioniert nicht mehr


Hallo Thomas,
danke für den Tip. Die Meldung vom Terminal lautet:
connection:DidFailWithError: zero byte resource
Softwareupdate: Could not connect.

Das klingt zwar gesprächig, sagt aber leider nicht mehr als ich schon weiß.

Die ganze Sache kommt mir langsam ziemlich spanisch vor (Ole! :-)
Aber ich geb die Hoffnung noch nicht auf.

Grüße, Sabine
als Antwort auf: [#92587] Top
 
Thomas Kaiser  M 
Beiträge: 1299
22. Jun 2004, 17:43
Beitrag #7 von 10
Beitrag ID: #92623
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

automatische Softwareaktualisierung funktioniert nicht mehr


Hi,

naja, meines Erachtens ist

> connection:DidFailWithError: zero byte resource
> Softwareupdate: Could not connect.

schon um Klassen gesprächiger und weist in der Tat auf ein Verbindungsproblem hin (und nicht auf evtl. defekte Resourcen des Software-Update Mechanismus, die aufgrund $irgendwas auf den Macs defekt gegangen sind). Tante Google findet auch einen interessanten Treffer, wenn man sie mit "zero byte resource" füttert.

Ich würde mal mitloggen (lassen), was da an Traffic passiert. Für den Hausgebrauch nehme ich dazu meist tcpdump und ethereal aber das dürfte für Fernsupport etwas heftig sein? ;-)

Gibt es einen Netzwerk-Admin? Falls ja, den löchern -- er soll parallel in seinen Logs gucken. Evtl. ist es ja auch nur ein Proxy-Fehler bzw. eine Umstellung beim Proxy?

Probier doch nochmals Folgendes aus dem Terminal heraus:

curl http://swscan.apple.com/...s/scanningpointX.xml

(alternativ einfach die Adresse von dem Mac aus im Browser aufrufen)

Da sollte eine ganze Menge Zeugs auf dem Bildschirm erscheinen...

Gruss,

Thomas
als Antwort auf: [#92587] Top
 
Anonym
Beiträge: 22827
23. Jun 2004, 11:24
Beitrag #8 von 10
Beitrag ID: #92756
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

automatische Softwareaktualisierung funktioniert nicht mehr


Hallo,

es ist wirklich viel Text erschienen, den ich aber leider nicht verstehe. So weit bin ich nicht in der Materie.

Gibt es vielleicht eine Möglichkeit, mit der ich mir als einfacher user eine Proxy-Umstellung oder einen Proxy-Fehler anzeigen lassen kann? Kann ich mir irgendwo anzeigen lassen, welchen Proxy der Apple-Server braucht? Alle anderen funktionieren ja einwandfrei.

Grüsse,
Sabine
als Antwort auf: [#92587] Top
 
Thomas Kaiser  M 
Beiträge: 1299
23. Jun 2004, 12:02
Beitrag #9 von 10
Beitrag ID: #92768
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

automatische Softwareaktualisierung funktioniert nicht mehr


Hallo Sabine,

die Ausgabe von dem Kram ist auch nicht für unsere Augen gedacht. Das ist bloß stumpfes XML, das dem SoftwareUpdate Framework sagt, wo was zu holen ist.

Wichtig ist, daß "curl" nicht die Proxy-Einstellungen des Systems benutzt (sondern einer sog. Environment-Variable namens $HTTP_PROXY gehorcht), ein Browser wie Safari aber bspw. schon.

Insofern könnte es Sinn machen, wenn Du das Ganze nochmal parallel in Safari probierst.

Im Browser stehen ganz zu Beginn der Zeichenkolonnen auch noch drei weitere Adressen, die mit http:// respektive https:// starten. Die lassen sich allerdings nicht wirklich sinnvoll per Browser testen, da diese normalerweise vom SoftwareUpdate Framework als Formular angesprochen werden, d.h. da Daten übergeben werden (die Systemkonfiguration eben, damit anschließend auch geklärt ist, was upzudaten ist -- Details finden sich hier: http://www.cunap.com/...ts/osx/exploit.html)

Wegen den Proxyeinstellungen: Der SoftwareUpdate-Mechanismus benutzt zum einen HTTP (Port 80) und zum anderen HTTPS (Port 443). In den System Preferences sind beide evtl. getrennt eingestellt. Ich würde das daher mal überprüfen, ob diese sinnvolle Werte (mit dem Netzwerk-Admin abzustimmen) haben bzw. ob URLs mit https:// am Anfang überhaupt generell funktionieren (bspw. die Homebanking-Seiten der eigenen Bank).

Wenn das alles funktioniert ist es, ohne auf die Netzwerk-Pakete schauen zu können, reichlich müssig, weiterzuforschen. Die Ursachen für dieses spezifische Problem können leider ziemlich beliebig sein und müssen nicht in Eurem Netz den Ursprung haben, sondern könnten bspw. auch beim Provider ihre Ursache haben...

Gruss,

Thomas
als Antwort auf: [#92587] Top
 
Anonym
Beiträge: 22827
23. Jun 2004, 13:13
Beitrag #10 von 10
Beitrag ID: #92795
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

automatische Softwareaktualisierung funktioniert nicht mehr


Hallo Thomas,

jetzt ist der Zeitpunkt gekommen, wo ich wohl doch eine "Vor-Ort"-Hilfe brauche. Dank Deiner Hilfe habe ich jetzt schonmal verschiedene Ansatzpunkte.

Vielen Dank für Deine Unterstützung!

Und ganz allgemein will ich noch sagen, daß ich die "hilfdirselbst"-Foren super finde! Werde sicher öfter mal vorbeischaun.

Grüsse
Sabine
als Antwort auf: [#92587] Top
 
X