hilfdirselbst.ch
Facebook Twitter gamper-media
a.manke
Beiträge: 3
9. Mär 2004, 16:46
Beitrag #1 von 5
Bewertung:
(1769 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

externen Film laden und steuern


Hallo, ich habe folgendes Problem.
Ich möchte für eine Präsentaion einen anderen Directorfilm in eine neue Präsentation laden und dort direkt auf den angewählten Frame springen.
Das reinladen des Filmes funktioniert, aber wie spreche ich nun den gewünschten Frame an?

Bin langsam am verzweifeln. Vielen Dank im Vorraus für Eure Hilfe
Gruß Anja Top
 
X
donkey shot
Beiträge: 1416
9. Mär 2004, 16:59
Beitrag #2 von 5
Beitrag ID: #74339
Bewertung:
(1769 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

externen Film laden und steuern


Das geht eigentlich ganz einfach mit der folgenden Zeile:

go to frame x of movie("xxx")

oder, wenn Du einen Marker ansprechen willst

go to frame("xyz") of movie("xxx")

Du mußt natürlich aufpassen, wo Du das Skript anbringst. Bei einigen eventHandlern (zB. prepareFrame) passiert nämlich unter Umständen nix.

grüsse,

Christof
als Antwort auf: [#74336] Top
 
Anonym
Beiträge: 22827
9. Mär 2004, 17:06
Beitrag #3 von 5
Beitrag ID: #74342
Bewertung:
(1769 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

externen Film laden und steuern


mhm soweit war ich auch schon, das funzt irgendwie ncith udn ich weiß nicht, wie ich das Debuggen soll. Habe das Skript dikret auf den Button gezogen, liegt da vielleicht der Fehler?

PS: danke für deine schnelle hilfe
als Antwort auf: [#74336] Top
 
donkey shot
Beiträge: 1416
9. Mär 2004, 17:11
Beitrag #4 von 5
Beitrag ID: #74344
Bewertung:
(1769 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

externen Film laden und steuern


Was ist denn genau das Problem?!

Ich hatte mal einen Skriptfehler, der nur im Projektor auftrat und habe mich totgesucht und nix gefunden. Da hatte ich ein "go to movie"-Skript auch an einem Button angebracht. Das ganze ließ sich nur dadurch lösen, daß ich den Abspielkopf zu einem leeren Frame geschickt habe, wo im Frameskript dann der Befehl "go to movie("blabla")" stand. Da war dann der Skriptfehler weg.

Vielleicht probierst du das auch mal?

grüsse,

Christof
als Antwort auf: [#74336] Top
 
a.manke
Beiträge: 3
9. Mär 2004, 17:22
Beitrag #5 von 5
Beitrag ID: #74347
Bewertung:
(1769 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

externen Film laden und steuern


Danke, dann versuche ich das auch mal. Denke da liegt der Hase begraben.

Danke für den Tipp
Gruß Anja
als Antwort auf: [#74336] Top
 
X