hilfdirselbst.ch
Facebook Twitter gamper-media
Tipps und Tricks zu Adobe GoLive von Dirk Levy, GoLive FAQ's von Randolph Sterna
björn
Beiträge: 44
26. Mär 2003, 15:29
Beitrag #1 von 13
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


Guten Tach!

Ich muss euch leider nochmal stören.

Hat noch irgendwer folgendes Problem oder weiß die Lösung?

Jedesmal wenn ich ein Rollover in eine Zelle einer Tabelle packe, bekomme ich folgende Meldungen:

CSInit undefined und
Objekt erwartet

Ich hab alles so gemacht, wie ich es in GL5 auch schon getan habe, da lief es. Momentan arbeite ich mit GL 6.0.1

Bitte helft mir! Ich verzweifle!

Danke!
Gruss,
Björn
Top
 
X
Urs Gamper  A  p
Beiträge: 3683
26. Mär 2003, 15:33
Beitrag #2 von 13
Beitrag ID: #29402
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


kannst du uns genau erklären, wie du die rollover einfügst? es gibt da etwa drei verschiedene möglichkeiten. und teile uns zusätzlich mit, wie du die rollover-bilder benannt hast.
(z.b: produkte.gif / produkte-over.gif)

ähm - entschuldige dich doch nicht - das forum lebt nur wegen der fragen und der antworten. sonst bräuchte es ja gar kein forum ;)


--------------------------------------
http://www.gamper.ch
Gamper Internet-Auftritte und Schulung
als Antwort auf: [#29399]
(Dieser Beitrag wurde von Urs Gamper am 26. Mär 2003, 15:34 geändert)
Top
 
björn
Beiträge: 44
26. Mär 2003, 15:54
Beitrag #3 von 13
Beitrag ID: #29406
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


Ich hab´s schon ganz einfach probiert:

Standard-Tabelle auf leere Seite gezogen, Standard-Rollover in eine Zelle gezogen, Bild (angebot.gif) ins Rollover gelegt. Ein zweites oder drittes Bild gebrauche ich nicht, da ich auf das Rollover nachher nur eine Bildwechsel-Aktion legen will.

In der Vorschau bekomme ich dann folgende Fehler:

CSAct ist undefiniert (Sorry, beim erstenmal falsch angegeben)
und danach: Objekt erwartet

Hab´s auch schon mit einem normalen Bild probiert, diesem im Rollover-Reiter einen Namen gegeben, aber nur das erste Bild aktiviert. Dann läuft´s. Aber auch nur solange, bis ich diesem Bild eine Aktion zuweise. Dann kommt der gleiche Fehler.
als Antwort auf: [#29399] Top
 
Urs Gamper  A  p
Beiträge: 3683
26. Mär 2003, 16:00
Beitrag #4 von 13
Beitrag ID: #29407
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


ein rollover nimmst du nur dann, wenn du zwei gleich grosse bilder hast, welche sich beim überfahren mit der maus austauschen sollten. (das ist ja eigentlich ein normal bildwechsel)
wenn das ausgangsbild aber keinen rollover aufweisen soll, setze doch ein ganz normales bild und dort drauf die aktion.
hast du allenfalls eine url, wo das ganze nachvollzogen werden kann?
--------------------------------------
http://www.gamper.ch
Gamper Internet-Auftritte und Schulung
als Antwort auf: [#29399] Top
 
björn
Beiträge: 44
26. Mär 2003, 16:06
Beitrag #5 von 13
Beitrag ID: #29410
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


Die Adresse lautet:
http://www.getraenke-kotten.de
Die grüne Zeile soll das Hauptmenü sein, in der weißen Zeile (momentan ein weißes Bild) sollen, je nachdem auf welchem Meunüpunkt man sich im Hauptmenü mit dem Mauszeiger befindet, die Unterpunkte gezeigt werden.
als Antwort auf: [#29399] Top
 
Urs Gamper  A  p
Beiträge: 3683
26. Mär 2003, 16:32
Beitrag #6 von 13
Beitrag ID: #29420
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


dann habe ich das vorhin schon richtig mitbekommen. das ist in diesem sinn kein rollover sondern auf den buttons sind aktionen mit einem bildwechsel gesetzt, welcher bei mauseintritt bzw. mausaustritt den balken "blakum" wechseln. ich habe auch gesehen, dass du diesen unter weitere korrekt beschriftet hast.
der button "Angebot" hat auch schon eine aktion bei mauseintritt. dies scheint mir alles korrekt zu sein.
tritt der fehler bereits in der gl-vorschau bzw. lokal im browser auf oder erst auf dem server?
ich kann mir das problem zur zeit nicht richtig erklären.

--------------------------------------
http://www.gamper.ch
Gamper Internet-Auftritte und Schulung
als Antwort auf: [#29399] Top
 
SabineP  M 
Beiträge: 7586
26. Mär 2003, 16:42
Beitrag #7 von 13
Beitrag ID: #29422
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


björn,

The requested URL /kotten.css was not found on this server.

Da fehlt erstmal die CSS-Datei.

Gruß Sabine
als Antwort auf: [#29399] Top
 
björn
Beiträge: 44
26. Mär 2003, 22:47
Beitrag #8 von 13
Beitrag ID: #29453
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


ja stimmt, die .css datei fehlt noch, ist aber weiter noch nicht schlimm, da sie noch nicht wirklich gebraucht wird.

ausserdem tritt der fehler schon in der gl-vorschau und offline im browser auf (fehler auf der seite), natürlich dann auch auf dem server.
hat das eventuell mit fehlender java-unterstützung zu tun? hab nämlich gerade mein betriebssystem von grund auf neu und weiß nicht, wie dass standardmäßig mit java ist.
als Antwort auf: [#29399] Top
 
SabineP  M 
Beiträge: 7586
26. Mär 2003, 23:23
Beitrag #9 von 13
Beitrag ID: #29454
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


>>ja stimmt, die .css datei fehlt noch, ist aber weiter noch nicht schlimm,

björn, die Fehler die der Webserver anzeigt sind entscheidend.
Ich bekomme nur einen Error 404 not found, wenn ich Deine URL im Browser eintippe.
Auf Deiner Festplatte kann ja kein Mensch nachsehen, um den Fehler einzukreisen.

Falls Du der Meinung bist, daß Du die CSS-Datei gar nicht brauchst, dann lösche doch den Verweis aus dem Quellcode.

<link href="kotten.css" rel="stylesheet" media="screen">

Gruß Sabine
als Antwort auf: [#29399] Top
 
björn
Beiträge: 44
27. Mär 2003, 11:14
Beitrag #10 von 13
Beitrag ID: #29490
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


sorry sabine. ich hab die kotten.css jetzt hochgeladen.
das behebt aber leider noch nicht den anderen fehler, den ich mir irgendwie gar nicht erklären kann.
als Antwort auf: [#29399] Top
 
SabineP  M 
Beiträge: 7586
27. Mär 2003, 11:24
Beitrag #11 von 13
Beitrag ID: #29495
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


Schau mal nach ob sich die Javscript-Datei auch auf dem Webserver befindet:
http://www.getraenke-kotten.de/...Items/CSScriptLib.js
Irgendetwas stimmt mit dieser Datei nicht.
Gruß Sabine
als Antwort auf: [#29399] Top
 
björn
Beiträge: 44
27. Mär 2003, 12:07
Beitrag #12 von 13
Beitrag ID: #29502
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


die datei ist hochgeladen.
allerdings ist mir aufgefallen, dass sie im gl und im netz 0 byte groß ist.

das ist wahrscheinlich nicht normal. wie kann ich sie neu generieren lassen?
als Antwort auf: [#29399] Top
 
björn
Beiträge: 44
27. Mär 2003, 12:16
Beitrag #13 von 13
Beitrag ID: #29503
Bewertung:
(2051 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

fehlermeldungen beim einsatz von rollover


Ich hab die Lösung!

Erstmal DANKE für eure Bemühungen.

Irgendwie wurde beim erstellen der Seite die CSScriptLib.js nicht richtig erstellt. Ich habe sie nun von woanders kopiert und siehe da, es läuft!

Gruss, Björn
als Antwort auf: [#29399] Top
 
X