hilfdirselbst.ch
Facebook Twitter gamper-media
dasistideal
Beiträge: 21
12. Feb 2017, 12:25
Beitrag #1 von 2
Bewertung:
(1140 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Apache2: VirtualHost wird nicht aufgelöst


Hi,
da sich PHP und MySQL ja auch irgendwo mit Servern beschäftigen, dachte ich, passt dieser Bereich im entferntesten zu meinem Problem.

Und zwar habe ich seit gestern eine VM und einen DNS-Server. Die IPs im Intranet sind wie folgt:
DNS-Server: 192.168.1.2
VM: 192.168.1.3

Die VM soll zwei Seiten hosten, dazu habe ich zwei VirtualHosts erstellt. Das Problem ist, dass die Seite mit der Subdomain vernünftig aufgelöst wird, die ohne allerdings nicht.

Meine hosts-file sieht so aus:
192.168.1.3 test.local
192.168.1.3 test.test.local

Der Apache-Configtest gibt auch "Syntax OK" zurück.

Der Ping von der VM, als auch vom DNS-Server funktioniert nicht beiden Seiten. Von zwei anderen Testgeräten ist im Browser allerdings nur test.test.local erreichbar, test.local allerdings nicht. "nslookup" funktioniert im Terminal auch für beide, "ping" allerdings nur für test.test.local

Wo könnte das Problem liegen?

PS: Wenn ich den VirtualHost und den Eintrag in /etc/hosts von test.local auf a.test.local ändere, funktioniert der Aufruf, aber wieso?
Top
 
X
dasistideal
Beiträge: 21
12. Feb 2017, 13:39
Beitrag #2 von 2
Beitrag ID: #555513
Bewertung:
(1112 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Apache2: VirtualHost wird nicht aufgelöst


Ich habe jetzt noch ein bisschen rumprobiert: Sobald man die Domain-Endung .local verwendet, braucht man eine Subdomain, sonst funktioniert es nicht.

Ist das richtig, bzw. was kann man dagegen tun, dass es auch ohne Subdomain funktioniert?
als Antwort auf: [#555511] Top