hilfdirselbst.ch
Facebook Twitter gamper-media
Pozor
Beiträge: 892
25. Apr 2003, 00:15
Beitrag #1 von 12
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


hallo,

ich habe ein kleines problem mit PHP_SELF es schein immer leer zu sein.

<?php
echo "<form method=\"post\" action=\"$PHP_SELF\">";
?>

<form method="post" action="<?echo $PHP_SELF;?>">

beides ergibt diesen ausdruck:

<form method="post" action="">

An was liegt das, kann das an der php.ini liegen?
dort unter dem infofile zeigt es folgendes an:
PHP_SELF no value

Beim Explorer stört dieser effekt nicht er sendet anscheinend die infos automatisch ans das selbe skript zurück, nur beim netscape gets nicht mehr.

gruss Stefan
(Dieser Beitrag wurde von Pozor am 9. Apr 2005, 12:14 geändert)
Top
 
X
Miro Dietiker
Beiträge: 699
25. Apr 2003, 06:17
Beitrag #2 von 12
Beitrag ID: #32913
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


Hi!

Mach mal folgendes:
<?PHP
phpinfo();
?>

Und schau dir die Konfiguration deines Servers als Summary an..
Was steht da unter PHP_SELF drin?

Was bringt <? echo $GLOBALS['PHP_SELF'] ?> ???

GrEeZ: Miro Dietiker
als Antwort auf: [#32909] Top
 
Husten
Beiträge: 8
25. Apr 2003, 09:48
Beitrag #3 von 12
Beitrag ID: #32938
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


wie wärs mit $_SERVER['PHP_SELF'] oder in phpversionen älter als 4.1.0 $HTTP_SERVER_VARS['PHP_SELF']

als Antwort auf: [#32909] Top
 
Miro Dietiker
Beiträge: 699
25. Apr 2003, 10:27
Beitrag #4 von 12
Beitrag ID: #32945
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


Du sagst es .. hatte das ganz vergessen mit dem _SERVER ;) Sorry

GrEeZ: Miro Dietiker
als Antwort auf: [#32909] Top
 
Pozor
Beiträge: 892
25. Apr 2003, 12:11
Beitrag #5 von 12
Beitrag ID: #32966
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


hallo,

hat alles den selben effekt.

habe jetzt phpinfo() ins file eingebaut dort sieht man es jetzt.

Wie schon im ersten Post

unter PHP_SELF steht no value

gruss Pozor
als Antwort auf: [#32909] Top
 
Husten
Beiträge: 8
25. Apr 2003, 14:28
Beitrag #6 von 12
Beitrag ID: #32990
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


ja dann hast du garkeinen server ;)
als Antwort auf: [#32909] Top
 
Pozor
Beiträge: 892
25. Apr 2003, 14:33
Beitrag #7 von 12
Beitrag ID: #32993
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


???

Was soll ich darunter verstehen?

es ist ein sogenanter "virtueller" Server (das ist ja der Normalfall, die wenigsten haben einen eigenen Server wie Miro), so wie man ihn bei einem normalem Host mieten kann.

als Antwort auf: [#32909]
(Dieser Beitrag wurde von Pozor am 25. Apr 2003, 14:38 geändert)
Top
 
Husten
Beiträge: 8
25. Apr 2003, 14:36
Beitrag #8 von 12
Beitrag ID: #32995
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


es war ein witz :)
als Antwort auf: [#32909] Top
 
Pozor
Beiträge: 892
29. Apr 2003, 14:01
Beitrag #9 von 12
Beitrag ID: #33354
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


Hallo,

danke für eure antworten,

es lag daran (sagen der Support):

Verwenden Sie bitte PHP_REQUEST anstelle von PHP_SELF. Ist ein offizieller Bug
der aktuelle PHP Version.


naja, wenn ned anders geht...

gruss Pozor
als Antwort auf: [#32909] Top
 
Miro Dietiker
Beiträge: 699
29. Apr 2003, 21:00
Beitrag #10 von 12
Beitrag ID: #33419
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


Empfehlung im Hinblick auf Serverwechsel:

Variable umkopieren!

<?PHP
if(isset($PHP_REQUEST)) { $PHP_SELF = $PHP_REQUEST; }
?>

GrEeZ: Miro Dietiker
als Antwort auf: [#32909] Top
 
Pozor
Beiträge: 892
29. Apr 2003, 22:03
Beitrag #11 von 12
Beitrag ID: #33422
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


hallo,

das einzige problem ist nur noch, dass PHP_REQUEST nicht definiert ist.
Habe auch in der Hilfedatei (.chm) und in phpinfo() habe ich nichts darüber gefunden.


gruss Pozor
als Antwort auf: [#32909]
(Dieser Beitrag wurde von Pozor am 9. Apr 2005, 12:14 geändert)
Top
 
Pozor
Beiträge: 892
30. Apr 2003, 14:53
Beitrag #12 von 12
Beitrag ID: #33487
Bewertung:
(1809 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

kleines problem mit PHP_SELF


hallo,


Der Support hatte sich vertan es sollte schon REQUEST_URL sein


gruss Pozor

PS: jetzt funtzt auch mit net(t)scape
als Antwort auf: [#32909] Top
 
X