hilfdirselbst.ch
Facebook Twitter gamper-media
Anonym
Beiträge: 22827
5. Mär 2004, 01:05
Beitrag #1 von 7
Bewertung:
(1266 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

loadmovie für director


hallo!
wie kann ich mit director eine eigene ladeanzeige für eine shockwave-homepage erstellen? Top
 
X
gec
Beiträge: 18
8. Mär 2004, 23:03
Beitrag #2 von 7
Beitrag ID: #74207
Bewertung:
(1266 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

loadmovie für director


hallo

in der skript-library (unter kategorie: internet - streaming) gibt es das verhalten "Progress Bar for Streaming Movies", dieses verhalten kannst du auf ein sprite, welches als balken dient, zuweisen.
gemäss skript-beschreibung muss der balken ein shape member sein, optional kannst du einen textmember angeben, der die prozentuale ladegrösse anzeigt.

gruess
cinzia
als Antwort auf: [#73561] Top
 
eisenstein
Beiträge: 46
8. Mär 2004, 23:40
Beitrag #3 von 7
Beitrag ID: #74212
Bewertung:
(1266 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

loadmovie für director


Die "eigene" Variante:

Aus dem Array getStreamStatus(id) kannst du die #bytesTotal und #bytesSoFar aus dem Streamingstatus herauslesen.
Mittels korrektem umrechnen in Prozent kannst dann deine Fieldmembers ,Vektorbalken etc. den aktuellen Stand der Dinge anzeigen lassen.

gruss

eisenstein
als Antwort auf: [#73561] Top
 
Anonym
Beiträge: 22827
9. Mär 2004, 00:06
Beitrag #4 von 7
Beitrag ID: #74214
Bewertung:
(1266 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

loadmovie für director


vielen Dank!

:o)
als Antwort auf: [#73561] Top
 
Anonym
Beiträge: 22827
3. Jun 2004, 22:07
Beitrag #5 von 7
Beitrag ID: #88930
Bewertung:
(1266 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

loadmovie für director


Ich habe zwar nicht die Frage gestellt habe aber das gleiche Problem.

@gec Das habe ich schon versucht aber es funktioniert nicht richtig. der Film wird erst abgespielt, wenn auch alle Darsteller geladen sien. Die default Progress Bar läuft also üblich ab, dannach erschein kurz mein selbstgestalltete mit 100% und der Film beginnt. Gibt es da vieleicht noch etwas was man beachten muß?
als Antwort auf: [#73561] Top
 
gec
Beiträge: 18
4. Jun 2004, 17:14
Beitrag #6 von 7
Beitrag ID: #89098
Bewertung:
(1266 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

loadmovie für director


hoi zäme

das progress bar verhalten erledigt nur die anzeige des ladebalkens, zusätzlich braucht es eine timeline steuerung, also der abspielkopf muss warten bis alles oder teile davon geladen sind. das kann man auch mit verhalten machen oder dem lingo befehl frameReady()
beispiel:
--------------------------
on exitFrame me
if frameReady(40) then
go to the frame + 1
else
go to the frame
end if
end
-------------------------

und zuletzt muss man dem director movie sagen, er soll sofort mit abspielen beginnen: unter menu modify-movie-playback das kästchen streaming aktivierien und im frames feld 1 eingeben.

hope it works ...
gruess
cinzia

als Antwort auf: [#73561] Top
 
Anonym
Beiträge: 22827
5. Jun 2004, 21:30
Beitrag #7 von 7
Beitrag ID: #89289
Bewertung:
(1266 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

loadmovie für director


Danke gec

Es hat bei mir geklappt:)
als Antwort auf: [#73561] Top
 
X