[GastForen Archiv Adobe GoLive ü = ü

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Archiv - Archivierte Foren
Themen
Beiträge
Moderatoren
Letzter Beitrag

ü = ü

tomi58
Beiträge gesamt: 38

22. Nov 2007, 21:54
Beitrag # 1 von 6
Bewertung:
(4742 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Liebe GoLivler

Was mache ich falsch:

Wenn ich im GoLive auf einer Webseite das Wort "für" schreibe, erscheint im Internet nachher "für".

Herzlichen Dank für eure Antwort.
X

ü = ü

Dirk Levy
  
Beiträge gesamt: 9460

22. Nov 2007, 21:58
Beitrag # 2 von 6
Beitrag ID: #323829
Bewertung:
(4739 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Das liegt wahrscheinlich am Encoding
für das Dokument, was ist bei Dir eingestellt?

Und Achtung UTF-8 geht leider nicht bei jedem
Hoster in Deutschland, ein Trauerspiel, aber
Realität....


als Antwort auf: [#323826]

ü = ü

Tömsken
Beiträge gesamt: 720

3. Dez 2007, 02:30
Beitrag # 3 von 6
Beitrag ID: #325339
Bewertung:
(4626 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Klingt so, als ob dein Doc mit Unicode-Codierung angelegt wäre - aber nicht so ganz richtig... ;)

So geht's richtig:
1. Speichere die Seite(n) als Unicode (ohne BOM) (kann sein, dass GL das eh autom. macht - weiß ich nicht)
2. Falls PHP verfügbar, dann stell' das an den Anfang einer jeden Seite:
<?php
header( 'content-type: text/html; charset=UTF-8' );
?>
3. In den <head>-Bereich schreibe als Erstes(!):
<head>
<meta http-equiv="content-type" content="text/html; charset=UTF-8">
...
</head>


Antwort auf [ Dirk Levy ] Und Achtung UTF-8 geht leider nicht bei jedem
Hoster in Deutschland, ein Trauerspiel, aber
Realität....


Staun... dazu müssten die ihre Server explizit auf eine bestimmte Codierung voreinstellen und zudem das Überschreiben dieses Settings in der htaccess (falls Apache...) verbieten. Warum sollte sich jemand diese Mühe machen?

Bye, Tom


als Antwort auf: [#323829]

ü = ü

Dirk Levy
  
Beiträge gesamt: 9460

3. Dez 2007, 09:11
Beitrag # 4 von 6
Beitrag ID: #325359
Bewertung:
(4601 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Die machen sich nicht die Mühe,
sondern die haben es einfach so
eingestellt......

Und haben scheinbar wenig Lust
sich die Mühe zu machen, das zu
ändern... ;-)


als Antwort auf: [#325339]

ü = ü

jlo
Beiträge gesamt: 93

19. Dez 2007, 19:05
Beitrag # 5 von 6
Beitrag ID: #327906
Bewertung:
(4435 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
In vorherigen Versionen hat Golive die Eingabe von "ä" im Layoutmodus automatisch in "&auml;" im Quellcode umgewandelt. macht Golive das jetzt nicht mehr?


als Antwort auf: [#325359]

ü = ü

SabineP
Beiträge gesamt: 7586

19. Dez 2007, 19:54
Beitrag # 6 von 6
Beitrag ID: #327910
Bewertung:
(4428 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Ich denke das hängt von der verwendeten Zeichencodierung ab.

http://de.selfhtml.org/...htm#zeichenkodierung

>> "ä" im Layoutmodus automatisch in "&auml;"

Mit der Zeichenkodierung ISO-8859-1 ist das gar nicht nötig.
Ein "ä" darf da ruhig ein "ä" bleiben.


als Antwort auf: [#327906]
X