hilfdirselbst.ch
Facebook Twitter gamper-media
kaelin
Beiträge: 29
3. Jun 2004, 16:47
Beitrag #1 von 10
Bewertung:
(1732 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

CPU Nutzung plötzlich dauernd auf 30%!


Hallo zusammen

Seit 2 Tagen ist ohne nennenswerte Belastung durch Programme oder neue Dienste die CPU Nutzung plötzlich dauernd auf 30%! Vorher war sie ohne das eine Anwendung läuft bei etwa 1-3%.

Was kann das sein?
So läuft eine Webanwendung sehr langsam!

Vielen Dank
Peter Top
 
X
erbuc  M  S
Beiträge: 577
3. Jun 2004, 18:18
Beitrag #2 von 10
Beitrag ID: #88884
Bewertung:
(1732 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

CPU Nutzung plötzlich dauernd auf 30%!


Hi

Wenn sichtbar ist, dass die CPU 30% nutzt, sollte im Task Manager auch sichtbar sein, welcher Prozess es ist.

Gib uns doch ein wenig mehr Infos.

Gruss

Erich
als Antwort auf: [#88861] Top
 
kaelin
Beiträge: 29
4. Jun 2004, 08:26
Beitrag #3 von 10
Beitrag ID: #88959
Bewertung:
(1732 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

CPU Nutzung plötzlich dauernd auf 30%!


Hallo Erich

Gemäss "Prozesse" braucht der "Leerlaufprozess" fast die ganze Leistung!
Unten 2 Sreenshots meines PC's.

Bei der "Systemleistung" sieht man im letzten Fünftel den Start vom Photoshop.


http://www.dogwalking.ch/prozesse.gif
http://www.dogwalking.ch/systemleistung.gif

Wenn Du noch andere Infos brauchst, schreib mir einfach welche Du noch brauchst.

Vielen Dank

Gruss Peter
als Antwort auf: [#88861] Top
 
erbuc  M  S
Beiträge: 577
4. Jun 2004, 09:28
Beitrag #4 von 10
Beitrag ID: #88975
Bewertung:
(1732 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

CPU Nutzung plötzlich dauernd auf 30%!


Hi Peter

Die zwei Anzeigen wiedersprechen sich eigentlich.

Du schreibst ja "seite 2 Tagen" sei das Problem vorhanden.
Ich nehme mal an, dass Du weder neue HW noch neue SW installiert hast.

Hast Du die neuesten Patches geladen? Wenn nein, mach das mal zuerst.

Den Server hast Du sicher auch schon einmal neu gestartet. Wenn nein, mach es mal.

Kannst Du mal alle zusätzlichen Dienste und Programme wie z.B. Outlook, SQL, Virenscanner etc. nach und nach stoppen. Jeden einzeln. Und nach jedem gestoppten Prozess schauen, was die CPU macht.

Gruss
Erich
als Antwort auf: [#88861] Top
 
kaelin
Beiträge: 29
4. Jun 2004, 10:24
Beitrag #5 von 10
Beitrag ID: #88988
Bewertung:
(1732 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

CPU Nutzung plötzlich dauernd auf 30%!


Hoi Erich

Ich habe alles beendet was sich beenden lässt:

Programme, Virenscanner, Server, Dienste!

Das neuste Update für Win2000 habe ich auch und Spybot installiert und nach Spyware gefandet und alle zerstört.

Leider ist das Problem noch da!?

Was kann man noch machen?

Grüessli Peter
als Antwort auf: [#88861] Top
 
erbuc  M  S
Beiträge: 577
4. Jun 2004, 10:40
Beitrag #6 von 10
Beitrag ID: #88996
Bewertung:
(1732 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

CPU Nutzung plötzlich dauernd auf 30%!


Hi Peter

Dienste beendet und auch den Server mal neu gebootet und es soll immer noch 30% Last sein?

Das kann ich (fast) nicht glauben. Nimm den Server mal vom LAN und schau, was dann passiert.

Eine Ferndiagnose wird ansonsten immer schwieriger.

Wobei zu sagen ist, dass eine CPU-Belastung von 30% ja eigentlich nicht schlecht ist, denn die meisten Rechner stehen nur dumm rum und haben nichts zu tun.

Was für eine HW setzt Du überhaupt ein (Prozessor usw.)?

Hol die mal das Tool Process Explorer unter http://www.sysinternals.com/...eeware/procexp.shtml

Vielleicht hilft das noch etwas um gezielter die Prozesse zu tracken.

Gruss

Erich
als Antwort auf: [#88861] Top
 
kaelin
Beiträge: 29
4. Jun 2004, 13:47
Beitrag #7 von 10
Beitrag ID: #89056
Bewertung:
(1732 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

CPU Nutzung plötzlich dauernd auf 30%!


Hi Erich

Also vom Netz nehmen hat keine Wirkung!
Das Problem bei den 30% ist das sie unser Webtool das wir entwickeln,
jetzt auf meiner lokalen Maschine seit dem extrem langsam wurde.

So wurde ich überhaubt darauf aufmerksam!

HW:
Pentium 3/1GH
Hauptspeicher 916 MB

Habe den Process Explorer installiert und eine Screenshot gemacht.
http://www.dogwalking.ch/process_explorer.gif

Gruss Peter
als Antwort auf: [#88861] Top
 
erbuc  M  S
Beiträge: 577
4. Jun 2004, 14:04
Beitrag #8 von 10
Beitrag ID: #89067
Bewertung:
(1732 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

CPU Nutzung plötzlich dauernd auf 30%!


Hi Peter

Schau Dir den Screen Shot des Process Explorers selber mal an.

Die Hardware Interrupts belegen 22% CPU Leistung!! D.h. durch irgendwas wird das OS immer wieder behindert. Irgendwas greift dauernd auf die HW zu und unterbricht so das System bei seiner eigentlichen Arbeit.

Es gibt meines Erachtens nun (mindestens) drei Möglichkeiten:

1. Die Hardware ist "faul".
2. Irgendeine SW produziert diese Interrupts.
3. Eurer Rechner ist zu schwach.

Da ich kein Web-SW-Entwickluns-Spezi bin, kann ich nicht beurteilen, ob das Tool Schuld an dem Engpass ist. Aber ich habe es schon oft erlebt, dass sogenannte WEB-Based-Applikationne z.B. Speicher richtig gefressen haben.

Gruss

Erich
als Antwort auf: [#88861] Top
 
kaelin
Beiträge: 29
4. Jun 2004, 14:53
Beitrag #9 von 10
Beitrag ID: #89073
Bewertung:
(1732 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

CPU Nutzung plötzlich dauernd auf 30%!


Hi Erich

Ich habe die Lösung!

Es war die Grafikkarte, das heisst eigentlich deren Treiber:
Habe untenstehendes gelesen und bei mir nachgeschaut!
Vor etwa 2 Tagen hatte ich den Opera 7 Browser installiert und per Tastatur den Linken "Karteibereich" ausgeschaltet. Dabei hat es mir in diesem Augenblick die Auflösung verstellt, so dachte ich. Ich habe sie wieder zurück gestellt auf die alten Werte.
Habe mir nachher leider nicht weiter darum gekümmert!
Ich denke jetzt musste der Hauptprozessor die Arbeit tun, weil anscheinend der Treiber beschädigt wurde und der Prozessor der Grafikkarte dies nicht mehr tat. Nach der Neuinstallation des Grafikartentreiber kommt nun die Prozessorlast bei 0-1% zu liegen.

http://www.hackerboard.de/...&page=1&sid=

Ist sowas häufig das eine Software Treiber zerstört?

Danke noch für deine Hilfe

Gruss Peter
als Antwort auf: [#88861] Top
 
erbuc  M  S
Beiträge: 577
4. Jun 2004, 15:06
Beitrag #10 von 10
Beitrag ID: #89076
Bewertung:
(1732 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

CPU Nutzung plötzlich dauernd auf 30%!


Hi Peter

Eigentlich habe ich das bisher nur bei Games oder unsauber programmierten Produkten gesehen. Aber es ist äusserst selten.

Noch als Tip: Versuch immer herauszufinden, was Du alles zuletzt noch gemacht hast als es noch normal lief. Meistens findet man den "Ueberltäter" recht schnell heraus.

Meine Standardfragen:

Frage: Was hast Du gemacht?
Antwort: Nichts!
Frage: Was heisst NICHTS?
Antwort: Ich habe nur ....

Gruss

Erich
als Antwort auf: [#88861] Top
 
X