[GastForen Programme Office Microsoft Office Else bei negativem Suchergebnis (#WERT übergehen)

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Office - Alles fürs Büro
Themen
Beiträge
Moderatoren
Letzter Beitrag

Else bei negativem Suchergebnis (#WERT übergehen)

Torben Anschau
Beiträge gesamt:

8. Feb 2012, 11:05
Beitrag # 1 von 5
Bewertung:
(1427 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo,
für eine Tabelle benötige ich eine Formel, die wenn in einem Textfeld ein ! enthalten ist, eine Verkettung eines anderen Feldes mit "*" herbeiführt. Wenn nicht, soll lediglich das gleiche Feld ohne Verkettung ausgegeben werden.

Hierfür nutze ich Formeln wie:

=WENN(SUCHEN("*!*";A1);VERKETTEN(B1;"*");B1)

Problem ist: immer wenn in A1 nun kein Prozent enhalten ist, erscheint im Ausgabefeld "#Wert"). Die Else-Bedingung wird also ignoriert. Wie macht man das?
X

Else bei negativem Suchergebnis (#WERT übergehen)

ktedo
Beiträge gesamt: 253

8. Feb 2012, 11:47
Beitrag # 2 von 5
Beitrag ID: #489381
Bewertung:
(1417 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Torben,

das geht so:

=WENN(ISTFEHLER( abfrage );""); abfrage )

wenn die abfrage also erfolglos ist (#wert), beleibt die Zelle z.B. leer. Wenn abfrage erfolgreich, dann passiert etwas.

=WENN(ISTFEHLER(
WENN(SUCHEN("*!*";A1);VERKETTEN(B1;"*");B1);"");
WENN(SUCHEN("*!*";A1);VERKETTEN(B1;"*");B1)
)

ungetestet, müsste aber funktionieren
Sonst nach ISTFEHLER googlen ;-)
VG
Thomas


als Antwort auf: [#489372]

Else bei negativem Suchergebnis (#WERT übergehen)

Torben Anschau
Beiträge gesamt:

8. Feb 2012, 12:15
Beitrag # 3 von 5
Beitrag ID: #489389
Bewertung:
(1402 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Vielen Dank für die prompte Antwort, leider funktioniert es nicht. Als Fehlermeldung wird angegeben, dass zu viele Argumente erhalten seien. Kommt mir auch etwas schleierhaft vor, aber in die Richtung muss es eigentlich gehen.

Der Punkt ist der: Das Feld muss funktionieren, egal ob ein ! nun in B1 enthalten ist oder nicht. Im einen Fall wird verkettet, im zweiten Fall steht B2 alleine. Ich habe jetzt den Verdacht (ohne soweit gekommen zu sein), dass diese Formel dann nicht funktioniert, wenn in B1 ein ! enthalten ist?


als Antwort auf: [#489381]

Else bei negativem Suchergebnis (#WERT übergehen)

Torben Anschau
Beiträge gesamt:

8. Feb 2012, 12:19
Beitrag # 4 von 5
Beitrag ID: #489390
Bewertung:
(1399 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Zwischenmeldung: Mit zwei Feldern geht es. Also einmal ein Feld mit Istfehler und dann die zweite mit der Verkettung. Nun soll das eleganterweise auf ein Feld gekürzt werden.


als Antwort auf: [#489389]

Else bei negativem Suchergebnis (#WERT übergehen)

Torben Anschau
Beiträge gesamt:

8. Feb 2012, 12:22
Beitrag # 5 von 5
Beitrag ID: #489391
Bewertung:
(1393 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
LÖSUNG:
die Formel geht so:
=WENN(ISTFEHLER(SUCHEN("*!*";A1))=FALSCH;VERKETTEN(B1;"*");B1)


als Antwort auf: [#489390]
X

Aktuell

Veranstaltungskalender

Hier können Sie Ihre Anlässe eintragen, welche einen Zusammenhang mit den Angeboten von HilfDirSelbst.ch wie z.B. Adobe InDesign, Photoshop, Illustrator, PDF, Pitstop, Affinity, Marketing, SEO, Büro- und Rechtsthemen etc. haben. Die Einträge werden moderiert freigeschaltet. Dies wird werktags üblicherweise innert 24 Stunden erfolgen.

pdf-icon Hier eine kleine Anleitung hinsichtlich Bedeutung der auszufüllenden Formularfelder.

Veranstaltungen
02.02.2023

Prozesse optimieren und effizient gestalten

Zürich
Donnerstag, 02. Feb. 2023, 08.00 - 10.00 Uhr

Digitalisierung, Webauftritt

Digitalisierung mitgestalten - Worauf kommt es an? Wie wichtig ist die Webseite? Webseite mit Word Press? Interne Prozesse optimieren

Ja

Organisator: B. Isik - SNF Academy

Kontaktinformation: Birol Isik, E-Mailinfo AT bkcc DOT ch

https://digitalisierung-heute.ch/digitalisierung-informationstag-schweiz/

Veranstaltungen
01.03.2023 - 09.03.2023

Online
Mittwoch, 01. März 2023, 00.00 Uhr - Donnerstag, 09. März 2023, 00.00 Uhr

Online Webinar

Wie gehen wir mit diesen Veränderungen um? Was ist notwendig, damit wir die Digitalisierung im Unternehmen klappt? Veränderungsprozesse verstehen und entsprechend handeln Mitarbeiter als Botschafter Webseite mit WordPress erstellen SEA /SEO (Ads aufschalten)

Ja

Organisator: B. Isik - SNF Academy

Kontaktinformation: B. Isik, E-Mailinfo AT snfa DOT ch

https://www.fernstudiumfitness.ch/digitalisierung-schweiz/