[GastForen Programme Office Microsoft Office Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Office - Alles fürs Büro
Themen
Beiträge
Moderatoren
Letzter Beitrag

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

TheDmD
Beiträge gesamt: 7

23. Mär 2012, 15:28
Beitrag # 1 von 14
Bewertung:
(5203 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo zusammen
ich habe ein kleines umsetzungs problem in excell.
ich habe 36 Zeilen mit 8 spallten. und würde gerne auf einer anderen seite die Spallte zb B nach einem bestimmten inhalt durchsuchen. wenn der Inhalt gefunden wird, den inhalt der spallten C,D und E auf das Blatt übertragen.

Beispiel:=WENN(B3='Test1'!E5:E43;'Test1'!F5:F43;0)
nun giebt er mir da aber nur 0 aus..

beziehe ich die Formel auf eine einzelne Zeile dann funktionierts.
=WENN(B3='Test1'!E5;'Test1'!F5;0)

Hat jemand einen Tipp wie ich das gelöst kriege?
X

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

Hallenstein
Beiträge gesamt: 142

23. Mär 2012, 19:33
Beitrag # 2 von 14
Beitrag ID: #492356
Bewertung:
(5180 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo,

ich muss nochmal nachfragen, damit ich das richtig verstehe:

In einer Spalte A stehen Werte. Aus dieser Menge an Werten soll einer gesucht werden und wenn dieser gefunden wird, dann sollen alle Werte der Spalte B oder C (oder andere) in einem anderen Datenblatt angezeigt werden.

Mit anderen Worten wenn der gesuchte Wert in Spalte A auftritt, dann soll der Bezug zu Spalte B gezeigt werden, sonst halt nicht, richtig soweit?


Schöne Grüße,
Hallenstein.


als Antwort auf: [#492348]

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

TheDmD
Beiträge gesamt: 7

25. Mär 2012, 08:07
Beitrag # 3 von 14
Beitrag ID: #492377
Bewertung:
(5140 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
genau...

auf einer Seite habe ich diverse namen in A.. in B steht dann zb 10 und in C 20

auf einer 2en seite sage ich nun ist der Name Muster auf dem ersten Blatt irgendwo vorhanden übertrage mir die werte 10 und 20 (diese werte stehen nur bei dem namen Muster) bei den anderen Namen steht was anderes.. in die Spalten zb D&E

hoffe es ist verständlich.. ;)
danke für die Antwort
gruss


als Antwort auf: [#492356]

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

Klaus79
Beiträge gesamt: 316

25. Mär 2012, 17:03
Beitrag # 4 von 14
Beitrag ID: #492386
Bewertung:
(5108 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo,
angenommen die Daten stehen in Tabelle1 im Bereich A1:H36
und die Suchspalte ist A.
Und das gesuchte Wort steht in Tabelle2 in Zelle E1

dann schreibe in Tabelle 2 in A1 für den 1. Suchwert (=Spalte B):
=SVERWEIS(E1;Tabelle1!A1:H36;2;FALSCH)
in B1 für den 2. Suchwert (=Spalte C)
=SVERWEIS(E1;Tabelle1!A1:H36;3;FALSCH)
in C1 für den 3. Suchwert (=Spalte D)
=SVERWEIS(E1;Tabelle1!A1:H36;4;FALSCH)

usw.

Gruß
Klaus


als Antwort auf: [#492377]

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

Hallenstein
Beiträge gesamt: 142

25. Mär 2012, 19:31
Beitrag # 5 von 14
Beitrag ID: #492392
Bewertung:
(5080 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Naja, aber das gibt ja nur die Ergebnisse der jeweiligen Zeile zurück. Und wenn ich den Beitragsersteller richtig verstanden habe, will er die Werte einer Spalte zurückhaben, wenn in einer anderen Spalte ein gesuchter Wert gefunden wird.

Schöne Grüße,
Hallenstein.


als Antwort auf: [#492386]

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

ktedo
Beiträge gesamt: 253

26. Mär 2012, 07:07
Beitrag # 6 von 14
Beitrag ID: #492411
Bewertung:
(5046 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
servus TheDmD,

das würde ich so machen:

in die Zelle, in der der gesuchte Wert erscheinen soll, kommt das:
=INDEX( Quelle! B:B ; VERGLEICH( A2 ; Quelle! A:A ;0);1)

Erklärung:
Quelle! = Tabellenblatt der Quelle bzw andere Excel-Datei*
B:B = Spalte, aus der die Daten geholt werden
A:A = Spalte, in der nach der Übereinstimmung mit dem Suchfeld (A2) gesucht wird
A2 = Suchfeld

* Tabellenblatt innerhalb selber Excel-Datei, wird eine andere Excel-Tabelle als Quelle benannt muss diese innerhalb '' stehen.
Beispiel 'D:\GESCHAEFT\1_Kunden\Webasto\1_Master\xls\[Master_Alle-Artikel.xls]Tabelle1'!


Ist obendrein wesentlich schneller als SVerweis (bei sehr vielen Berechnungen)

VG
Thomas


als Antwort auf: [#492377]

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

Klaus79
Beiträge gesamt: 316

26. Mär 2012, 12:18
Beitrag # 7 von 14
Beitrag ID: #492431
Bewertung:
(5022 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Hallenstein,
woraus entnimmst Du, dass der Frager die ganze Spalte meint?
(wäre m.V. auch ein wenig unlogisch).

Zitat:
[auf einer Seite habe ich diverse namen in A
in B steht dann zb 10 und in C 20 (= korrespondierende Werte in der Zeile)
auf einer 2en seite sage ich nun
ist der Name Muster auf dem ersten Blatt irgendwo vorhanden übertrage mir die werte 10 und 20 ... (also die Zeilenwerte)
... in die Spalten zb D&E]

Ich glaube eher, dass der Frager der deutschen Sprache nicht sehr mächtig ist
und von daher seine Ausdrucksweise hinsichtlich Spalten und Zeilen verwirrend war ...

Aber vielleicht äußert sich der Frager ja noch dazu.

@Thomas
Bei 36 Suchzeilen ist der Hinweis auf "schneller" zu vernachlässigen :-)
(Ich glaube, dass greift erst ab ca. 6500 Zeilen).
Ansonsten entspricht Deine Lösung ja exakt der von SVerweis.

Gruß
Klaus


als Antwort auf: [#492392]

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

TheDmD
Beiträge gesamt: 7

29. Mär 2012, 09:16
Beitrag # 8 von 14
Beitrag ID: #492658
Bewertung:
(4961 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
der Frager ist nach 29h arbeit ein wenig müde.. tut mir leid für die verwirrung.
ich versuch das nochmals klar darzustellen wo das problem liegt.

Ausgangslage:
1 File.mit ca 30 blätter.
Blatt 1-5=Woche1-5
Blatt 6-30 detailierte Monats Blätter für die MA (jeder MA hat ein Blatt)

ziel der übung ist es die Namen der MA aus den Blätter 6-30 in den Wochenblätter 1-5 heraus zu filtern und die an den Tagen gearbeitete Zeit zu übertragen in das Monatsblatt des MA.

=WENN(B3='Woche 1'!E5:E43;'Woche 1'!F5:F43;0)
B3 ist der Name des MA.. (bleibt auf allen Blättern (6-30) Gleich)
Woche 1 ist dann logischerweise die Woche 1
E5-E43 sind die Spalten der Namens Spallte auf dem Wochen Blatt.
F5-F43 sind die Spalten der Arbeitszeit

Ziel: such in der Spalte E nach dem Namen (B3) und übertrage den wert aus E

Hoffe das ist so etwas verständlicher.. ist nicht einfach das verständlich zu schreiben..

danke und Gruss


als Antwort auf: [#492431]
(Dieser Beitrag wurde von TheDmD am 29. Mär 2012, 09:18 geändert)

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

TheDmD
Beiträge gesamt: 7

29. Mär 2012, 09:30
Beitrag # 9 von 14
Beitrag ID: #492660
Bewertung:
(4957 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hmm.. hab das von ktedo nun ausprobiert.. und siehe da.. es funzt.. :)
ich geh nun ein schritt weiter und versuch das mal weiter zu machen.. wenn ich hängen bleibe meld ich mich natürlich.

SUPER ktedo DANKE !
und auch den andern soweit


als Antwort auf: [#492658]

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

TheDmD
Beiträge gesamt: 7

29. Mär 2012, 10:12
Beitrag # 10 von 14
Beitrag ID: #492669
Bewertung:
(4935 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Gibt es eine Möglichkeit den wert #NV zu verstecken..


als Antwort auf: [#492660]

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

ktedo
Beiträge gesamt: 253

29. Mär 2012, 10:47
Beitrag # 11 von 14
Beitrag ID: #492674
Bewertung:
(4918 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
 
klar ;-)

=WENN(ISTFEHLER( Prüfung, die erfolgen soll );"";
( Prüfung, die erfolgen soll ))

wenn die Prüfung zu #nv führt, ist die Zelle leer.
Liefert die Prüfung keinen Fehler, ist in der Zelle das Ergebnis

VG
Thomas


als Antwort auf: [#492669]

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

TheDmD
Beiträge gesamt: 7

29. Mär 2012, 11:18
Beitrag # 12 von 14
Beitrag ID: #492678
Bewertung:
(4902 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Ähm.. Was?? lach..

=WENN(ISTFEHLER( Prüfung, die erfolgen soll );"";
( Prüfung, die erfolgen soll )) <-- versteh grad bahnhof.. muss das doch an die bestehende formel anfügen

=INDEX(ISTFEHLER('Woche 1'!P5:P43; VERGLEICH(B3;'Woche 1'!N5:N43;0);1);"";0) <--stimmt das?


als Antwort auf: [#492674]
(Dieser Beitrag wurde von TheDmD am 29. Mär 2012, 11:20 geändert)

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

ktedo
Beiträge gesamt: 253

29. Mär 2012, 11:56
Beitrag # 13 von 14
Beitrag ID: #492686
Bewertung:
(4877 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
=WENN(ISTFEHLER( INDEX(ISTFEHLER('Woche 1'!P5:P43; VERGLEICH(B3;'Woche 1'!N5:N43;0);1);"";0) );""; ( INDEX(ISTFEHLER('Woche 1'!P5:P43; VERGLEICH(B3;'Woche 1'!N5:N43;0);1);"";0) ))

ist doch gar nicht so schwer? - oder?
Schön ,wenn andere einem die Arbeit abnehmen....


als Antwort auf: [#492678]

Excell 36Zeilen in einer Spallten abfrage funktioniert nicht

TheDmD
Beiträge gesamt: 7

29. Mär 2012, 12:16
Beitrag # 14 von 14
Beitrag ID: #492691
Bewertung:
(4870 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
danke..
ne war so nicht gemeint..
arbeite gerade mal seit 3 Monaten mit Excell..
die Formelei ist noch ein wenig verwirrend..


als Antwort auf: [#492686]
X

Veranstaltungskalender

Hier können Sie Ihre Anlässe eintragen, welche einen Zusammenhang mit den Angeboten von HilfDirSelbst.ch wie z.B. Adobe InDesign, Photoshop, Illustrator, PDF, Pitstop, Affinity, Marketing, SEO, Büro- und Rechtsthemen etc. haben. Die Einträge werden moderiert freigeschaltet. Dies wird werktags üblicherweise innert 24 Stunden erfolgen.

pdf-icon Hier eine kleine Anleitung hinsichtlich Bedeutung der auszufüllenden Formularfelder.

Veranstaltungen
05.02.2021 - 05.11.2021

Digicomp Academy AG, Limmatstrasse 50, 8005 Zürich
Freitag, 05. Feb. 2021, 13.00 Uhr - Freitag, 05. Nov. 2021, 17.00 Uhr

Lehrgang

Bilden Sie sich zum zertifizierten Publishing-Multimedia-Profi aus. Neben Fotografie und Video befassen Sie sich mit der Medienproduktion, digitalen Publikationen und dem Webdesign für Desktop- und mobile Endgeräte.

Preis: CHF 10'500.-
Dauer: 30 Tage (ca. 210 Lektionen) – Unterricht findet jeweils am Freitag von 13 - 19 Uhr und Samstag von 09 - 17 Uhr statt

Ja

Organisator: Digicomp Academy AG

Kontaktinformation: Kundenberater-Team, E-Mailkundenberatung AT digicomp DOT ch

digicomp.ch/d/9PM

Veranstaltungen
09.09.2021 - 17.12.2021

Digicomp Academy, Zürich
Donnerstag, 09. Sept. 2021, 13.00 Uhr - Freitag, 17. Dez. 2021, 19.00 Uhr

Lehrgang

Steigen Sie in die Welt des Publishings ein und erlangen Sie die Zertifizierung von Publishing NETWORK. Lernen Sie in diesem Lehrgang Druckmedien professionell zu erarbeiten, druckfertige PDFs zu erstellen und CI/CD-Vorgaben umzusetzen.

Preis: 6'300.– zzgl. 7.7% MWST
Dauer: 18 Tage(ca. 126 Lektionen) – Unterricht findet jeweils am Freitag von 13 - 19 Uhr und Samstag von 09 - 17 Uhr statt.

Ja

Organisator: Digicomp Academy AG

Kontaktinformation: Kundenberater-Team, E-Mailkundenberater AT digicomp DOT ch