[GastForen Web allgemein Browser Fehler auf der Seite.

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Themen
Beiträge
Moderatoren
Letzter Beitrag

Fehler auf der Seite.

vollueli
Beiträge gesamt: 785

3. Mär 2005, 20:00
Beitrag # 1 von 7
Bewertung:
(2345 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
hallo
wenn man mit IE auf meine Seite http://www.wasser-engineering.ch/...ames/frame_oben.html geht, kommt unten Links die Fehlermeldung: Fehler auf der Seite.
kommt das davon, dass mein Quelltext noch nicht perfekt ist?
http://www.webmasterplan.com/...ames/frame_oben.html
(keine Sorge, ich werde ihn bald verbessern...)?
mfg vollueli
--------------------------------------------------------------------
nichts zu wissen glauben ist immerhin noch besser als nichts wissen.
X

Fehler auf der Seite.

jrandi
Beiträge gesamt: 794

4. Mär 2005, 00:08
Beitrag # 2 von 7
Beitrag ID: #149900
Bewertung:
(2345 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
hello,

"kommt das davon, dass mein Quelltext noch nicht perfekt ist?"
konkret der javascript-code - der stimmt nicht. wo genau der hacken liegt, kann ich dir da auch nicht sagen, ist schon wieder spàt, keine lust zu hirnen.

aber klick einfach mal drauf, dann weisst du wenigstens auf welcher zeile der fehler liegt.
allerdings wenn es z.b. die zeile zwei ist, so ist das die 2. zeile deines javascript - plus ou moins. und nicht die 2. zeile deines quellcodes.

übrigens, bau noch ein "newWindow.focus();" (wobei "newWindow" angepasst werden muss.) in dein script ein. somit kommt das popup immer in den vordergrund wenn man auf deiner nav hin und her klickt, auch wenn es fenster nicht geschlossen wurde.

gruss
jurg
________________________________
net & print production
http://www.randj.net / http://www.alpha-randj.net


als Antwort auf: [#149863]

Fehler auf der Seite.

vollueli
Beiträge gesamt: 785

4. Mär 2005, 07:01
Beitrag # 3 von 7
Beitrag ID: #149914
Bewertung:
(2345 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
>konkret der javascript-code - der stimmt nicht.
ok, dann schau ich den noch einmal genau an.

>übrigens, bau noch ein "newWindow.focus();" (wobei "newWindow" angepasst werden muss.) in dein script ein.
die Navigationsseite (/.../frame_oben.html) ist in einem Frameset eingebettet. Die Unterseiten gehen in einem anderen Frame auf, also nicht immer als Pop-Ups.Danke für die Anmerkung.

mfg vollueli
--------------------------------------------------------------------
nichts zu wissen glauben ist immerhin noch besser als nichts wissen.


als Antwort auf: [#149863]

Fehler auf der Seite.

SabineP
Beiträge gesamt: 7586

4. Mär 2005, 13:00
Beitrag # 4 von 7
Beitrag ID: #150018
Bewertung:
(2345 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo vollueli,

Der Grund der Fehlermeldung:
Die Einbindung der common.js in den HTML-Code ist falsch.
Die common.js wurde 2 mal eingebunden.
<script type="text/javascript" src="javascript/common.js"></script>
<script type="text/javascript" src="http://www.wasser-engineering.ch/...cript/common.js">

richtig wäre:
<script type="text/javascript" src="http://www.wasser-engineering.ch/..."></script>

Gruß Sabine


als Antwort auf: [#149863]
(Dieser Beitrag wurde von SabineP am 4. Mär 2005, 13:04 geändert)

Fehler auf der Seite.

vollueli
Beiträge gesamt: 785

4. Mär 2005, 14:47
Beitrag # 5 von 7
Beitrag ID: #150056
Bewertung:
(2345 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
ok danke, hat geklappt!
Nun kommt keine Fehlermeldung mehr.
mfg vollueli
--------------------------------------------------------------------
nichts zu wissen glauben ist immerhin noch besser als nichts wissen.


als Antwort auf: [#149863]

Fehler auf der Seite.

vollueli
Beiträge gesamt: 785

4. Mär 2005, 16:55
Beitrag # 6 von 7
Beitrag ID: #150109
Bewertung:
(2345 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
nochmals wegen einem ähnlichen Problem:
auf http://www.webmasterplan.com/...ben.html&popup=1
kommt ja: -- unknown attribute "NAME" for element <IMG>.
wenn ich nun NAME durch ID ersetze, funktioniert das script immer noch mit ie5 und mozilla firefox 1.0. auch der Quelltext ist dort laut webmasterplan.com perfekt.
doch beim ie kommt immer noch die Fehlermeldung.
was wäre dsa geeignete Attribut?
mfg vollueli
--------------------------------------------------------------------
nichts zu wissen glauben ist immerhin noch besser als nichts wissen.


als Antwort auf: [#149863]

Fehler auf der Seite.

r a c
Beiträge gesamt: 955

5. Mär 2005, 11:33
Beitrag # 7 von 7
Beitrag ID: #150201
Bewertung:
(2345 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo,

>was wäre dsa geeignete Attribut?

Bei HTML 4 ist für <img> name erlaubt
http://de.selfhtml.org/...nz/attribute.htm#img

und id als Universalattribut auch.
http://de.selfhtml.org/...m#universalattribute

In XHTML fällt dann name zugunsten von id weg. Das braucht dich aber nicht zu kümmern.

Was du brauchst ist also ein richtiger Validator
Guckst du bei w3.orghttp://www.wasser-engineering.ch%2Fde%2Fframes%2Fframe_oben.html

Grüsse r a c


als Antwort auf: [#149863]
(Dieser Beitrag wurde von r a c am 5. Mär 2005, 11:39 geändert)
X