hilfdirselbst.ch
Facebook Twitter gamper-media
« « 1 2 » »  
Martin Fischer  M  p
Beiträge: 11865
24. Mai 2018, 16:11
Beitrag #1 von 19
Bewertung:
(1620 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Hallo,

seit der Installation des Updates Firefox Quantum werden mir auf einigen Seiten (z.B. Google Suche) alle Zeichen mit einem A im Quadrat dargestellt:
Bildschirmfoto
Bildschirmfoto

Es geht aber auch richtig:
Bildschirmfoto
Bildschirmfoto

Hab in den Einstellungen mit diversen Schriftarten (erweitert) und Codierungen herumgespielt, Firefox mit AppCleaner komplett deinstalliert und neu eingerichtet.
Mit unterschiedlichen Profilen versucht.
Alle Plugins deaktiviert.
Adobe Flash Player deinstalliert.

lm Netz habe ich nach diversen Stichworten recherchiert und ab und an von Darstellungsproblemen bei deutlich älteren Firefox-Versionen gelesen.
Zu Quantum konnte ich keine entsprechenden Fehlerberichte lesen.

Hat jemand eine Idee, womit das zusammenhängen könnte?

Etwa mit der OS-Version: OX X Yosemite 10.10.5?

Viele Grüße
Martin
(Dieser Beitrag wurde von Martin Fischer am 24. Mai 2018, 16:12 geändert)
Top
 
X
Martin Fischer  M  p
Beiträge: 11865
24. Mai 2018, 16:26
Beitrag #2 von 19
Beitrag ID: #564016
Bewertung:
(1611 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Ah, eines hatte ich noch nicht ausprobiert:

x Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben


Sobald ich diese Option deaktiviere und die Darstellung mit den von mir eingestellten Schriften erzwinge, werden die zuvor falsch dargestellten Seiten richtig dargestellt.

Es muss also mit den von den Seiten vorgegebenen Fonts zusammenhängen.
Komisch.

Und warum finde ich keine Klagen von anderen Anwendern?

Viele Grüße
Martin
als Antwort auf: [#564015] Top
 
Martin Fischer  M  p
Beiträge: 11865
24. Mai 2018, 16:33
Beitrag #3 von 19
Beitrag ID: #564017
Bewertung:
(1609 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Komisch.

Bei manchen Seiten, bei denen es vorher nicht gegangen ist, geht es jetzt:
- Bildschirmfoto

Und bei anderen geht es nach wie vor nicht:
Bildschirmfoto

Eine Regel kann ich noch nicht so recht erkennen.

Viele Grüße
Martin
als Antwort auf: [#564016] Top
 
Martin Fischer  M  p
Beiträge: 11865
24. Mai 2018, 17:32
Beitrag #4 von 19
Beitrag ID: #564018
Bewertung:
(1596 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Ok, zum Ende meines Monologs gebe ich hier meine vorläufige Lösung an:

1. Deaktivierung der Option "Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben"
2. Einrichtung bestimmter Schriftarten (z.B. Serif: Cambria, Sans Serif: Calibri, Feste Breite: Hack); mit o.g. Kombination scheint es relativ zuverlässig zu funktionieren (nicht immer; kleine Texte in eBay etwa werden nicht korrekt dargestellt).

Nach meiner Erfahrung stellt Firefox Quantum strengere Anforderungen an die Schriften. Die genannten Probleme konnte ich in früheren Versionen nicht beobachten.

Viele Grüße
Martin
als Antwort auf: [#564017]
(Dieser Beitrag wurde von Martin Fischer am 24. Mai 2018, 17:47 geändert)
Top
 
Peter Lenz m
Beiträge: 1764
24. Mai 2018, 19:27
Beitrag #5 von 19
Beitrag ID: #564019
Bewertung:
(1574 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Hallo Martin,

stelle sicher, dass Yosemite auf alle ursprünglich installierten Schriften zugreifen kann. Ich finde jetzt gerade keine Liste, aber mit der Apple Schriftsammlung kannst Du den ursprünglichen Zustand wieder herstellen. Wähle „Ablage“ > „Standardschriften wiederherstellen“. Infos hier:

https://support.apple.com/...your-mac-fb34862/mac

Viele Grüße Peter
•-------------------------------------------------------------------------------------------------------•
iMac 27" Retina 5K, i7, macOS High Sierra 10.13.6, CC2015, CC2017, CC2018 / iPad 4, iOS 10
als Antwort auf: [#564018] Top
 
Martin Fischer  M  p
Beiträge: 11865
24. Mai 2018, 20:48
Beitrag #6 von 19
Beitrag ID: #564020
Bewertung:
(1559 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Hallo Peter,

ich kann spontan nicht erkennen, dass damit viel gewonnen wäre.

Sobald die Option "Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben" aktiv ist, tauchen die bekannten Probleme wieder auf.

Und ohne diese Option war die Darstellung mit den o.g. ausgewählten Schriften vorhin bereits in Ordnung.


Allerdings ist nach der Wiederherstellung der Standardschriften der User/Library/Fonts-Ordner gähnend leer und alle zuvor installierten Schriften sind in den Fonts (Removed)-Ordner herauskatapultiert worden (gut, dass sie von dort wieder so einfach zurückgeschoben werden können). Im [MAC]/Library/Fonts-Ordner sieht’s zwar nicht gar so öde aus, aber auch hier sind viele Schriften, die von bestimmten Programmen zwingend benötigt werden, einfach deaktiviert worden.


Unter diesen Gesichtspunkten würde ich niemandem raten, ohne Not die "Standardschriften wiederherzustellen".

Im Übrigen ist die Darstellung in allen anderen Browsern (Safari, Opera, Chrome) ohne diese bei Firefox Quantum beobachteten Irritationen.


Gibt es jemanden, der bestätigen kann, dass die Zeichendarstellung bei aktivierter Option "Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben" zerstört ist?
Worin könnte die Ursache darin liegen?
Ich meine, auch der neueste Firefox sollte doch mit nicht-lokalen/entfernten Webfonts klarkommen.

Viele Grüße
Martin
als Antwort auf: [#564019] Top
 
Dirk Levy  A 
Beiträge: 9291
24. Mai 2018, 21:09
Beitrag #7 von 19
Beitrag ID: #564021
Bewertung:
(1554 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Hallo Martin,

ich weiß es hilft nicht viel, aber bei mir geht alles wie gewohnt
mit Quantum - überhaupt null Schriftprobleme.

Ich verwende Sierra und den aktuellen Fontexplorer für die Schriften.

Gruß
Dirk

[levy-media.de MCP]
http://www.levy-media.de
als Antwort auf: [#564020] Top
 
Martin Fischer  M  p
Beiträge: 11865
24. Mai 2018, 21:16
Beitrag #8 von 19
Beitrag ID: #564022
Bewertung:
(1550 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Hallo Dirk,

hab Dank für Deine Antwort.
Sie hilft insofern als sie bestätigt, dass es im Prinzip wie erwartet funktionieren sollte. ;-)

Möglicherweise liegt es am Rendering-Zusammenspiel von OS Yosemite und Firefox Quantum (in Firefox Quantum unter Win 10 kann ich die obigen Probleme auch nicht beobachten).

Eins noch: wird bei Dir auch die Google-Seite bei aktivierter Option "Seiten das Verwenden von eigenen statt der oben gewählten Schriftarten erlauben" korrekt dargestellt?

Viele Grüße
Martin
als Antwort auf: [#564021]
(Dieser Beitrag wurde von Martin Fischer am 24. Mai 2018, 21:23 geändert)
Top
 
Dirk Levy  A 
Beiträge: 9291
24. Mai 2018, 21:20
Beitrag #9 von 19
Beitrag ID: #564023
Bewertung:
(1548 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Hallo Martin,

ja ist alles korrekt auch mit der Einstellung, die
ja wohl Standard in Firefox ist.... Ich habe auch
diverse Websites getestet - alles ist dort wie immer

Gruß
Dirk

[levy-media.de MCP]
http://www.levy-media.de
als Antwort auf: [#564022] Top
 
Martin Fischer  M  p
Beiträge: 11865
24. Mai 2018, 21:23
Beitrag #10 von 19
Beitrag ID: #564024
Bewertung:
(1544 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Ich beobachte ein unterschiedliches Verhalten je nachdem, welche Standard-Schriftart ausgewählt wird.

Eine Minion Pro, Myriad Pro, Helvetica, Geneva und eine Lucida Sans sind ok.

Bei Alegreya, Fontin Sans, Open Sans ... streikt die Darstellung (bei anderen Browsern auch hier kein Problem).

Das deutet auf einen möglichen Zusammenhang mit bestimmten Fonttypen hin.

Viele Grüße
Martin
als Antwort auf: [#564023] Top
 
Peter Lenz m
Beiträge: 1764
24. Mai 2018, 23:54
Beitrag #11 von 19
Beitrag ID: #564025
Bewertung:
(1507 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Hallo Martin,

Zitat Unter diesen Gesichtspunkten würde ich niemandem raten, ohne Not die "Standardschriften wiederherzustellen".


Ich habe die Funktion auch noch nie benötigt, da ich grundsätzlich System-Fonts und die Library-Fonts unangetastet lasse. Aber gut, mal ein Feedback zu haben.

Zitat Möglicherweise liegt es am Rendering-Zusammenspiel von OS Yosemite und Firefox Quantum (in Firefox Quantum unter Win 10 kann ich die obigen Probleme auch nicht beobachten).


Gut möglich. Ansonsten ist bei mir - wie bei Dirk - unter High Sierra alles in Butter.

Viele Grüße Peter
•-------------------------------------------------------------------------------------------------------•
iMac 27" Retina 5K, i7, macOS High Sierra 10.13.6, CC2015, CC2017, CC2018 / iPad 4, iOS 10
als Antwort auf: [#564024] Top
 
IdAiPs-Acrobat p
Beiträge: 3
25. Mai 2018, 09:45
Beitrag #12 von 19
Beitrag ID: #564026
Bewertung:
(1403 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Guten Morgen Martin,

ich sitze im gleichen Boot:
unter meinem Mac OS X 10.9.5 (auf die nötigsten Systemschriften reduziert und installiertem FontExplorer X Pro 6.0.5) ist auch hier das Darstellungsproblem mit der Ersatzglyphe in Firefox Quantum 60.x.x.
Da die deaktivierte Schriftoption nur teilweise Abhilfe schaffte, bin ich bei Release vorerst auf 59.0.3 zurück.

Beste Grüße

Björn
als Antwort auf: [#564015] Top
 
Freunek
Beiträge: 1444
25. Mai 2018, 12:32
Beitrag #13 von 19
Beitrag ID: #564027
Bewertung:
(1381 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Antwort auf: Ich beobachte ein unterschiedliches Verhalten je nachdem, welche Standard-Schriftart ausgewählt wird.


Die Problematik der „Darstellung mit lauter [A] in Kästchen“ gab es teilweise schon beim Update auf Firefox Version 56. Beschrieben wurde das bei macuser.de und auch auf mozilla.org

Das ging über einen Eingriff in den Preferences. Ich hatte damals die beschriebenen Schritte vorgenommen, aber ich bekomme es aus dem Gedächtnis nicht mehr hin. Musst Du bitte selbst schauen.

Seitdem verzichte ich
1. Auf automatische Firefox-Updates.
2. Auf die 60er Version, weil ich das gleiche Elend wieder erwarte.

Gruß Günther
als Antwort auf: [#564024] Top
 
JoPo m
Beiträge: 462
25. Mai 2018, 13:38
Beitrag #14 von 19
Beitrag ID: #564030
Bewertung:
(1373 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Hi zusammen,
bei mir unter 10.11.4 ist es das gleiche Problem.
Zuerst hatte ich die Arial in Verdacht. Je nach Site waren es nur noch Kästchen mit einem Fragezeichen drin (bei Martin ist es das "a").
Ich habe als Standardschrift jetzt in Firefox die Verdana eingestellt und die freie Wahl der Schriften unterbunden. Vorerst klappt es damit.
Salü
Joachim
als Antwort auf: [#564024]
(Dieser Beitrag wurde von JoPo am 25. Mai 2018, 13:39 geändert)
Top
 
Martin Fischer  M  p
Beiträge: 11865
25. Mai 2018, 13:48
Beitrag #15 von 19
Beitrag ID: #564031
Bewertung:
(1369 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Firefox Quantum (60.0.1): Zeichendarstellungsprobleme


Hallo Günther,

vielen Dank für Deine Rückmeldung und Deinen Hinweis.

Antwort auf: Beschrieben wurde das bei macuser.de und auch auf mozilla.org

Das ging über einen Eingriff in den Preferences. Ich hatte damals die beschriebenen Schritte vorgenommen, aber ich bekomme es aus dem Gedächtnis nicht mehr hin. Musst Du bitte selbst schauen.


Dem werde ich gelegentlich mal nachgehen.
Einstweilen funktioniert es mit bestimmten, fest angegebenen lokalen Schriften.

So ähnlich wie bei Dir, Joachim.
Auch Dir vielen Dank für die Bestätigung.
Das bedeutet mir auch eine Entlastung: ist nicht allein mein persönliches Problem.

Viele Grüße
Martin
als Antwort auf: [#564027] Top
 
« « 1 2 » »  
X