hilfdirselbst.ch
Facebook Twitter gamper-media

"Geht nicht" ist keine gültige Fehlermeldung!

« « 1 2 » »  
FSt  M 
Beiträge: 1950
14. Mär 2003, 08:40
Beitrag #1 von 28
Bewertung:
(10159 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Hallo zusammen

Ich habe ein verzwicktes Problem. Ich habe ein mydomain-Account bei Tiscali. Dort versuche ich den FomMailer von Matt's Script Archive zum laufen zu bringen. Soweit ist alles klar und funktioniert.

Das Problem fängt aber mit den E-Mail-Adressen an, an die ich meine Formulare versenden will. Wenn ich die E-Mail info@ der entsprechenden Domain einsetze wird das Script zwar ausgeführt und der Besucher auf die vorgesehene "Danke"-Site umgeleitet. Wenn ich dann diesen info-Account abfrage, ist kein E-Mail eingegangen.
Jetzt kommt der komplizierte Teil. Wenn ich eine andere E-Mail-Adresse verwende, also @tiscali.ch zum Beispiel, dann funktioniert alles tadellos.

Zusammenfassung: Der Script funktioniert. Aber irgendwo liegt ein Unterschied zwischen den Domains der E-Mail-Adressen. Hat irgendjemand eine Ahnung was das soll, oder sogar schon ähnliches erlebt?

Danke für die Hilfe
FSt Top
 
X
SabineP  M 
Beiträge: 7586
14. Mär 2003, 11:25
Beitrag #2 von 28
Beitrag ID: #28105
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Hallo Fst,

stehen denn alle Domainnamen der Empfänger-EMail-Adressen in der Referer-Liste drin?

@referers = ('domain1.com','domain2.ch');

Du kannst ja auch den Mailer von Tiscali verwenden:
http://support.tiscali.ch/...beispielformular.htm

Gruß Sabine
als Antwort auf: [#28076] Top
 
FSt  M 
Beiträge: 1950
14. Mär 2003, 11:36
Beitrag #3 von 28
Beitrag ID: #28107
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Hallo SabineP

Ja. Es stehen alle drin. Nur eben mit tiscali.ch funzts und mit der anderen Domain nicht.

Den "Stray's General Purpose Form Mailer" von Tiscali habe ich zur Zeit eingebaut. Funzt aber auch nicht mehr zufriedenstellend. Beim Matt-Script gefallen mir die vielen zusätzlichen Möglichkeiten der "E-Mail-Gestaltung".

Die beiden Forms findest Du unter
http://www.alemannia-basel.ch/html/kon/form.html (Stray's)
http://www.alemannia-basel.ch/html/kon/form1.html (Matt's)
Die beiden Scripts kannst Du runterladen unter
http://www.alemannia-basel.ch/html/kon/scripts.html

Gruss
FSt
als Antwort auf: [#28076]
(Dieser Beitrag wurde von FSt am 14. Mär 2003, 11:41 geändert)
Top
 
SabineP  M 
Beiträge: 7586
14. Mär 2003, 12:38
Beitrag #4 von 28
Beitrag ID: #28116
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Hallo FSt,
der Formmailer von Matt (hab Dein Beispiel getestet) funktioniert so wie er ist bei mir einwandfrei.
Wenn er auf dem Tiscali-Server nicht funktioniert, dann liegt es wahrscheinlich an der sendmail-Konfiguration.

Du kannst mal folgendes probieren:

Variante 1, die Parameter -i -t entfernen
$mailprog = '/usr/sbin/sendmail';

Variante 2
Bevor Du Dein Formular sendest einen Absender angeben, also das Feld E-Mail ausfüllen.
zum Beispiel: tester@irgendeinedomain.ch

Gruß Sabine
als Antwort auf: [#28076] Top
 
FSt  M 
Beiträge: 1950
14. Mär 2003, 14:00
Beitrag #5 von 28
Beitrag ID: #28131
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Hallo SabineP

Ich habe die Variante 1 ausprobiert. Leider funzts es immer noch nicht. Jetzt krieg ich einen Error 500 Internal Server Error zurück.

Leider krieg ich von Tiscali bis jetzt noch keine Hilfe...

Variante 2 hab ich gestern schon probiert und funzt auch nicht...

FSt
als Antwort auf: [#28076] Top
 
SabineP  M 
Beiträge: 7586
14. Mär 2003, 14:12
Beitrag #6 von 28
Beitrag ID: #28133
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Ich fürchte da kann Dir nur Tiscali weiterhelfen, ich kenne ja die Sendmail-Konfiguration nicht.
Es sieht fast so aus, als ob Tiscali das Versenden der Mails per sendmail an fremde Domainnamen
(alles was nicht tiscali.ch heißt) sperrt.

Kannst Du denn mit einem normalen E-Mail-Programm (Outlook oder Netscape)
Mails an die gewünschte Domain senden und empfangen?

Gruß Sabine
als Antwort auf: [#28076] Top
 
FSt  M 
Beiträge: 1950
14. Mär 2003, 15:16
Beitrag #7 von 28
Beitrag ID: #28148
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Schei...

Hab mir schon gedacht, dass hier Tiscali der Hemmschuh ist.
Werd mich bei denen mal so richtig "beschweren".

PS: Ja der normale Versand läuft ohne Probleme.

Danke und Tschüss
FSt
als Antwort auf: [#28076] Top
 
SabineP  M 
Beiträge: 7586
14. Mär 2003, 16:30
Beitrag #8 von 28
Beitrag ID: #28160
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


FSt, es gibt noch eine Möglichkeit.
Du verwendest den Formmailer von nms
http://nms-cgi.sourceforge.net/scripts.shtml

und versendest die Mails mit dem SMTP-Server von Tiscali

Auszug aus der README:

$mailprog = 'SMTP:mailhost.your.domain'; #Zeile 48 der formmail.pl

Für
mailhost.your.domain
trägst Du den Servernamen ein, der auch in Deinem Mailprogramm als SMTP-Server eingetragen ist.


Vielleicht klappt ja das.

Gruß Sabine
als Antwort auf: [#28076] Top
 
FSt  M 
Beiträge: 1950
27. Mär 2003, 07:06
Beitrag #9 von 28
Beitrag ID: #29462
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Hallo SabineP

Wollte nur ein abschliessendes Feedback geben:

Ich danke Dir für den interesanten Formmailer von nms. Der hat wirklich tolle Möglichkeiten.

Seit gestern funktioniert mein Formular nun wieder. Ich habe wirklich alles probiert und keine Lösung gefunden. Und dann geschah das unglaubliche: Tiscali hat sich nach 12 Tagen gemeldet mit folgendem E-Mail (Auszug):
----------------------------------------

Das Problem ist nun gelöst, auf dem Server war noch ein falscher Eintrag den ich nun korrigiert habe. Sie haben noch Mails auf dem alten Mailserver die Sie mit den alten Benutzerdaten abrufen können.

Freundliche Grüsse

---------
Tiscali DataComm AG
----------------------------------------

Danke für die Hilfe die ich von überall gekriegt habe und macht weiter so, nicht immer ist der Provider schuld...
FSt.

als Antwort auf: [#28076] Top
 
ArtDesigner
Beiträge: 101
3. Apr 2003, 16:11
Beitrag #10 von 28
Beitrag ID: #30394
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Hi.

Ich hoffe, ich hab das jetzt richtig verstanden. Allgemein gilt, dass bei den cgi´s von Matt man keine Mails an info-Postfächer senden kann. Keine Ahnung warum.

Gruß Stefan
als Antwort auf: [#28076] Top
 
SabineP  M 
Beiträge: 7586
3. Apr 2003, 16:35
Beitrag #11 von 28
Beitrag ID: #30408
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Stefan, wo steht das? Was sind info-Postfächer? Gruß Sabine
als Antwort auf: [#28076] Top
 
ArtDesigner
Beiträge: 101
3. Apr 2003, 16:55
Beitrag #12 von 28
Beitrag ID: #30413
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Hi Sabine.

Na info-Postfächer sind eMail-Adressen, die vor dem @ ein info stehen haben. Ich arbeite in einer großen Werbeagentur und das ist unsere Erfahrung mit Matt-Scripten.

LG Stefan
als Antwort auf: [#28076] Top
 
SabineP  M 
Beiträge: 7586
3. Apr 2003, 17:10
Beitrag #13 von 28
Beitrag ID: #30417
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Hmm, das Script selbst verbietet nicht die Empfänger-Adressen in der Form

info@irgendeine_domain.de

http://www.scriptarchive.com/...&f=FormMail%2Epl

Vielleicht hat der Provider sendmail so konfiguriert,
daß an info@irgendeine_domain.de keine Mails gesendet werden.

Gruß Sabine
als Antwort auf: [#28076] Top
 
FSt  M 
Beiträge: 1950
3. Apr 2003, 17:32
Beitrag #14 von 28
Beitrag ID: #30422
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


Hallo Stefan

Bei mir war wirklich der Provider und nicht das Script schuld. Nach tagelangen Test hat sich der Provider bei mir gemeldet. Alle meine E-Mails von den verschiedensten Scripts generiert waren abgeschickt worden und lagen im inf@-Postfach. Aber durch einen Fehler in der Konfiguration beim Provider wurden die E-Mails von den Formularen auf einem anderen Server abgelegt als meine normalen E-Mails im info@-Postfach. Deshalb entstand die ganze Verwirrung. Alle E-Mails die "normal" mit (z.B.) Outlook geschrieben wurden kamen bei mir an, aber alle E-Mails, die von den Formularen generiert wurden wanderten auf einen falschen Server. Nachdem die Konfiguration geändert wurde funktioniert nun alles tadellos.
Also einen Zusammenhang zwischen Matts Script und info@-Postfaächern kann in meinem Fall definitiv ausgeschlossen werden!

e schöne no
FSt
als Antwort auf: [#28076] Top
 
Anonym
Beiträge: 22827
3. Jun 2004, 17:22
Beitrag #15 von 28
Beitrag ID: #88875
Bewertung:
(10156 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

FormMailer.pl von Matt


HAllo leute, hab gesehn, ihr kennt euch sehr gut mit diesen Scrips aus.

Bin ein neuling in diesem gebiet und wollte euch nur fragen, ob es nicht einen deutschen scrip dazu gibt. Kann leider nicht englisch.

ach ja, und welche möglichkeiten bietet mir dieser scrip z.B. alles?
als Antwort auf: [#28076] Top
 
« « 1 2 » »  
X