[GastForen Programme Web/Internet Adobe Dreamweaver Formulare: Beim senden wird der Standardemail-Client aufgestartet anstatt das Formular an den Webser

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Web/Internet - Webdesign, eForms
Themen
Beiträge
Moderatoren
Letzter Beitrag

Formulare: Beim senden wird der Standardemail-Client aufgestartet anstatt das Formular an den Webser

mbisch
Beiträge gesamt: 5

23. Apr 2004, 16:17
Beitrag # 1 von 4
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Der Code sieht so aus:
<form name="productCataloque" method="post" action="mailto:sales@vacotec.ch?subject=Produktekatalog Bestellung /Catalog order/Commande de Catalogue" onSubmit="MM_validateForm('Name','','R','company','','R','street','','R','postecode','','R','town','','R','state','','R','phone','','R','eMail','','RisEmail');return document.MM_returnValue" enctype="multipart/form-data" id="productCataloque">

Nach dem Klicken auf senden kommt eine Windows-Meldung, dass das Email per "Dieses Formular wird per Email versandt. ...... Sie können den Vorgang fortsetzen oder abbrechen."
Beim Fortsetzen Starten der EmailClient auf , z.B. Outlook. Alle Formulardaten fehlen und sind nicht vorhanden.

Bitte um dringende Hilfe.
X

Formulare: Beim senden wird der Standardemail-Client aufgestartet anstatt das Formular an den Webser

SabineP
Beiträge gesamt: 7586

23. Apr 2004, 17:29
Beitrag # 2 von 4
Beitrag ID: #81591
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo mbisch,

Du mußt im Attribut action den Pfad und den Namen des CGI-Scriptes angeben, das die Formulardaten verarbeiten soll.

Beispiel:

<form action="verzeichnisname/dein_script.cgi" method="post">

Gruß Sabine


als Antwort auf: [#81575]
(Dieser Beitrag wurde von SabineP am 23. Apr 2004, 17:34 geändert)

Formulare: Beim senden wird der Standardemail-Client aufgestartet anstatt das Formular an den Webser

mbisch
Beiträge gesamt: 5

23. Apr 2004, 17:39
Beitrag # 3 von 4
Beitrag ID: #81593
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Danke Sabine
Aber ist ohne cgi-script das Problem nicht zu lösen? Wenn ja. wo finde ich eines, dass auch ich verstehe.
Gruss
Markus


als Antwort auf: [#81575]

Formulare: Beim senden wird der Standardemail-Client aufgestartet anstatt das Formular an den Webser

SabineP
Beiträge gesamt: 7586

23. Apr 2004, 18:00
Beitrag # 4 von 4
Beitrag ID: #81596
Bewertung:
(1634 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Markus, ohne ein serverseitiges Script gehts natürlich nicht.
Schau mal im PHP-Forum oder im Perl-Forum nach. Da gibt es einige Beispiele.

Gruß Sabine


als Antwort auf: [#81575]
X