[GastForen Archiv Adobe GoLive GL 9.0 Formular (Tabelle, FORM) nicht valider XHTML-Code, wie lösen ?

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Archiv - Archivierte Foren
Themen
Beiträge
Moderatoren
Letzter Beitrag

GL 9.0 Formular (Tabelle, FORM) nicht valider XHTML-Code, wie lösen ?

maiemi
Beiträge gesamt: 54

20. Mär 2009, 19:00
Beitrag # 1 von 5
Bewertung:
(2174 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Zusammen,

auf einer Seite habe ich ein Kontaktformular erstellt.
Das Formular ist aus Tabellen (table, td, tr, etc.) .
Wenn ich richtig informiert bin, muss ich ein Tabellenfreies Layout haben, wenn ich XHTML valide produzieren möchte.

Wie kann ich das Formular gestalten, damit ich das erreiche ?

hier ist der Link:http://www.liebetanz-zahntechnik.de/kontakt.html

Ich mache das nur als Hobby und bin nicht so der "Fachbegriffkenner"....

Dank Urs seinem Workshop (GL CS2) bin ich überhaupt so weit gekommen, die Site so zu erstellen....

Herzlichen Dank für Eure Hilfe

maiemi
X

GL 9.0 Formular (Tabelle, FORM) nicht valider XHTML-Code, wie lösen ?

SabineP
Beiträge gesamt: 7586

20. Mär 2009, 19:29
Beitrag # 2 von 5
Beitrag ID: #390349
Bewertung:
(2166 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
>> Wenn ich richtig informiert bin, muss ich ein Tabellenfreies Layout haben,
>> wenn ich XHTML valide produzieren möchte.

Das stimmt nicht, XHTML erlaubt Tabellen genau so wie HTML.
http://de.selfhtml.org/.../tabellen/aufbau.htm


als Antwort auf: [#390347]
(Dieser Beitrag wurde von SabineP am 20. Mär 2009, 19:31 geändert)

GL 9.0 Formular (Tabelle, FORM) nicht valider XHTML-Code, wie lösen ?

maiemi
Beiträge gesamt: 54

21. Mär 2009, 19:16
Beitrag # 3 von 5
Beitrag ID: #390407
Bewertung:
(2113 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Sabine,

danke für Deine Antwort.
Es irritiert mich, dass beim HTML- Validations-Test die Formulartabelle als fehlerhaft ausgewiesen wird.

Vielleicht kannst Du mir helfen, die Fehler zu beseitigen ?

Herzlichen Dank und Gruss

maiemi


als Antwort auf: [#390349]

GL 9.0 Formular (Tabelle, FORM) nicht valider XHTML-Code, wie lösen ?

SabineP
Beiträge gesamt: 7586

21. Mär 2009, 20:09
Beitrag # 4 von 5
Beitrag ID: #390408
Bewertung:
(2107 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo maiemi,

hier die erste Zeile, die dem Validator nicht gefällt (Line 44):

<table border="0" cellspacing="2" cellpadding="0" height="391" />

richtig wäre:

<table border="0" cellspacing="2" cellpadding="0">

Das Attribut height gibt es nicht für das Element table, auch nicht bei HTML.
Die Höhe der Tabelle müßtest Du mit CSS festlegen, falls Du überhaupt eine Höhe brauchst.

Legt Golive tatsächlich solchen falschen HTML-Code an:
<table border="0" cellspacing="2" cellpadding="0" height="391" />
Oder stammt dieser Code aus einem anderen Programm?

Der Slash am Ende des Table-Elements beendet die Tabelle bevor sie angefangen hat.


als Antwort auf: [#390407]
(Dieser Beitrag wurde von SabineP am 21. Mär 2009, 20:18 geändert)

GL 9.0 Formular (Tabelle, FORM) nicht valider XHTML-Code, wie lösen ?

maiemi
Beiträge gesamt: 54

22. Mär 2009, 17:32
Beitrag # 5 von 5
Beitrag ID: #390426
Bewertung:
(2046 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Sabine,

herzlichen Dank für Deine Antwort.
Inzwischen habe ich das Formular neu erstellt (nur noch nicht publiziert). Der Code ist nicht von Golive, sondern aus einer anderen Seite übernommen und angepasst worden.
(Da das Formular an sich funktioniert(e), dachte ich, der Code ist OK.)

Das Problem hat sich denmach durch Deinen Hinweis erledigt.

Dafür habe ich nun ein anderes Problem, dazu aber in einem separaten Thread mehr...

Alles Liebe und nochmal herzlichen Dank,

maiemi


als Antwort auf: [#390408]
(Dieser Beitrag wurde von maiemi am 22. Mär 2009, 17:34 geändert)
X