[GastForen Web allgemein Browser IE 6/7 und FF3 zeigen Elemente auf Seite nicht an

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Themen
Beiträge
Moderatoren
Letzter Beitrag

IE 6/7 und FF3 zeigen Elemente auf Seite nicht an

pimsn
Beiträge gesamt: 3

6. Apr 2008, 23:11
Beitrag # 1 von 6
Bewertung:
(1701 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
hallo an alle.

folgendes problem: meine seite (vamosaver.tk) wird bei mir im ff2 problemlos dargestellt, leider erscheint nur nichts auf dem bildschirm wenn ich das ganze mit ie6,7 oder ff3 öffne.
xhtml, css und die feeds sind w3c validiert. der quellcode wird (soweit ich das gesehen habe) in allen browsern identisch angezeigt, was ja schon ein hinweis darauf ist, dass es ein browserproblem ist, oder? die hintergrundfarbe ist und der titel sind so ziemlich das einzige was die browser schlucken, bei denen sonst nichts funktioniert.
die seite ist ausserdem mit (äußerst simplem) php zusammengebastelt, aber ich denke dass der hund da nicht begraben ist.
ich kenne mich mit den dtd's nicht 100%ig aus, vielleicht könnte da ja was falsch sein. wundern tut's mich auf jeden fall, da ja alles w3c-validiert ist (oder hat das nicht sooo viel zu sagen??)
bin über jeden hinweis dankbar, danke im vorraus! sollte ich gerade wichtige infos vergessen haben, einfach bescheid geben.
mfg, pirmin
X

IE 6/7 und FF3 zeigen Elemente auf Seite nicht an

SabineP
Beiträge gesamt: 7586

6. Apr 2008, 23:55
Beitrag # 2 von 6
Beitrag ID: #345004
Bewertung:
(1690 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Pirmin,

entferne die erste Zeile:
<?xml version="1.0" encoding="utf-8"?>
Vielleicht hilft das schon.
Gruß Sabine


als Antwort auf: [#345003]

IE 6/7 und FF3 zeigen Elemente auf Seite nicht an

pimsn
Beiträge gesamt: 3

7. Apr 2008, 01:02
Beitrag # 3 von 6
Beitrag ID: #345006
Bewertung:
(1672 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
nein, das ist es leider nicht. aus irgendwelchen gründen ist durch diese zeile das dokument erst w3c valid geworden, ist es jetzt aber nach der entfernung wundersamer weise immernoch.
ich lass sie jetzt mal lieber draussen, aber das problem besteht weiterhin.
habe gerade die seite mit dem aktuellen opera getestet, da funktioniert auch alles.
ich frage mich halt die ganze zeit an was es denn nun liegen könnte.. mögliche fehlerquellen sind meines wissens nach entweder dtd, css, vielleicht sogar die rss-datei, oder am ende liegts doch am php?? aber wie gesagt, alles ist valid. hier mal der php-code:

Code
<?PHP 
echo "<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\"
\"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd\">
<html xmlns=\"http://www.w3.org/1999/xhtml\" lang=\"en\" xml:lang=\"en\">
<head>
<title>vamos a ver dot tk</title>

<link rel=\"stylesheet\" type=\"text/css\" href=\"vamos.css\" />
<link rel=\"alternate\" href=\"";
import_request_variables('gp','url_');

switch($url_site) {
case "mexanf":
echo "test/mex_anfang";
break;

default:
echo "main";
}

echo ".rss\" type=\"application/rss+xml\" title=\"\" id=\"gallery\" />
<script type=\"text/javascript\" src=\"http://lite.piclens.com/current/piclens.js\" />
<meta http-equiv=\"Content-Type\" content=\"application/xhtml+xml; charset=UTF-8\" />
<meta name=\"keywords\" content=\"reisen, travel, viaje\" />
<meta name=\"description\" content=\"\" />
<meta name=\"robots\" content=\"all, index, follow\" />
<meta name=\"revisit-after\" content=\"2 days\" />
</head>
<body>
<table border=\"0px\" cellspacing=\"0\" cellpadding=\"0\">
<tr><td colspan=\"2\">
<div class=\"head\">
<a href=\"index.php?site=intro\">
<img src=\"img/head.jpg\" title=\"a donde vamos\" alt=\"vamos a ver - un viaje por latinoamerica\" />
</a>
</div>
</td></tr>
<tr><td width=\"200\">
<div class=\"menu\">
<div class=\"mp_head\" style=\"background-color:#00a30c;\">mexico</div>
<div class=\"mp\">
<a href=\"index.php?site=mexanf\" class=\"lnk1\">ein Anfang</a>
</div>
<div class=\"mp\">
<a href=\"index.php?site=mexciu\" class=\"lnk1\">Ciudad de Mexico</a>
</div>
<div class=\"mp\">
<a href=\"index.php?site=mexver\" class=\"lnk1\">Veracruz</a>
</div>
<div class=\"mp\">
<a href=\"index.php?site=mexoax\" class=\"lnk1\">Oaxaca</a>
</div>
<div class=\"mp\">
<a href=\"index.php?site=mexchi\" class=\"lnk1\">Chiapas</a>
</div>
<div class=\"mp\">
<a href=\"index.php?site=mexyuc\" class=\"lnk1\">Yucatan</a>
</div>
<div class=\"mp_head\" style=\"background-color:#0077a3;\">belice</div>
</div>
</td>
<td>
<div class=\"thumbs\">";
switch($url_site) {
case "intro":
include("intro.html");
break;

case "mexanf":
include("test/gallery.html");
break;

default:
include("intro.html");
}

echo " </div>
</td></tr>
</table>
</body>

</html>";
?>


css:
Code
body  
{
margin: 0px;
padding: 0px;
background-color: black;
}

img
{
border: 0;
}

td
{
vertical-align: top;
}

a
{
cursor: pointer;
outline: 0;
}

.head
{
margin-left: 10px;
margin-top: 1px;
}

.menu
{
margin-left: 30px;
width: 150px;
}

.mp_head
{
padding-left: 10px;
text-transform: uppercase;
color: white;
text-decoration: none;
font-size: 12px;
font-weight: bold;
font-family:trebuchet ms, univers;
width: 150px;
margin-top: 10px;
}

.mp
{
padding-left: 10px;
}

.thumbs
{
margin-top: 0px;
margin-left: 20px;
padding:5px;
}

#test/pl_main
{
width: 700px;
font-family: Arial;
font-size: 14px;
line-height: 18px;
color: #333;
}
table.gallery
{
padding:5px;
width: 100%;
}

table.gallery td
{
text-align: center;
vertical-align: middle;
width: 140px;
height: 140px;
background-color: white;
}

table.gallery img
{
padding: 0px;
margin: 2px;
border: 2px solid white;
}
.mbf-item
{
display: none;
}

a.lnk1:link, a.lnk1:visited
{
color: white;
text-decoration: none;
font-size: 12px;
font-weight: bold;
font-family: trebuchet ms, univers;
}

a.lnk1:hover
{
color: white;
text-decoration: underline;
font-size: 12px;
font-weight: bold;
font-family: trebuchet ms, univers;
}

a.lnk1:active, a.lnk1:focus
{
color: black;
text-decoration: none;
font-size: 12px;
font-weight: bold;
font-family: trebuchet ms, univers;
background-color: white;
}


rss: (nur test-code)
Code
<?xml version="1.0" encoding="UTF-8" standalone="yes"?> 
<rss version="2.0" xmlns:media="http://search.yahoo.com/mrss/" xmlns:atom="http://www.w3.org/2005/Atom">
<channel>
<atom:icon>http://web7.zefix2003.de/Pirmin/vamosaver/img/logo.jpg</atom:icon>
<atom:link href="http://web7.zefix2003.de/Pirmin/vamosaver/main.rss" rel="self" type="application/rss+xml" />
<generator>piclens publisher win 1.0.12</generator>
<title>Mexico Anfang</title>
<link>http://web7.zefix2003.de/Pirmin/vamosaver/main.rss</link>
<description>viajando por latinoamerica</description>

<item>
<title>img001</title>
<link>http://web7.zefix2003.de/Pirmin/vamosaver/test/pl_images/img001.jpg</link>
<guid isPermaLink="false">9bb49109-1a4b-455c-bda9-084c009bb2e0</guid>
<media:thumbnail url="http://web7.zefix2003.de/Pirmin/vamosaver/test/pl_thumbs/img001_thumb.jpg" />
<media:content url="http://web7.zefix2003.de/Pirmin/vamosaver/test/pl_images/img001.jpg" type="" />
</item>

</channel>
</rss>



könnte es eine kombination von fehlern sein?


als Antwort auf: [#345004]
(Dieser Beitrag wurde von pimsn am 7. Apr 2008, 01:04 geändert)

IE 6/7 und FF3 zeigen Elemente auf Seite nicht an

SabineP
Beiträge gesamt: 7586

7. Apr 2008, 09:41
Beitrag # 4 von 6
Beitrag ID: #345025
Bewertung:
(1633 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Pirmin,

PHP spielt für den Browser keine Rolle.
Der RSS-Feed wird doch unter der geposteten URL gar nicht angezeigt,
sondern ein Frameset, das diese URL enthält:

http://web7.zefix2003.de/Pirmin/vamosaver/index.php

Der Validator hat einen Fehler übersehen:

<table border="0px" ...

richtig wäre

<table border="0" ...


Dann habe ich noch das Javascript entfernt:
<script type="text/javascript" src="http://lite.piclens.com/current/piclens.js" />

Ich habe hier nur IE4, aber der kann nach diesen Änderungen die Seite darstellen.

Binde das Javascript besser so ein:
<script type="text/javascript" src="http://lite.piclens.com/current/piclens.js"></script>

Warum wird das Javascript überhaupt von einem anderen Server geladen?
Gruß Sabine


als Antwort auf: [#345006]
(Dieser Beitrag wurde von SabineP am 7. Apr 2008, 09:59 geändert)

IE 6/7 und FF3 zeigen Elemente auf Seite nicht an

pimsn
Beiträge gesamt: 3

7. Apr 2008, 10:14
Beitrag # 5 von 6
Beitrag ID: #345030
Bewertung:
(1617 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
oh, damit hätte ich jetzt nicht gerechnet.

aber was soll ich denn jetzt machen, wenn ich das JS doch brauche?


als Antwort auf: [#345025]

IE 6/7 und FF3 zeigen Elemente auf Seite nicht an

SabineP
Beiträge gesamt: 7586

7. Apr 2008, 10:27
Beitrag # 6 von 6
Beitrag ID: #345034
Bewertung:
(1611 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Das steht oben im Beitrag.
Gruß Sabine


als Antwort auf: [#345030]
X

Aktuell

Veranstaltungskalender

Hier können Sie Ihre Anlässe eintragen, welche einen Zusammenhang mit den Angeboten von HilfDirSelbst.ch wie z.B. Adobe InDesign, Photoshop, Illustrator, PDF, Pitstop, Affinity, Marketing, SEO, Büro- und Rechtsthemen etc. haben. Die Einträge werden moderiert freigeschaltet. Dies wird werktags üblicherweise innert 24 Stunden erfolgen.

pdf-icon Hier eine kleine Anleitung hinsichtlich Bedeutung der auszufüllenden Formularfelder.

Veranstaltungen
07.12.2020 - 08.12.2020

Digicomp Academy AG, Küchengasse 9, 4051 Basel
Montag, 07. Dez. 2020, 08.30 Uhr - Dienstag, 08. Dez. 2020, 17.00 Uhr

Kurs

Dieser Basic-Kurs ist der perfekte Einstieg in die Welt von InDesign, dem vielseitigen Layout-Programm. Sie lernen, wie InDesign aufgebaut ist, wie saubere Dokumente erstellt werden und wie man korrekt mit gelieferten InDesign-Projekten umgeht.

CHF 1'400.-
Dauer: 2 Tage

Nein

Organisator: Digicomp Academy AG

Kontaktinformation: Isil Günalp, E-Mailisil.guenalp AT digicomp DOT ch

https://www.digicomp.ch/weiterbildung/software-anwendungs-trainings/adobe-trainings/desktop-publishing/adobe-indesign-cc/kurs-indesign-cc-basic

Veranstaltungen
21.01.2021 - 22.01.2021

Digicomp Academy AG, Bern oder Basel
Donnerstag, 21. Jan. 2021, 08.30 Uhr - Freitag, 22. Jan. 2021, 17.00 Uhr

Kurs

Dieser Basic-Kurs ist der perfekte Einstieg in die Welt von InDesign, dem vielseitigen Layout-Programm. Sie lernen, wie InDesign aufgebaut ist, wie saubere Dokumente erstellt werden und wie man korrekt mit gelieferten InDesign-Projekten umgeht.

Dauer: 2 Tage
Preis: CHF 1'400.–

Ja

Organisator: Digicomp Academy AG

Kontaktinformation: Kundenberater-Team, E-Mailkundenberatung AT digicomp DOT ch

digicomp.ch/d/INDEM1

Neuste Foreneinträge


Home-Office

Fehlende Bilddarstellung in Mail

Wer bist du? - Stell' dich vor!

Anpassung von Scriptfunktion auf Bleedbox

Jobs aus dem Quark sollen im Acrobat verglichen werden

Arial Narrow in Tabellen

Indesign 2014

Zwei Fragen zur Tabelle

Webinar IDUG Stuttgart: Grafik- und Bilddaten crossmedial aufbereiten

PPT-Grafik nachbauen
medienjobs