[GastForen Archiv Perl und CGI Kein SHTML in CGI-Verzeichnis?

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Archiv - Archivierte Foren
Themen
Beiträge
Moderatoren
Letzter Beitrag

Kein SHTML in CGI-Verzeichnis?

Robbi
Beiträge gesamt: 267

29. Mai 2002, 15:42
Beitrag # 1 von 10
Bewertung:
(2089 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo,
hoffenlich bin ich nicht im falschen Forum.
Ich habe ein CGI-fähiges und mit htaccess geschütztes Verzeichnis angelegt, in dem eine SHTML-Datei liegt. Die Datei lässt sich aber nicht aufrufen: Fehlere 500 Interner Serverfehler.
Woran liegt das? Am geschützten Verzeichnis oder daran, dass es CGI-fähig ist oder am SHTML?
Wäre schön, enn jemand die Antwort weiß.

Tschüss
Robbi
X

Kein SHTML in CGI-Verzeichnis?

Ollli
Beiträge gesamt: 458

29. Mai 2002, 17:57
Beitrag # 2 von 10
Beitrag ID: #4344
Bewertung:
(2089 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Soweit ich weiß, funktionieren in einem cgi-bin oder anderem script-verzeichnis keine html-dateien und auch keine shtml-dateien.
Es kann aber auch an den SSI liegen.

Ollli


als Antwort auf: [#4340]

Kein SHTML in CGI-Verzeichnis?

SabineP
Beiträge gesamt: 7586

29. Mai 2002, 18:05
Beitrag # 3 von 10
Beitrag ID: #4345
Bewertung:
(2089 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Im cgi-bin Verzeichnis können nur Programme ausgeführt werden, welche die cgi-Schnittstelle benutzen. Bei den meisten Providern ist der Server auch so aus Sicherheitsgründen konfiguriert. Du kannst aber die shtml-Dateien und auch die HTML-Dateien und Bilder außerhalb des cgi-bin-Verzeichnisses speichern.


als Antwort auf: [#4340]

Kein SHTML in CGI-Verzeichnis?

Robbi
Beiträge gesamt: 267

30. Mai 2002, 08:34
Beitrag # 4 von 10
Beitrag ID: #4368
Bewertung:
(2089 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo!
Ja, das war's wohl. Da werd ich mir wohl was anderes überlegen müssen

Ich danke Euch!
Tschau, Robbi


als Antwort auf: [#4340]

Kein SHTML in CGI-Verzeichnis?

Ollli
Beiträge gesamt: 458

30. Mai 2002, 21:02
Beitrag # 5 von 10
Beitrag ID: #4393
Bewertung:
(2089 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Schildere uns doch dein Problem, was dich dazu veranlasst html-Seiten ins cgi-bin zu speichern.
Vielleicht können wir helfen!?

Ollli


als Antwort auf: [#4340]

Kein SHTML in CGI-Verzeichnis?

Robbi
Beiträge gesamt: 267

1. Jun 2002, 19:14
Beitrag # 6 von 10
Beitrag ID: #4466
Bewertung:
(2089 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hai Olli,
ich habe ein Forum eingerichtet, das in einem per Passwort geschützten Verzeichnis liegt und cgi-fähig ist. Da gehören noch einige shtml-Seiten zu, die ich praktischerweise gleich mit in dasselbe Verzeichnis packen wollte - aber nix is.
Also hab ich's nun umgedreht: Innerhalb des geschützten Bereiches liegen die shtml-Seiten sowie ein cgi-Verzeichnis, in dem das Forum liegt. Und so klappts auch.

Tschüss
Robbi


als Antwort auf: [#4340]

Kein SHTML in CGI-Verzeichnis?

Ollli
Beiträge gesamt: 458

1. Jun 2002, 21:04
Beitrag # 7 von 10
Beitrag ID: #4469
Bewertung:
(2089 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Freut mich, dass du es geschafft hast

Hast du einen eigenen Server oder wie kannst du ein zweites cgi-bin anlegen???

Ollli


als Antwort auf: [#4340]

Kein SHTML in CGI-Verzeichnis?

Robbi
Beiträge gesamt: 267

1. Jun 2002, 23:40
Beitrag # 8 von 10
Beitrag ID: #4477
Bewertung:
(2089 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hai,
nee, nen eigenen Server nicht, aber nen sehr flexiblen Provider
Da ich etwa ein Dutzend solcher Verzeichnisse anlegen muss, die alle extra geschützt sind und gleichzeitig cgi-Skripte beinhalten, sind sie mit entsprechenden htaccess-Dateien cgi-fähig gemacht ("Options +ExecCGI" und "SetHandler cgi-script").
Eine andere Lösung hab ich nicht gefunden.

Tschüss!
Robbi


als Antwort auf: [#4340]

Kein SHTML in CGI-Verzeichnis?

Ollli
Beiträge gesamt: 458

2. Jun 2002, 04:11
Beitrag # 9 von 10
Beitrag ID: #4480
Bewertung:
(2089 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Das muss ich auch gleichmal bei meinen Provider versuchen
eine gute Idee!!!

Ollli


als Antwort auf: [#4340]

Kein SHTML in CGI-Verzeichnis?

Anonym
Beiträge gesamt: 22827

19. Jul 2004, 14:24
Beitrag # 10 von 10
Beitrag ID: #98026
Bewertung:
(2089 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Kannste mir auch mal sagen, was für nen guten Provider hast?
Wer echt gut!


als Antwort auf: [#4340]
X

Veranstaltungskalender

Hier können Sie Ihre Anlässe eintragen, welche einen Zusammenhang mit den Angeboten von HilfDirSelbst.ch wie z.B. Adobe InDesign, Photoshop, Illustrator, PDF, Pitstop, Affinity, Marketing, SEO, Büro- und Rechtsthemen etc. haben. Die Einträge werden moderiert freigeschaltet. Dies wird werktags üblicherweise innert 24 Stunden erfolgen.

pdf-icon Hier eine kleine Anleitung hinsichtlich Bedeutung der auszufüllenden Formularfelder.

Veranstaltungen
02.02.2023

Prozesse optimieren und effizient gestalten

Zürich
Donnerstag, 02. Feb. 2023, 08.00 - 10.00 Uhr

Digitalisierung, Webauftritt

Digitalisierung mitgestalten - Worauf kommt es an? Wie wichtig ist die Webseite? Webseite mit Word Press? Interne Prozesse optimieren

Ja

Organisator: B. Isik - SNF Academy

Kontaktinformation: Birol Isik, E-Mailinfo AT bkcc DOT ch

https://digitalisierung-heute.ch/digitalisierung-informationstag-schweiz/

Veranstaltungen
01.03.2023 - 09.03.2023

Online
Mittwoch, 01. März 2023, 00.00 Uhr - Donnerstag, 09. März 2023, 00.00 Uhr

Online Webinar

Wie gehen wir mit diesen Veränderungen um? Was ist notwendig, damit wir die Digitalisierung im Unternehmen klappt? Veränderungsprozesse verstehen und entsprechend handeln Mitarbeiter als Botschafter Webseite mit WordPress erstellen SEA /SEO (Ads aufschalten)

Ja

Organisator: B. Isik - SNF Academy

Kontaktinformation: B. Isik, E-Mailinfo AT snfa DOT ch

https://www.fernstudiumfitness.ch/digitalisierung-schweiz/