hilfdirselbst.ch
Facebook Twitter gamper-media
zaph0x
Beiträge: 43
30. Dez 2004, 23:29
Beitrag #1 von 4
Bewertung:
(1119 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit 3 Frames!!!


hallo,

also mein problem ist das ich eine seite mit 3 frames habe(jeweils horizontal)und die obere als titel nutze und die mittlere als navigation, die untere ist der main teil....

wenn ich jetzt aber einen button inder navi anklicke,dann macht der nie des alles was eigentlich im main teil,d,h, unten rein sollte...sondern entweder alles weg und den ziellink extra,oder er öffnet das im navi frame was ja auch falsch ist...

ich möchte aber das es im unteren teil geöffnet wird....
ich hoffe ihr könnt mir helfen......DANKE Top
 
X
Dirk Levy  A 
Beiträge: 9285
31. Dez 2004, 00:02
Beitrag #2 von 4
Beitrag ID: #133280
Bewertung:
(1119 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit 3 Frames!!!


Du mußt bei Linkziel den Name des Frameteils
für jeden Link der darauf geht angeben....

Wenn Du mal einen Link oder den Quellcode hast
kann man Dir bestimmt besser helfen....

Ich finde gerade nicht die Tasse mit dem
Kaffeesatz zum lesen... ;o9

Gruß
Dirk

[Adobe GoLive Tipps & Tricks]
http://www.gltipps.de
Adobe GoLive CS Buch
http://www.galileodesign.de/685?GPP=levy
als Antwort auf: [#133276] Top
 
zaph0x
Beiträge: 43
31. Dez 2004, 00:10
Beitrag #3 von 4
Beitrag ID: #133281
Bewertung:
(1119 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit 3 Frames!!!


also inner home datei wo die frames geregelt werdden siehts so aus(ein teil davon):
<frameset rows="170,*"border="0" scrolling="no">
<frame name="oben" src="oben.htm" scrolling="no">

<frameset rows="25,0"border="0" scrolling="no">
<frame name="unten" noresize src="navi.htm" scrolling="no">

<frameset>
<frame name="Haupt" noresize src="main.htm" >
</frameset>


und inder der navi.htm:
<a href="home.html" target="_blank"><img src="home.gif" border="0"></a>
<a href="member.html" target="Haupt"><img src="member.gif" border="0"></a>
<a href="projekte.html"><img src="projekte.gif" border="0"></a>
<a href="forum.htm" target="_blank"><img src="forum.gif" border="0"></a>
<a href="guestbook.htm" target="Haupt"><img src="guestbook.gif" border="0"></a>
<a href="links.htm"><img src="links.gif" border="0"></a>
<a href="download"><img src="download.gif" border="0"></a>
<a href="sponsor"><img src="sponsor.gif" border="0"></a>


wenn ich auf member klicken möchte dann macht der browser nichts...

ach und noch eine frage!!!(sorry)

die src gif files zeigt er bei mozilla an und bei inet explorer nicht....woran liegt das???THX
als Antwort auf: [#133276] Top
 
Dirk Levy  A 
Beiträge: 9285
31. Dez 2004, 00:23
Beitrag #4 von 4
Beitrag ID: #133283
Bewertung:
(1119 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Problem mit 3 Frames!!!


Also da stimmt der Quellcode für die Definition
schon mal nicht:

<frameset rows="*">
<frameset rows="80,*,80">
<frame name="oben" noresize src="(EmptyReference!)">
<frame name="Haupt" noresize src="(EmptyReference!)">
<frame name="unten" noresize src="(EmptyReference!)">
</frameset>

Die müssen allen innerhalb von frameset stehen....

Ist Haupt auch immer wirklich groß geschrieben?
Unter Windows sieht man das häufig nicht richtig,
schau mal auf dem Sever in den Quellcode..

Gruß
Dirk

[Adobe GoLive Tipps & Tricks]
http://www.gltipps.de
Adobe GoLive CS Buch
http://www.galileodesign.de/685?GPP=levy
als Antwort auf: [#133276] Top
 
X