hilfdirselbst.ch
Facebook Twitter gamper-media
Mac OS X enthält verschiedene integrierte Werkzeuge und Technologien, mit denen sich gängige Aufgaben schnell und einfach automatisieren lassen.
Anonym
Beiträge: 22827
17. Okt 2003, 13:30
Beitrag #1 von 5
Bewertung:
(841 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme mit Script "PhotoXpress 3.6


Hallo,

ich habe mir hier:
http://home.earthlink.net/~mnieves/
das Script "PhotoXpress 3.6" geladen.

Beim ausführen bleibt es hier:
"set the image 1 of newPBox to picturepath"
mit der Fehlermeldung:
"QuarkXPress Passport 4.11 got an error: Can't make some data into the expected type"
stehen.

Was mache ich falsch?

Vielen Dank für die Tips!

Mikka Top
 
X
Hans Haesler  M  p
Beiträge: 5533
17. Okt 2003, 14:49
Beitrag #2 von 5
Beitrag ID: #418361
Bewertung:
(840 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme mit Script "PhotoXpress 3.6


Hallo Mikka,

welcome aboard! Ich habe das Script heruntergeladen und unverändert ausprobiert.

Resultat: Kein Problem. Ein Dokument wird erstellt, die Bildboxen werden erzeugt, die Bilder geladen und angepasst, die Namen der Bilder werden in Textboxen unterhalb der Bilder gesetzt.

Ich vermute, dass Du Mac OS 9.2 benutzt und dass die AppleScript-Version 1.7 installiert ist. Du kannst dies auf zwei Arten herausfinden:
1) Skripteditor starten, in das Fenster das Wort "version" tippen (ohne Anführungszeichen) und dieses Script ausführen. Im Ergebnisfenster erscheint die Versionsnummer.
2) Im Ordner Systemerweiterungen die Datei "AppleScript" auswählen und mit Befehl-I die Informationen aufrufen.

Wenn die Versionsangabe die Nummer "1.7" enthält, dann muss man ein Downgrade auf Version 1.6 vornehmen, wenn man Wert auf funktionierende Scripts legt. Zum Downgraden müssen nur zwei Dateien ausgewechselt werden: die Systemerweiterung "AppleScript" und die Scripting Addition (befindet sich im gleichnamigen Ordner im Systemordner) "Standard Additions".

Dieser Austausch ist gefahrlos. Wir haben ihn hier auf allen Macs vorgenommen und es ist kein einziges Problem gemeldet worden. Ich kann Dir die Dateien zustellen, wenn Du sie nicht auftreiben kannst.

Übrigens: das "PhotoXpress"-Script ist ein schönes Beispiel dafür, wie man ein Script nicht aufbauen soll: alle Befehle, auch jene an QuarkXPress sind in einem riesigen 'tell application "Finder"'-Block untergebracht. Und bei den XPress-Abschnitten gäbe es auch einiges zu optimieren. Aber es läuft ja …

Hans Haesler <hsa@ringier.ch>
als Antwort auf: [#418360] Top
 
Anonym
Beiträge: 22827
17. Okt 2003, 18:22
Beitrag #3 von 5
Beitrag ID: #418362
Bewertung:
(840 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme mit Script "PhotoXpress 3.6


Hallo Hans,

vielen Dank für die schnelle und ausführliche Antwort.

Ich bin zwar schon zuhause und kann es deshalb jetzt nicht ausprobieren, weiss aber, dass die AppleScript-Version 1.7 unter OS 9.2.2 installiert ist.

Wie ich an die zwei Dateien der 1.6 Version kommen soll, weiss ich leider nicht. Ich würde dein Angebot gerne annehmen. Ich will wegen Spam meine Email-Adresse hier nicht angeben, daher werde ich dir gleich eine Mail schicken.

1000 Dank nochmal. Tolles Forum!

Mikka
als Antwort auf: [#418360] Top
 
Hans Haesler  M  p
Beiträge: 5533
18. Okt 2003, 09:07
Beitrag #4 von 5
Beitrag ID: #418363
Bewertung:
(840 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme mit Script "PhotoXpress 3.6


Hallo Mikka,

bitte sehr. Nun, ich hätte noch ausführlicher sein können &#133; Die AS-Version hat ein Problem mit Pfaden. Aber ich habe mir nie die Zeit genommen, um einen Workaround zu testen, weil Experten noch verschiedene andere Dinge erwähnten, welche nicht funktionieren.

Inzwischen hat Apple die zuverlässige AS 1.8.3 veröffentlicht. Aber diese lässt sich nur auf einem englischen Mac OS installieren! Eine Ausnahme davon habe ich erlebt: zum Testen unter OS X wollte ich das 9.2.1-System einer anderen Partition als Classic-Umgebung benutzen. Ich erhielt die Meldung, dass dieses System zuerst angepasst werden müsste. Dies geschah auf mein OK automatisch: in meinem französischen Mac OS wurde AS 1.6 gegen 1.8.3 ausgetauscht!

Wer sich die 1.6-Version beschaffen möchte &#150; hier ist die Adresse: http://docs.info.apple.com/article.html?artnum=120001
In der Reihe "Deutsch" das Disketten-Symbol doppelklicken. Dann wird der Installer heruntergeladen.

Man kann die beiden Dateien aber auch problemlos manuell austauschen.

Hans Haesler <hsa@ringier.ch>
als Antwort auf: [#418360] Top
 
Anonym
Beiträge: 22827
20. Okt 2003, 17:42
Beitrag #5 von 5
Beitrag ID: #418364
Bewertung:
(840 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

Probleme mit Script "PhotoXpress 3.6


Hallo Hans,

klasse, jetzt läuft es mit AS 1.6.
Danke dir auch für das auf Quark 6 modifizierte Script.

Mikka
als Antwort auf: [#418360] Top
 
X