[GastForen Betriebsysteme und Dienste Apple (Hard- und Software) Verlorene Verbindung

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Themen
Beiträge
Moderatoren
Letzter Beitrag

Verlorene Verbindung

robinson
Beiträge gesamt: 786

25. Aug 2004, 15:09
Beitrag # 1 von 12
Bewertung:
(2551 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Ich habe hier folgendes Problem: Ich habe mir im Keller einen WLAN-Access-Point eingerichtet und dort einen kleinen File-Server installiert.
Jetzt habe ich zwar von meinem Mac aus Zugriff über Airport auf dessen Freigaben, oft aber verliere ich die Verbindung zu meinem Server (vor allem wenn die Backup-Software, ich verwende momentan Synk, automatisch darauf zugreifen soll). Dann kriege ich immer wieder die Meldung «Am File-Server XXX anmelden».
Hat irgendjemand eine Idee, wie ich meine Macs dazu bringen kann, ohne manuellen Eingriff die Verbindung erneut aufzubauen, bzw. gar nicht erst zu verlieren? Ich denke, es hat mit dem WLAN zu tun, was ich aber nicht ändern kann, da ich sonst viele Meter Ethernet-Kabel verlegen müsste.
X

Verlorene Verbindung

GoeGG-ArT
  
Beiträge gesamt: 2535

26. Aug 2004, 03:05
Beitrag # 2 von 12
Beitrag ID: #105191
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
im Keller?
wieviele meter und wieviel Stahlbeton-mauern muss denn AirPort durchdringen?

gruess
GöGG
**************************
G4 Dual 450Hz | OS X 10.3.5 | Safari 1.2.3


als Antwort auf: [#105081]

Verlorene Verbindung

GoeGG-ArT
  
Beiträge gesamt: 2535

26. Aug 2004, 03:14
Beitrag # 3 von 12
Beitrag ID: #105192
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
vielleicht hilft dir sowas hier:
AppleScript:
______
tell application "Finder"
if exists (disk "FILESERVERNAME") then

else
mount volume "afp://192.168.2.4/FILESERVERNAME"
end if
end tell
______
oder die nicht zu empfehlende Variante
AppleScript:

_____

tell application "Finder"
if exists (disk "FILESERVERNAME") then

else
mount volume "afp://benutzer:[email protected]/FILESERVERNAME"
end if
end tell
_____
aber eben es ist (habe ich auch eingesehen) nicht sehr schlau
wenn AppleSkript o.a.s mit Passwörter drin rumliegen.
Ausser das passwort ist eh allen bekannt..;)

gruess
GöGG
**************************
G4 Dual 450Hz | OS X 10.3.5 | Safari 1.2.3


als Antwort auf: [#105081]

Verlorene Verbindung

robinson
Beiträge gesamt: 786

26. Aug 2004, 03:30
Beitrag # 4 von 12
Beitrag ID: #105193
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Also die Verbindungsqualität ist nicht wirklich schlecht (trotz Stahbeton).
Das wäre ein Versuch wert, aber wie schon so oft ist das wohl eher eine Symtombekämpfung. Inzwischen weiss ich, dass das Problem die Software auf dem Server ist (AFP 2.2 unterstüzt kein «reconnect»; wäre aber nötig, da die Verbindung dank Ruhezustand des Clients abbricht). Darum werde ich die Variante mit dem AppleScript versuchen und hoffe, dass ein Software-Update (der irgendwann von Buffalo-Tech zu erwarten ist) das Problem an der Wurzel packt.


als Antwort auf: [#105081]

Verlorene Verbindung

robinson
Beiträge gesamt: 786

26. Aug 2004, 03:32
Beitrag # 5 von 12
Beitrag ID: #105194
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Übrigens:
Wie mache ich das Ganze, wenn ich als Gast auf den Server zugreifen will?


als Antwort auf: [#105081]

Verlorene Verbindung

Thomas Kaiser
Beiträge gesamt: 1299

26. Aug 2004, 12:48
Beitrag # 6 von 12
Beitrag ID: #105273
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hi,

> Wie mache ich das Ganze, wenn ich als Gast auf den Server zugreifen will?

So, wie Du es immer machen solltest, wenn Du Paßwörter per WLAN durch die Gegend wirfst: Indem Du die Kontrolle über die zu verwendende UAM behältst, d.h. indem Du die passende (in dem Fall Gastzugang, also "No User Authent") angibst. Vgl. mit:

     http://users.phg-online.de/...t%20afp-servers.html

Wenn man ansonsten diese Methode per AppleScript versucht (die insofern doof ist, als es wegen "Paßwort im Klartext" viel eleganter wäre, einfach ein Alias des Volume mit Paßwort im Schlüsselbund per Finder zu erstellen und dieses dann per AppleScript und "open" aufzurufen), sollte man tunlichst darauf achten, in welcher Form dabei die Paßwörter durchs Netz gehen -- insbesondere bei WLAN!

Hier bietet es sich grundsätzlich an, eine starke UAM, d.h. Minimum "DHCAST128" vorzugeben (so sie denn der Server unterstützt). Einen Kurzüberblick über UAMs habe ich mal hier geschrieben (gilt sinngemäß auch für andere AFP-Server als Netatalk) und dort ist auch ein sehr ausführlicher Artikel bei Apple verlinkt:

     http://netatalk.sourceforge.net/....html#authentication

Gruss,

Thomas


als Antwort auf: [#105081]

Verlorene Verbindung

robinson
Beiträge gesamt: 786

26. Aug 2004, 12:57
Beitrag # 7 von 12
Beitrag ID: #105276
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Ich hatte mich hier (users.phg-online.de/tk/automount%20afp-servers.html) schon informiert. Dieser (blöde) Server (Buffalo LinkStation; bin sonst eigentlich sehr zufrieden damit) stellt dann aber diesen Teil (;AUTH=No%20User%20Authent) ins Feld «Benutzernamen». Darum meine dumme Frage.


als Antwort auf: [#105081]

Verlorene Verbindung

Thomas Kaiser
Beiträge gesamt: 1299

26. Aug 2004, 13:10
Beitrag # 8 von 12
Beitrag ID: #105285
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo,

> Dieser (blöde) Server (Buffalo LinkStation; bin sonst eigentlich
> sehr zufrieden damit)

Das Teil benutzt anscheinend Netatalk für den AFP-Part. Sei doch mal so nett und laß gegen die IP-Adresse von dem "asip-status-pl" laufen (liegt auch auf meiner alten Seite neben den AFP-Mount Ausführungen) und poste hier den kompletten Output.

> stellt dann aber diesen Teil (;AUTH=No%20User%20Authent) ins Feld
> «Benutzernamen». Darum meine dumme Frage.

Oha, das ist aber kein Fehler von der Station, sondern dann stimmt die Syntax des mount Aufrufes nicht (mehr). Ich geh der Sache mal kurz nach, bleib aber dabei, daß es am Sinnigsten wäre, wenn Du per Finder Volume-Aliase anlegst und diese dann referenzierst. Siehe auch

     http://www.cocoa-co.de/.../wiki.pl?MountOMatic

Gruss,

Thomas


als Antwort auf: [#105081]

Verlorene Verbindung

Thomas Kaiser
Beiträge gesamt: 1299

26. Aug 2004, 13:18
Beitrag # 9 von 12
Beitrag ID: #105291
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo,

> das ist aber kein Fehler von der Station, sondern dann stimmt die
> Syntax des mount Aufrufes nicht (mehr)

Jetzt isses klar. Die Syntax mit Angabe der UAM war die für den Aufruf von /sbin/mount_afp. Per AppleScript geht das anscheinend nicht.

Also führt der Umweg evtl. über AppleScripts "do shell script" (wobei ich abermals die Variante, einfach ein Alias per "open" zu öffnen, vorziehen würde).

BTW: Netatalk 2.0, das sich momentan wohl doch noch Richtung "final" bewegt, beherrscht reconnect. Du kannst das ja die "Entwickler" von Buffalo wissen lassen. Sie dürfen aber auch zur Kenntnis nehmen, daß sich die Lizenz der neuen Teile geändert hat, d.h. sie nicht mehr so einfach nur "Nehmen" können, sondern -- falls sie Änderungen an Netatalk machen -- das Ganze auch der Gemeinschaft zurückgeben müssen.

An dem asip-status.pl Output bin ich immer noch interessiert :-)

Gruss,

Thomas


als Antwort auf: [#105081]

Verlorene Verbindung

robinson
Beiträge gesamt: 786

26. Aug 2004, 14:05
Beitrag # 10 von 12
Beitrag ID: #105315
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Das ist die Rückmeldung deines Progrämmchens:

AFP reply from aregger.gotdns.com:548
Flags: 1 Cmd: 3 ID: 57005
Reply: DSIGetStatus
Request ID: 57005
Machine type: unix
AFP versions: AFPVersion 1.1,AFPVersion 2.0,AFPVersion 2.1,AFP2.2
UAMs: DHCAST128,Cleartxt Passwrd,No User Authent
Flags: SupportsCopyFile,SupportsServerMessages,SupportsServerSignature,SupportsTCP/IP,SupportsSrvrNotifications,SupportsSuperClient
Server name: LINKSTATION
Signature:
00 58 0a 00 00 58 0a 00 00 58 0a 00 00 58 0a 00 .X...X...X...X..

Network address: 10.0.0.88 (tcp/ip address)
Network address: 65280.80 (ddp address)

Das Problem mit den Server-Alias ist, dass ich das schon probiert habe, der Mac aber trotzdem (ich denke eben, wegen fehlendem «reconnect») die Verbindung verliert.
Ich habe jetzt mal versucht ein «.automounted» in den Mountpoint zu stellen: bei der ersten Station, bei der ich das gemacht hatte, hat es funktioiert.

Von Buffalo habe ich die Nachricht erhalten (dort allerdings wegen der Nicht-Unterstützung langer Dateinamen; auch ein Problem von AFP 2.2), dass momentan an einer neuen Firmware gearbeitet wird: leider ohne Terminangabe.


als Antwort auf: [#105081]

Verlorene Verbindung

Thomas Kaiser
Beiträge gesamt: 1299

28. Aug 2004, 15:13
Beitrag # 11 von 12
Beitrag ID: #105627
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo,

> Das Problem mit den Server-Alias ist, dass ich das schon probiert
> habe, der Mac aber trotzdem (ich denke eben, wegen fehlendem
> «reconnect») die Verbindung verliert.

Schon klar. Aber da hilt eben ein AppleScript, das periodisch (idle Handler benutzen) die Volume-List prüft und dann eben das Server-Alias wieder öffnet (oder gleich stumpf das Alias jede Minute öffnen -- passiert ja nix, wenn das Volume eh schon gemountet ist)

> Ich habe jetzt mal versucht ein «.automounted» in den Mountpoint
> zu stellen: bei der ersten Station, bei der ich das gemacht hatte,
> hat es funktioiert.

Also das ".automounted" wird eigentlich vom System selbst in den physischen Mountpoint gelegt, also wenn der Server als /Volumes/Trallala bspw. eingehängt werden soll, dann wird *vor* dem Mount dort eben /Volumes/Trallala/.automounted angelegt, damit das System beim nächsten Neustart merkt, daß diese Verzeichnisse (die evtl. zurückbleiben, wenn MacOS X unsauber beendet wurde) automatisch erzeugt wurden und eben deshalb wieder entsorgt werden können.

> Von Buffalo habe ich die Nachricht erhalten (dort allerdings wegen
> der Nicht-Unterstützung langer Dateinamen; auch ein Problem von
> AFP 2.2), dass momentan an einer neuen Firmware gearbeitet wird:
> leider ohne Terminangabe.

Naja, hinter der "Firmware" versteckt sich ein stinknormales Linux, der AFP-Server ist Netatalk (wahrscheinlich 1.6.4). Netatalk 2.0 ist aktuell bei 2.0-rc1 (d.h. erster Release Candidate) angelangt. Wenn alles gut geht, dann gibt es spätestens am 1. Oktober Netatalk 2.0. Die "Entwickler" bei Buffalo können aber ruhig schon jetzt ihre Integrationsbemühungen starten, da sich an Features bis zur 2.0 nichts mehr tun wird. Du kannst sie ja direkt mit der Nase auf

     http://netatalk.sourceforge.net/...tmldocs/upgrade.html

stossen.

Gruss,

Thomas


als Antwort auf: [#105081]

Verlorene Verbindung

robinson
Beiträge gesamt: 786

30. Sep 2004, 02:24
Beitrag # 12 von 12
Beitrag ID: #112141
Bewertung:
(2549 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Thomas

Unter diesem Link findet man die neue Firmware:
http://www.buffalotech.com/...ownloads-product.php

Leider immer noch mit Netatalk 1.6.4

Gäbe es evtl. die Möglichkeit Netatalk 2 darauf zu installieren? Hast du Erfahrung mit solchen Manövern?

Danke!


als Antwort auf: [#105081]
X

Aktuell

Veranstaltungskalender

Hier können Sie Ihre Anlässe eintragen, welche einen Zusammenhang mit den Angeboten von HilfDirSelbst.ch wie z.B. Adobe InDesign, Photoshop, Illustrator, PDF, Pitstop, Affinity, Marketing, SEO, Büro- und Rechtsthemen etc. haben. Die Einträge werden moderiert freigeschaltet. Dies wird werktags üblicherweise innert 24 Stunden erfolgen.

pdf-icon Hier eine kleine Anleitung hinsichtlich Bedeutung der auszufüllenden Formularfelder.

Veranstaltungen
23.11.2020 - 24.11.2020

Digicomp Academy AG, Luzern, St. Gallen, Zürich
Montag, 23. Nov. 2020, 08.30 Uhr - Dienstag, 24. Nov. 2020, 17.00 Uhr

Kurs

In diesem Advanced-Kurs erlernen Sie weitergehende Methoden im Dokumentenaufbau, der Typografie und im Bereich Layouttechniken. Nach diesem Kurs können Sie strukturierte Dokumente erstellen oder bestehende effizienter anpassen.

Preis: CHF 1'400.-
Dauer: 2 Tage

Nein

Organisator: Digicomp Academy AG

Kontaktinformation: Isil Günalp, E-Mailisil.guenalp AT digicomp DOT ch

https://www.digicomp.ch/weiterbildung/software-anwendungs-trainings/adobe-trainings/desktop-publishing/adobe-indesign-cc/kurs-indesign-cc-advanced

Veranstaltungen
23.11.2020 - 24.11.2020

Digicomp Academy AG, Basel und Bern
Montag, 23. Nov. 2020, 08.30 Uhr - Dienstag, 24. Nov. 2020, 17.00 Uhr

Kurs

Mit After Effects können Sie visuelle Effekte und Animationen für Video, Web, DVD und Blu-Ray erzeugen. In diesem Kurs lernen Sie die Grundlagen kennen und sehen inspirierende Anwendungsbeispiele, die Ihnen helfen, Ihre eigenen Ideen umzusetzen.

Preis: CHF 1'700.-
Dauer: 2 Tage

Nein

Organisator: Digicomp Academy AG

Kontaktinformation: Isil Günalp, E-Mailisil.guenalp AT digicomp DOT ch

https://www.digicomp.ch/weiterbildung/software-anwendungs-trainings/adobe-trainings/video-und-audio-publishing/adobe-after-effects-cc/kurs-adobe-after-effects-basic

Neuste Foreneinträge


Bilder exportieren

Satz für blinde bzw. seheingeschränkte Menschen

Mockup Alias Ebene erstellen

Preflight Ticket Signature Preflight.p12

Fußnote im Fließtext Fett dargestelllt?

Abbildungsunterschriften: Numerierung pro Kapitel neu

ExtendScript Toolkit CS6 - Fenster von 'suchen & ersetzen' erscheint nicht mehr

Grep suche nur erster Fund anzeigen

Spaltenfarben in Tabelle mit Script

Probleme mit dem Strukturbaum Acrobat Pro DC (barrierefrei)
medienjobs