[GastForen Archiv Perl und CGI cgi auf NT Server

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Archiv - Archivierte Foren
Themen
Beiträge
Moderatoren
Letzter Beitrag

cgi auf NT Server

Schomo
Beiträge gesamt: 96

2. Mai 2002, 17:23
Beitrag # 1 von 6
Bewertung:
(3627 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hi,
wer hat schon mal auf einem NT Server cgi's installiert?
Ich muss sagen, dass ich etwas verwirrt bin, da ich jetzt aus mehreren Quellen erfahren hab, dass ich die Quelle nicht als cgi/datei.pl ansprechen darf, sondern scripte/datei.pl! Was soll das? Das darf doch nicht wahr sein, dass Microbensaft auch in diesem Bereich sein Extrasüppchen kocht! Noch schlimmer finde ich die Aussage von Dr.Web.de dass die Pfade mit Windows "backslash" statt "slash" angegeben werden sollen. Geht's noch?(http://www.ideenreich.com/programmierung/cgi_3.shtml)

Ein immer noch verwirrter Schomo

[ Diese Nachricht wurde geändert von: Schomo am 2002-05-02 17:43 ]

[ Diese Nachricht wurde geändert von: Schomo am 2002-05-02 17:43 ]
X

cgi auf NT Server

SabineP
Beiträge gesamt: 7586

2. Mai 2002, 20:08
Beitrag # 2 von 6
Beitrag ID: #3443
Bewertung:
(3627 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
!-- BBCode Quote Start -->
Zitat:
Wer hat schon mal auf einem NT Server cgi's installiert?
Was meinst Du mit "NT Server" ? Welcher Webserver ist gemeint? Internet Information Server, Apache, Sambar OmniHTTPd...
Zitat:
Ich muss sagen, dass ich etwas verwirrt bin, da ich jetzt aus mehreren Quellen erfahren hab, dass ich die
Quelle nicht als cgi/datei.pl ansprechen darf, sondern scripte/datei.pl!
Das hängt ganz von der Konfiguration des Webservers ab. Der kann auch so eingerichtet sein, daß in jedem Verzeichnis Perl-Programme ausgeführt werden können. Die Dateiendung
darf auch *.cgi sein. Das kann man im Registrierungseditor angeben
Zitat:
Noch schlimmer finde ich die Aussage von Dr.Web.de dass die Pfade mit Windows "backslash" statt "slash" angegeben werden sollen.
Das ist Unsinn. Perl kann mit einem "backslash" im Pfad_zu_einer_Datei nichts anfangen. Lediglich während
der Webserverkonfiguration kann es vorkommen daß die Pfade mit "backslash" angegeben werden, damit der Webserver weiß wo bestimmte Dateien oder Verzeichnisse zu finden sind.
Das gilt zum Beispiel nicht für den Apache Webserver.

[ Diese Nachricht wurde geändert von: SabineP am 2002-05-02 20:25 ]


als Antwort auf: [#3438]

cgi auf NT Server

Ollli
Beiträge gesamt: 458

2. Mai 2002, 20:39
Beitrag # 3 von 6
Beitrag ID: #3445
Bewertung:
(3627 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Das mit dem Backslash bezieht sich wohl mehr auf Verweise, die im Perl-Script stehen. Ich jedenfalls gebe bei Verweisen immer Backslashes an

z.B.:
\programme\server\cgi-bin\dats\db.txt

Ollli


als Antwort auf: [#3438]

cgi auf NT Server

Schomo
Beiträge gesamt: 96

2. Mai 2002, 20:49
Beitrag # 4 von 6
Beitrag ID: #3446
Bewertung:
(3627 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hi,
ich weiss bis jetzt nicht, welcher Webserver installiert ist. Der Provider meldet sich nicht, und der Kunde hat keine Info. Blindflug praktisch. "Schwitz"
Vielleicht hab ich morgen mehr Info. Das Schlimme ist, dass auf der Site Frontpage installiert ist, und die Site so weiterlaufen muss, bis ich den Scheiss gekillt habe. Sorry für die Formulierung, aber das Programm ist der Alptraum. Is ne Verkaufseite, die täglich erreichbar sein muss.

Schomo


als Antwort auf: [#3438]

cgi auf NT Server

SabineP
Beiträge gesamt: 7586

2. Mai 2002, 23:21
Beitrag # 5 von 6
Beitrag ID: #3454
Bewertung:
(3627 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Schomo, hast Du irgendeine Fehlermeldung?
Wenn ja, wie sieht die denn aus?


als Antwort auf: [#3438]

cgi auf NT Server

Schomo
Beiträge gesamt: 96

3. Mai 2002, 15:14
Beitrag # 6 von 6
Beitrag ID: #3474
Bewertung:
(3627 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Danke an alle.
Ich hab das Problem gelöst. Die Backslashmethode ist nur bei .exe angesagt. Hmm!Für Perl und PHP ist das egal.

Gruss Schomo


als Antwort auf: [#3438]
X