[GastForen Archiv Adobe GoLive css: probleme mit first-letter in gecko

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Archiv - Archivierte Foren
Themen
Beiträge
Moderatoren
Letzter Beitrag

css: probleme mit first-letter in gecko

ollematze
Beiträge gesamt: 16

9. Jun 2005, 22:24
Beitrag # 1 von 7
Bewertung:
(1995 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
  css: probleme mit first-letter in gecko

--------------------------------------------------------------------------------

hallo zusammen, ich erstelle gerade eine site für meinen zahnarzt

eins der probleme: im ie sieht die site genau so aus, wie ich das will, zumindest fast; so könnte ich damit leben.
auf der linken seite ist eine unternavigation namens praxis lexikon. das first-letter element habe ich gerade erst entdeckt und ich muß sagen, daß das eine tolle sache ist.
leider funktioniert das in den gecko-browsern nicht so richtig, besonders im firefox. der stellt den jeweils ersten buchstaben zwar auch in der gewollten farbe dar, aber die schriftgröße bleibt klein wie die darauf folgenden buchstaben.
und was noch viel schlimmer ist: wenn ich mit der maus über die links fahre, erlöschen die first-letter farben, außerdem "zuckt" alles so komisch.
was mache ich falsch?

zweites problem: diees praxis lexikon habe ich für kleinere auflösungen mit einem overflow:auto versehen.
wenn ich im firefox mit 1024x768 die scrollleiste des praxis lexikons betätige, komme ich nicht bis zum untersten link, ohne die hauptscrollleiste ebenfalls zu bemühen. genau das wollte ich aber mit dem overflow verhindern- im ie klappt es.
das entsprechende div (#side) habe ich auch mit einem padding nach unten von 10 em versehen, im firefox hört das div aber mit dem letzten link auf. genau das ist wohl das problem. was kann ich tun?

ich weiß, mit 800x600 verutscht das layout, ich arbeite noch daran. vermutlich werde ich das bild vom praxisteam kleiner machen müssen.

und wenn ihr schon mal beim schauen seid, höre ich mir auch gern kommentare und kritik zum design an. muß aber nicht sein; problemlösungen wären mir wichtiger. vielen dank!

hier die links:

http://www.hommestest.de/new/
http://www.hommestest.de/new/zahn.css

danke & gruß matthias
X

css: probleme mit first-letter in gecko

SabineP
Beiträge gesamt: 7586

9. Jun 2005, 22:58
Beitrag # 2 von 7
Beitrag ID: #171236
Bewertung:
(1995 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Matthias,

da ist noch ein winziger Fehler im HTML-Code:http://www.hommestest.de/new/%23

deshalb kann man den CSS-Code noch nicht prüfen:http://www.hommestest.de/new/%23

first-letter müßte im Firefox eigentlich klappen:

http://www.w3.org/...S1/current/sec26.htm
http://www.w3.org/...S1/current/sec24.htm

Vielleicht liegts am HTML-Fehler, oder am CSS-Code oder an etwas anderem.
Mach mal den Fehler raus, dann sehen wir weiter.

Gruß Sabine


als Antwort auf: [#171219]
(Dieser Beitrag wurde von SabineP am 9. Jun 2005, 22:58 geändert)

css: probleme mit first-letter in gecko

SabineP
Beiträge gesamt: 7586

9. Jun 2005, 23:14
Beitrag # 3 von 7
Beitrag ID: #171238
Bewertung:
(1995 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Noch etwas zur Ergänzung:
http://www.w3.org/...or.html#first-letter
The :first-letter pseudo-element matches parts of block-level elements only.

first-letter funktioniert nur bei Block-Level-Elementen.
Der <A> Tag ist jedoch kein Block-Level-Elementen.

Vielleicht hilft diese Ergänzung im CSS
a.side{display:block}

Gruß Sabine


als Antwort auf: [#171219]

css: probleme mit first-letter in gecko

ollematze
Beiträge gesamt: 16

10. Jun 2005, 09:36
Beitrag # 4 von 7
Beitrag ID: #171283
Bewertung:
(1995 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
hallo sabine,

danke für den hinweis; den fehler habe ich beseitigt, code und css sind valide.
die probleme bestehen leider nach wie vor.
mit deinem tip a.side{display:block} in die css-datei zu schreiben, werden die first-letter überhaupt nicht mehr angezeigt (!), weder im ie noch im ff. sehr eigenartig. jetzt fällt mir gar nichts mehr ein.....

gruß matthias


als Antwort auf: [#171219]

css: probleme mit first-letter in gecko

ollematze
Beiträge gesamt: 16

10. Jun 2005, 09:50
Beitrag # 5 von 7
Beitrag ID: #171288
Bewertung:
(1995 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
ich habe es übrigens auch mit p.side{display:block} probiert, geht auch nicht.


als Antwort auf: [#171219]

css: probleme mit first-letter in gecko

SabineP
Beiträge gesamt: 7586

10. Jun 2005, 12:29
Beitrag # 6 von 7
Beitrag ID: #171333
Bewertung:
(1995 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Ich habe Dir mal ein Beispiel gebaut:

<div> ist ein Block-Level-Element
first-letter darf nur für solche Elemente angewendet werden.


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<HTML>
<HEAD>
<TITLE> New Document </TITLE>
<style>
.side:first-letter {font-size:2em}
</style>
</HEAD>

<BODY>
<a href="#"><div class="side">Diagnodent</div></a>
</BODY>
</HTML>

Gruß Sabine


als Antwort auf: [#171219]

css: probleme mit first-letter in gecko

ollematze
Beiträge gesamt: 16

11. Jun 2005, 13:27
Beitrag # 7 von 7
Beitrag ID: #171460
Bewertung:
(1995 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
vielen dank, sabine.
ich hab jetzt alles mögliche ausprobiert, deshalb hat es etwas gedauert mit meiner antwort- nebenbei hab ich ja auch noch ´ne familie :)
wenn ich deinen vorschlag umsetze, passiert folgendes: first-letter und die restlichen buchstaben haben alle die first-letter größe.
im ff hovert plötzlich der gesamte seitentext! war also nicht so der hit, obwohl ich sicher war, daß es so funktionieren würde.
jetzt habe ich dies gemacht: in der css-datei habe ich das p von p.side entfernt, das hat folgendes gebracht: im ie sieht´s aus wie vorher, also so wie ich es haben will; im ff hat der first-letter zwar immer noch nicht die größe übernommen, aber: die first-letter-farbe verschwindet nicht mehr, wenn ich mit der maus über die links fahre und es flackert nicht mehr so komisch. warum auch immer, nachvollziehen kann ich das nicht... so bin ich jedenfalls für´s erste zufrieden.

das zweite problem habe ich so gelöst: da der ff das padding-bottom in #side nicht angenommen hat, habe ich´s jetzt ganz weggemacht und unter die links einfach noch 5-6 mal <p>&nbsp</p> eingefügt.

ich wünsche allen noch ein schönes wochenende, wir werden sicher bald wieder voneinander lesen ;-))

gruß matthias


als Antwort auf: [#171219]
X