Forenindex » Programme » Print/Bildbearbeitung » Adobe InDesign » Absatzformate kopieren

i-tupfer
Beiträge: 72
23. Jan 2007, 15:13
Bewertung:
gelesen: 15507
Beitrag als Lesezeichen

Absatzformate kopieren


Irgendwas läuft hier krumm: (InDesign CS2 - OSX 10.3.9)

Ich habe auf einer Seite 2x die gleiche Headline.

Wenn ich nun hingehe, und die Headline mit Apfel+C kopiere und im selben Textkasten wieder einfügen möchte, übernimmt er die Absatzformatierung nicht komplett. (heißt: die Schriftgröße bleibt bestehen, die Schrift wird aber in Helvetica eingefügt.) In der Zeichenpalette (unten) wird die Helvetica auch in eckigen Klammern angezeigt. In der Absatzformate-Palette zeigt er mir "Headline+" an.

Das Absatzformat basiert auf "Kein Absatz" und auch das nächste Format steht auf "Gleiches". Ich habe grundsätzlich nirgendwo die Helvetica angegeben, sondern die Excelsior.

Das ganze findet auch dann statt, wenn ich keine Helvetica in Suitcase geöffnet habe.

Wo mach ich hier was falsch???
Top
 
mpeter  M 
Beiträge: 4539
23. Jan 2007, 15:18
Bewertung:
gelesen: 15457
Beitrag als Lesezeichen

Absatzformate kopieren


Hi,
ich tippe mal auf Objektstil in dem die Helvetica definiert ist oder in den Umbruchoptionen bei »Absatzbeginn« eine fehlerhafte Einstellung.
Gruß
Magnus

OSX 10.9.4, Adobe CS6
... und kein Quark mehr zum Nachtisch Top
 
i-tupfer
Beiträge: 72
23. Jan 2007, 15:37
Bewertung:
gelesen: 15448
Beitrag als Lesezeichen

Absatzformate kopieren


Antwort auf [ mpeter ] Hi,
ich tippe mal auf Objektstil in dem die Helvetica definiert ist oder in den Umbruchoptionen bei »Absatzbeginn« eine fehlerhafte Einstellung.


?? Objektstile - hm - ich habe mal alle Abweichungen der Objektstile gelöscht, das Format "Headline" neu vergeben und wenn ich die Überschrift nun kopiere und einfüge passiert immer noch das gleiche.

Umbruchoptionen - Absatzbeginn?? Da kann ich nur eine Position auswählen.

Sorry, bin gerade erst auf Indesign umgestiegen. War vorher auf Quark :-)

Folgendes hab ich noch ausprobiert:
Neuen Textrahmen aufgezogen
Objektstil "Keine" zugewiesen
Text eingetippt
Format "Headline" zugewiesen
diesen Text kopiert
eingefügt
und - immer noch das selbe! :-(
(Dieser Beitrag wurde von i-tupfer am 23. Jan 2007, 15:45 geändert)
Top
 
Martin Fischer  M  p
Beiträge: 11834
23. Jan 2007, 15:45
Bewertung:
gelesen: 15438
Beitrag als Lesezeichen

Absatzformate kopieren


Holla i-tupfer,

handelt es sich um eine konvertierte oder um eine neu angelegte Datei?

Eventuell hilft ein Waschgang im Austauschformat: Datei im InDesign Interchange-Format (inx) exportieren und wieder öffnen und das Verhalten mit copy & paste prüfen.

Viele Grüße
Martin Top
 
Michael Pabst S
Beiträge: 2463
23. Jan 2007, 15:53
Bewertung:
gelesen: 15431
Beitrag als Lesezeichen

Absatzformate kopieren


Hallo,

evtl. mal gucken, ob dem neu aufgezogenen Textrahmen nicht ein Zeichenformat als Standard zugewiesen ist.

Gruß
Michael

MacBook Pro 2.8 GHz Intel Core i7, 16 GB 1600 MHz DDR3, High Sierra, Adobe CC/silver] Top
 
i-tupfer
Beiträge: 72
23. Jan 2007, 15:57
Bewertung:
gelesen: 15429
Beitrag als Lesezeichen

Absatzformate kopieren


Antwort auf [ Martin Fischer ] Holla i-tupfer,

handelt es sich um eine konvertierte oder um eine neu angelegte Datei?

Eventuell hilft ein Waschgang im Austauschformat: Datei im InDesign Interchange-Format (inx) exportieren und wieder öffnen und das Verhalten mit copy & paste prüfen.


Es ist eine selbst angelegte Datei. Aber wie gesagt. Ich bin blutiger Anfänger.
Wir kommen der Sache aber schon näher.

Ich habe gerade festgestellt, das wenn ich ein neues Dokument anlege, und genau dieses Absatzformat importiere, den Text kopieren und einfügen kann, so wie ich mir das vorstelle. Mit allem Pi-pa-po!

Da ich aber 13 solcher Dateien mit jeweils ca. 12 verschiedenen Absatzformaten habe, wäre es schön, wenn ich an den Kern des Problems kommen könnte. Das mit dem exportieren und wieder öffnen hat leider nichts gebracht...
(Dieser Beitrag wurde von i-tupfer am 23. Jan 2007, 16:01 geändert)
Top
 
i-tupfer
Beiträge: 72
23. Jan 2007, 16:02
Bewertung:
gelesen: 15421
Beitrag als Lesezeichen

Absatzformate kopieren


Antwort auf [ Pabst ] Hallo,

evtl. mal gucken, ob dem neu aufgezogenen Textrahmen nicht ein Zeichenformat als Standard zugewiesen ist.

Gruß
Michael


Nein, da hab ich schon drauf geachtet.
Top
 
mpeter  M 
Beiträge: 4539
23. Jan 2007, 16:46
Bewertung:
gelesen: 15403
Beitrag als Lesezeichen

Absatzformate kopieren


Hi,
wenn du auf das Textwerkzeug gehst und KEIN Rahmen markiert ist in der Zeichen-, Absatz-, Objektpalette überprüfen, ob wirklich kein Stil ausgewählt ist. Unter den Umbruchoptionen darauf achten, dass bei Absatzbeginn »beliebige Position« gewählt ist. Wenn es jetzt immer noch nicht hinhaut weiß ich auch nicht mehr.
Gruß
Magnus

OSX 10.9.4, Adobe CS6
... und kein Quark mehr zum Nachtisch Top
 
Gerald Singelmann  M  p
Beiträge: 6178
23. Jan 2007, 20:33
Bewertung:
gelesen: 15375
Beitrag als Lesezeichen

Absatzformate kopieren


Probieren Sie mal Folgendes:
- exportieren Sie die Datei ins Austauschformat / Interchangeformat
- öffnen Sie die inx Datei in einem Texteditor.
- in der inx Datei gibt es einen Absatz, der mit <psty pnam="k_[No paragraph style]" anfängt. Suchen Sie diesen
- in diesem Abschnitt ist ein Eintrag, der mit font="c_ anfängt. Bei meiner Test-datei 3 Zeilen unter <psty pnam

Welcher Font steht hier in Ihrer inx-Datei?
Wenn etwas anderes als font="c_Times" dann ersetzen Sie den Eintrag gegen die Times. Speichern Sie die inx und öffnen Sie diese wieder in InDesign.
Geht's wieder?
--------------------------

InDesign-Wissen und Automatisierung nicht nur rund um die Suite.

http://www.cuppascript.com Top
 
i-tupfer
Beiträge: 72
24. Jan 2007, 10:51
Bewertung:
gelesen: 15338
Beitrag als Lesezeichen

Absatzformate kopieren


Antwort auf [ Gerald Singelmann ] Probieren Sie mal Folgendes:
- exportieren Sie die Datei ins Austauschformat / Interchangeformat
- öffnen Sie die inx Datei in einem Texteditor.
- in der inx Datei gibt es einen Absatz, der mit <psty pnam="k_[No paragraph style]" anfängt. Suchen Sie diesen
- in diesem Abschnitt ist ein Eintrag, der mit font="c_ anfängt. Bei meiner Test-datei 3 Zeilen unter <psty pnam

Welcher Font steht hier in Ihrer inx-Datei?
Wenn etwas anderes als font="c_Times" dann ersetzen Sie den Eintrag gegen die Times. Speichern Sie die inx und öffnen Sie diese wieder in InDesign.
Geht's wieder?


Jaaaaa! Vielen Dank. Ich bin gestern echt frustriert in den Feierabend gegangen. Aber was ist da falsch gelaufen? Ich habe noch 13 solcher Dateien. Können Sie aufgrund dessen, das bei mir dort die Helvetica stand nun vielleicht sagen, was in Indesign verändert werden muss? Oder muss ich alle 13 Dateien Exportieren und ändern?
Top
 
lowtone S
Beiträge: 145
24. Jan 2007, 11:47
Bewertung:
gelesen: 15328
Beitrag als Lesezeichen

Absatzformate kopieren


Lieber Herr Singelmann,
Was bitte war DAS????
Ich sitze mit Bewunderung vor meinem Monitor und frage mich ernsthaft, was Sie soeben beschrieben haben. Dass Sie die Lösung des Problems kennen wundert mich ja nicht weiter, aber können Sie erklären, welche Einstellungen / Veränderungen da vorgenommen wurden? Zumal die Times doch nun bisher gar nicht erwähnt wurde?
Ich verstehe immer gerne, anstatt nur die Lösung zu wissen ...
Beste Grüße,
simon wehr
Top
 
i-tupfer
Beiträge: 72
24. Jan 2007, 13:02
Bewertung:
gelesen: 15315
Beitrag als Lesezeichen

Absatzformate kopieren


Antwort auf [ lowtone ] Lieber Herr Singelmann,
Was bitte war DAS????
Ich sitze mit Bewunderung vor meinem Monitor und frage mich ernsthaft, was Sie soeben beschrieben haben. Dass Sie die Lösung des Problems kennen wundert mich ja nicht weiter, aber können Sie erklären, welche Einstellungen / Veränderungen da vorgenommen wurden? Zumal die Times doch nun bisher gar nicht erwähnt wurde?
Ich verstehe immer gerne, anstatt nur die Lösung zu wissen ...
Beste Grüße,
simon wehr


Stimmt - fällt mir auch gerade auf. Die Headline ist aber eine Times. Das kann er aber nicht wissen.
Und in einem anderen Dokument ist mir auch schon aufgefallen, dass es NUR die Times ist, die nicht ersetzt wird. Jede andere Schrift schon.
Es muss irgendwas mit der Times zu tun haben. Sie hatte zwischenzeitlich auch Probleme mit einer meiner Systemschriften. Leider erwähnt der Mac nicht mit einem Wort, mit welcher Systemschrift die Times da kollidiert.

Wir bitten um eine Erklärung, großer Guru! :-))))
Top
 
Gerald Singelmann  M  p
Beiträge: 6178
24. Jan 2007, 13:07
Bewertung:
gelesen: 15309
Beitrag als Lesezeichen

Absatzformate kopieren


Hier also die Theorie hinter der schlichten Lösung.

InDesign CS2 hat ein anderes Verhalten als bisherige Versionen und alle anderen Layout-Programme, wenn es darum geht, wie Absatzformate auf anderen Absatzformaten basieren.
Notorisch (hier glaube ich auch schon ein zwei Mal diskutiert) ist das "Basiert auf [Einfacher Absatz]": wenn im Zieldokument der [Einfache Absatz| anders definiert ist als im Quelldokument ändert sich die Formatierung.

Wenn innerhalb desselben Dokuments sich die Formatierung ändert, kann es nicht am [Einfachen Absatz] liegen. Zumal ja berichtet wurde, dass die AFs auf [Kein Absatzformat] basieren.

Während die Theorie sagt, dass [Kein Absatzformat] sich nie ändern kann und immer Times, 12pt etc. ist, habe ich schon Rechner / Dokumente gesehen, bei denen diese Definition zerschossen war und stattdessen i.d.R. eine Helvetica für [Kein Absatzformat] angelegt war. Das, wie gesagt, darf nicht sein und daher gibt es innerhalb von InDesign auch keine UI Möglichkeit, das wieder zurück zu ändern.
Also bleibt nur der Weg über das Austauschformat, wo kurioserweise [Kein Absatzformat] einen Definitionsblock hat. Und damit korrigiert werden kann.

Also lag die Vermutung nahe, dass bei diesen Dokumenten auch die Definition von [Kein Absatzformat] kaputt ist.
Bestehende Dokumente können meines Wissens nur auf dem beschriebenen Weg repariert werden.
Wenn das Problem auch bei neu angelegten Dokumenten passiert, ist es Zeit, die Preferences zu löschen. Ich kann leider derzeit nicht sagen, in welcher Vorgabe-Datei [Kein Absatzformat] definiert ist. Also schmeißen Sie am besten alle weg.

Macht's das klarer?
--------------------------

InDesign-Wissen und Automatisierung nicht nur rund um die Suite.

http://www.cuppascript.com Top
 
i-tupfer
Beiträge: 72
24. Jan 2007, 13:51
Bewertung:
gelesen: 15295
Beitrag als Lesezeichen

Absatzformate kopieren


Antwort auf [ Gerald Singelmann ] Wenn innerhalb desselben Dokuments sich die Formatierung ändert, kann es nicht am [Einfachen Absatz] liegen. Zumal ja berichtet wurde, dass die AFs auf [Kein Absatzformat] basieren.

Macht's das klarer?


Hm - ich glaub ja.

Die Formatierung kann sich natürlich geandert bzw. zerschossen haben, als der Schriftenkonflikt aufgetreten ist. Das wäre zumindest eine logische Erklärung.

Toll! Ich bin begeistert von Ihren "Knobelkünsten" :-) Ich habe auch Ihren Lösungsweg bezüglich der Dateikopien bei Dokumentvorlagen (.indt) gelesen. Habs gleich umgesetzt.

Danke noch mal für die Mühe.

Heute ist nicht aller Tage - Ich komm wieder - keine Frage! :-)
(Happy End im La-la-Land...)
(Dieser Beitrag wurde von i-tupfer am 24. Jan 2007, 13:53 geändert)
Top
 
lowtone S
Beiträge: 145
24. Jan 2007, 16:10
Bewertung:
gelesen: 15272
Beitrag als Lesezeichen

Absatzformate kopieren


Antwort auf [ Gerald Singelmann ] Macht's das klarer?

Enorm!
Herzlichen Dank!
simon
Top
 
Jochen Uebel p
Beiträge: 3196
25. Jan 2007, 09:50
Bewertung:
gelesen: 2637
Beitrag als Lesezeichen

Absatzformate kopieren


Antwort auf [ Gerald Singelmann ] Während die Theorie sagt, dass [Kein Absatzformat] sich nie ändern kann und immer Times, 12pt etc. ist, habe ich schon Rechner / Dokumente gesehen, bei denen diese Definition zerschossen war und stattdessen i.d.R. eine Helvetica für [Kein Absatzformat] angelegt war.

Kurze Nachfrage noch: Mit dieser Situation ist also nicht gemeint, daß bei inaktiven Objekten ode bei geschlossenen Dokumenten einerseits das Absatzformat [Kein Absatzformat] aktiv ist und gleichzeitig (z.B. via Steuerung-Palette) eine andere Schrift als die Times ausgewählt ist?
Zum Beispiel das Dokument zeigt also [Kein Absatzformat] und "Times", setzt aber, wenn ich z.B. mit Alt-Shift-Klick noch einmal sauber auf [Kein Absatzformat] zurücksetze, weiterhin irgendwas (helvetica etc.)?
Grüße, Jochen Top
 
Gerald Singelmann  M  p
Beiträge: 6178
25. Jan 2007, 17:47
Bewertung:
gelesen: 2624
Beitrag als Lesezeichen

Absatzformate kopieren


Zitat Zum Beispiel das Dokument zeigt also [Kein Absatzformat] und "Times", setzt aber, wenn ich z.B. mit Alt-Shift-Klick noch einmal sauber auf [Kein Absatzformat] zurücksetze, weiterhin irgendwas (helvetica etc.)?


Yepp, das gibt's
--------------------------

InDesign-Wissen und Automatisierung nicht nur rund um die Suite.

http://www.cuppascript.com Top
 
srakete
Beiträge: 2
26. Mär 2007, 17:47
Bewertung:
gelesen: 2577
Beitrag als Lesezeichen

Absatzformate kopieren


Hallo,

dieser Thread hat mir sehr, sehr geholfen.

Bei der Analyse von einigen Dokumenten, die Probleme mit fehlenden Schriften bereiteten, ist mir aufgefallen, dass es auch vorkommt, dass im Abschnitt

<cfnt pnam="k_[No composite font]" ptag="x_0" Self="rc_u54">

die Einträge für k_Numbers und k_Alphabetic:

<cfen pnam="k_Alphabetic" font="k_Times (T1)" ....
<cfen pnam="k_Numbers" font="k_Times (T1)" ptfs="k_Roman" ...

ein anderes Font Format (Times (T1) ) besitzt als im Abschnitt

<psty pnam="k_[No paragraph style]" ... font="k_Times"

Wie gelingt einem denn dieses Kunststück ?

Beim Korrigieren der falschen Einträge unter no_composite_font werden keine fehlenden Schriften mehr angezeigt.


Stefan Rakete
Top
 
Gerald Singelmann  M  p
Beiträge: 6178
26. Mär 2007, 19:51
Bewertung:
gelesen: 2561
Beitrag als Lesezeichen

Absatzformate kopieren


Zitat Wie gelingt einem denn dieses Kunststück ?


InDesign hängt ein (TT) oder (T1) an den Namen an, wenn Sie mehr als eine Times installiert haben. Es scheint etwas zufällig zu sein, ob er sich für die TT oder die T1 entscheidet.

Immer, wenn Sie mehr als ein Format für eine Schrift installiert haben, gehört für dieses Dokument (diesen Rechner) das (TT) mit zum Schriftnamen. Sie haben also Probleme beim Austausch mit Rechnern, die nur eine Version (also ohne "(TT|T1)") haben.
Das kann im Fall der Times auch das Format [kAF] verhunzen.
--------------------------

InDesign-Wissen und Automatisierung nicht nur rund um die Suite.

http://www.cuppascript.com Top
 
Martin Fischer  M  p
Beiträge: 11834
26. Mär 2007, 20:00
Bewertung:
gelesen: 2560
Beitrag als Lesezeichen

Absatzformate kopieren


Hallo Gerald,

> Es scheint etwas zufällig zu sein, ob er sich für die TT oder die T1 entscheidet.

Bezeichnet das nicht einmal eine TrueType- (TT) und das andere Mal eine Type-1 Schrift (T1)?

Viele Grüße
Martin Top
 
Gerald Singelmann  M  p
Beiträge: 6178
26. Mär 2007, 20:25
Bewertung:
gelesen: 2548
Beitrag als Lesezeichen

Absatzformate kopieren


Zitat Bezeichnet das nicht einmal eine TrueType- (TT) und das andere Mal eine Type-1 Schrift (T1)?


Ja, klar. Der Punkt ist, dass in [kAF] dann nicht "Times" steht, sondern "Times(TT)" oder Times(T1)". Welches von beiden ist nicht nachvollziehbar.
--------------------------

InDesign-Wissen und Automatisierung nicht nur rund um die Suite.

http://www.cuppascript.com Top
 
Martin Fischer  M  p
Beiträge: 11834
9. Feb 2012, 10:30
Bewertung:
gelesen: 2211
Beitrag als Lesezeichen

Absatzformate kopieren


Antwort auf [ Gerald Singelmann ] - in der inx Datei gibt es einen Absatz, der mit <psty pnam="k_[No paragraph style]" anfängt. Suchen Sie diesen
- in diesem Abschnitt ist ein Eintrag, der mit font="c_ anfängt. Bei meiner Test-datei 3 Zeilen unter <psty pnam

Welcher Font steht hier in Ihrer inx-Datei?
Wenn etwas anderes als font="c_Times" dann ersetzen Sie den Eintrag gegen die Times. Speichern Sie die inx und öffnen Sie diese wieder in InDesign.
Geht's wieder?


Die Diskussion ist sehr alt und bezieht sich auf InDesign CS2.
Aber die Problematik taucht auch in Dokumenten, die in neueren InDesign-Versionen erstellt wurden, auf. Dort kann man das in der IDML-Datei (/Resources/Styles.xml) unter

<ParagraphStyle Self="ParagraphStyle/$ID/[No paragraph style]" Name="$ID/[No paragraph style] ...>

in

<AppliedFont type="string">Calibri</AppliedFont>

prüfen.


Das Problem ist jüngst in mediengestalter.info: Indesign CS5 Absatzformate gehen beim Kopieren verloren geschildert worden. Weil es bei mir in CS4 und CS5 auch ab und an noch vorkommt und ich noch keine schlüssige Erklärung bzw. Rezepte zur Vorbeugung hatte, wollte ich dem einmal auf den Grund gehen.

Inzwischen habe ich vom Thread-Ersteller Dateien zur Analyse erhalten.

Analyse:
In der Quelldatei hatte AF [Kein Absatzformat] die 'Times New Roman'.
In der Zieldatei hatte AF [Kein Absatzformat] die 'Calibri'.

Von beiden Dateien fertigte ich Duplikate an und tauschte dort 'Times New Roman' durch 'Calibri' und umgekehrt aus.


Das Ergebnis hat mich dann doch etwas überrascht:

Immer dann, wenn Text aus der Vorlagedatei mit der 'Times New Roman' in egal welche Zieldatei kopiert wird, entstehen Abweichungen.

Wenn Text aus der (modifizierten) Vorlagedatei mit der 'Calibri' in eine Zieldatei kopiert wird, entstehen in beiden Zieldateien keine Abweichungen.


Ich hätte erwartet, dass die 'Times New Roman' die richtige Schrift für AF [Kein Absatzformat] ist und deswegen beim Kopieren aus dieser Vorlage die geschilderten Probleme (Abweichungen) nicht auftreten sollten.
Nun ist's aber gerade umgekehrt: dort, wo die Calibri bei AF [Kein Absatzformat] zum Einsatz kommt, taucht das Problem nicht auf.


Nun endlich meine Frage:

Welcher der beiden Fonts ('Calibri' oder 'Times New Roman') ist in Windows-Versionen von CS5/CS5.5 standardmäßig dem AF [Kein Absatzformat] zugewiesen?


Möglicherweise gibt es für das beschriebene Verhalten noch eine andere Erklärung.
Die Vorlagedatei hatte ein Basisabsatzformat, das auf AF [Kein Absatzformat] basierte. In der Times-Version der Datei war im Basisabsatzformat die Calibri als Abweichung gegenüber dem AF [Kein Absatzformat] aufgeführt.
In der Calibri-Version war dies nicht der Fall.


Viele Grüße
Martin Top
 
zaphodbeeblebroxx p
Beiträge: 408
9. Feb 2012, 12:59
Bewertung:
gelesen: 2165
Beitrag als Lesezeichen

Absatzformate kopieren


 
Hallo Martin,

CS5.0 auf Win/PC:
Code
<AppliedFont type="string">Minion Pro</AppliedFont> 


CS5.5 ebenso.


Matthias Top
 
Martin Fischer  M  p
Beiträge: 11834
9. Feb 2012, 13:18
Bewertung:
gelesen: 2157
Beitrag als Lesezeichen

Absatzformate kopieren


Hallo Matthias,

das ist gut so.
Danke für den Hinweis.

Auf Grund dieser Tatsache gehe ich davon aus, dass die geprüften Dokumente mit Calibri bzw. Times New Roman als Font von AF [Kein Absatzformat] aus früheren Versionen hochkonvertiert wurden und dabei andere Einstellungen Huckepack mit nach CS5.5 genommen haben.

Oder hat jemand eine Idee, wie diese von der Minion als Standardschrift abweichenden Schriften in das AF [Kein Absatzformat] gelangen können?

Viele Grüße
Martin Top