Forenindex » Archiv » Perl und CGI » An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht

mc-schmitz
Beiträge gesamt:

15. Jul 2002, 13:14
Bewertung:

gelesen: 1658

Beitrag als Lesezeichen
Hallo

Ich habe ein Perl Script im einsatz, das läuft auf meinem Account leider nicht, aber auf einem anderen Server läuft es
ohne Probleme.

Was kannd as Problem sein??? Kann es an der Perl Version auf dem Server liegen???

Gruß Mc-Schmitz

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht

SabineP
Beiträge gesamt: 7586

15. Jul 2002, 13:48
Bewertung:

gelesen: 1658

Beitrag als Lesezeichen
Hallo Mc-Schmitz, das kann viele verschiedene Gründe haben:
unterschiedliche Webserverkonfiguration, Perl-Versionen, installierte Perl-Module, Pfade, Ausführungsrechte.
Wie äußert sich denn der Fehler? Gibts eine Fehlermeldung?

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht

mc-schmitz
Beiträge gesamt:

15. Jul 2002, 14:24
Bewertung:

gelesen: 1658

Beitrag als Lesezeichen
Das ist der Fehler

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, root@linux.local and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Es ist übrigens das Kalenderwochenscript von dir. AUf meinem Testserver ist es wunderbar gelaufen, aber auf meiner Homepage läuft es überhaupt nicht, rechte sollten aber passen. 755 sollte doch ausreichen.

Danke für deine schnelle Antwort

Mc-Schmitz

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht

SabineP
Beiträge gesamt: 7586

15. Jul 2002, 15:08
Bewertung:

gelesen: 1658

Beitrag als Lesezeichen
Teste mal folgendes Script:

#!/usr/bin/perl
print "Content-type: text/html\n\n";
print "Hello world";

Im Browser muß nach Aufruf "Hello world" erscheinen.

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht

mc-schmitz
Beiträge gesamt:

15. Jul 2002, 15:16
Bewertung:

gelesen: 1658

Beitrag als Lesezeichen
Hi

Da kommt genau der gleiche Fehler

Gruß Mc-Schmitz

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht

SabineP
Beiträge gesamt: 7586

15. Jul 2002, 15:26
Bewertung:

gelesen: 1658

Beitrag als Lesezeichen
Ich nehme an, Du hast das Testscript im Ascii-Modus übertragen und mit chmod 755 die Rechte gesetzt.
Wie lautet denn der Pfad zu Perl bei Deinem Provider?
Vielleicht ist der Pfad so eingerichtet:
#!/usr/local/bin/perl


[ Diese Nachricht wurde geändert von: SabineP am 2002-07-15 15:28 ]

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht

oesi50
  
Beiträge gesamt: 2315

15. Jul 2002, 15:29
Bewertung:

gelesen: 1658

Beitrag als Lesezeichen
hi,
speicher mal in dem Verzeichnis eine
.htaccess Datei mit folgendem Inhalt
----schnipp--------------
Options +ExecCGI
AddHandler cgi-script pl cgi
----schnapp--------------

Fragen:
Wer hat den Webserver configuriert?
Läßt sich da noch was machen?


[ Diese Nachricht wurde geändert von: oesi50 am 2002-07-15 15:31 ]

An was kann das liegen? Script läuft auf einem Server auf dem anderen nicht

mc-schmitz
Beiträge gesamt:

16. Jul 2002, 08:05
Bewertung:

gelesen: 1658

Beitrag als Lesezeichen
Hallo

mitlerweile funktioniert es wunderbar, ich mußte meinen Account auf dem Server löschen und neu erstellen. Komisch, nicht mal der Provider konnte mir sagen an was es lag.

Gruß Mc-Schmitz

Danke für eure Hilfe