hilfdirselbst.ch
Facebook Twitter gamper-media
jrandi
Beiträge: 794
4. Sep 2017, 18:44
Beitrag #1 von 3
Bewertung:
(6393 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

php7.0 -> php7.1. CodeIgniter Encrypt.php


Guten Tag,

auf unserer Website mit php 7.0. geht alles gut.
upgrade auf php 7.1.7 (eine site mit CodeIgniter) haben wir folgende Fehlermeldung :

A PHP Error was encountered
Severity: 8192
Message: Function mcrypt_get_iv_size() is deprecated
Filename: libraries/Encrypt.php

Wir dachten, wir ersetzen mal das File Encrypt.php mit der neusten Version von CI, aber funktioniert nicht...

habt Ihr eine Idee ? Für Tipps und Tricks danke ich im voraus bestens.
gruss
jurg

___________________________________________________

net & print production : www.randj.net / www.alpha-randj.net Top
 
X
crisies  A  p
Beiträge: 92
6. Feb 2018, 22:41
Beitrag #2 von 3
Beitrag ID: #562319
Bewertung:
(2719 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

php7.0 -> php7.1. CodeIgniter Encrypt.php


https://stackoverflow.com/questions/45341314/function-mcrypt-get-iv-size-is-deprecated-in-codeigniter-on-php-version-7-1

Da scheint diese Encrypt Biblio. veraltet zu sein. Vermutlich müsste man CodeIgniter aktualisieren.
lg
chris.w.
als Antwort auf: [#559327] Top
 
jrandi
Beiträge: 794
7. Feb 2018, 17:50
Beitrag #3 von 3
Beitrag ID: #562324
Bewertung:
(2681 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen

php7.0 -> php7.1. CodeIgniter Encrypt.php


hey Chris,

danke für den Tipp... ja wir haben die neuste CI-version installiert (vor monaten) und es ging dann.

gruss
jurg

___________________________________________________

net & print production : www.randj.net / www.alpha-randj.net
als Antwort auf: [#562319] Top