[GastForen Archiv Adobe GoLive iFrame-Problem

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Archiv - Archivierte Foren
Themen
Beiträge
Moderatoren
Letzter Beitrag

iFrame-Problem

Frank Walensky-Schweppe
Beiträge gesamt: 227

26. Feb 2004, 16:02
Beitrag # 1 von 8
Bewertung:
(2189 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Liebe Freunde, ich habe ein kleines Problem mit einem iFrame. Hat jemand Zeit, auf http://www.liveatwork.de/ einmal auf Betriebs-/Dienstvereinbarungen zu klicken und mir dann zu erklären, warum IE6 und Netscape 7 sich bezüglich der Bildlaufleisten völlig unterscheidlich verhalten? Danke für jede Hilfe! FRANK
X

iFrame-Problem

Dirk Levy
  
Beiträge gesamt: 9460

26. Feb 2004, 16:09
Beitrag # 2 von 8
Beitrag ID: #72248
Bewertung:
(2189 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Wegen der unterschiedlichen Behandlung Ihrer Ränder
vermute ich, ich glaube da mußt Du etwas durch Ausprobieren
rankommen.

Gruß
Dirk

[Adobe GoLive Tipps & Tricks]
http://www.gltipps.de


als Antwort auf: [#72243]

iFrame-Problem

Frank Walensky-Schweppe
Beiträge gesamt: 227

26. Feb 2004, 16:42
Beitrag # 3 von 8
Beitrag ID: #72257
Bewertung:
(2189 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Dirk, 1001 Versuche sind gelaufen. Warum erscheint beim IE6 die Bildlaufleiste erst, wenn ich einmal kurz die Größe des Browserfensters geändert habe?


als Antwort auf: [#72243]

iFrame-Problem

SabineP
Beiträge gesamt: 7586

26. Feb 2004, 16:48
Beitrag # 4 von 8
Beitrag ID: #72258
Bewertung:
(2189 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Frank,

der Validator zeigt einige Fehler an:http://www.liveatwork.de/bv_dv/index_bv_dv.html

Schau Dir mal das Beispiel von Selfhtml an:
http://selfhtml.teamone.de/...s/anzeige/iframe.htm

In diesem Beispiel erfolgt die Darstellung in beiden Browsern so wie Du es Dir vorstellst,
aber der Validator kommt mit dem DOCTYPE der Seite auch nicht zurecht. :-(

Gruß Sabine
PS. mit "beide Browser" meine ich IE4 und Mozilla. Was anderes habe ich gerade nicht zum Testen da.


als Antwort auf: [#72243]
(Dieser Beitrag wurde von SabineP am 26. Feb 2004, 17:09 geändert)

iFrame-Problem

Frank Walensky-Schweppe
Beiträge gesamt: 227

26. Feb 2004, 17:13
Beitrag # 5 von 8
Beitrag ID: #72263
Bewertung:
(2189 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Sabine, auch wenn ich den DOCTYPE von XHTML auf HTML ändere, das Problem scheint die Angabe der Breite zu sein. Netscape bringt die Bildlaufleiste innerhalb der ID, IE fügt sogar eine horizontale BLL ein. Mist. Die Fehlermeldungen des Validators weisen nicht auf das prinzipielle Problem hin. Und ich hatte die Hoffnung, das iframes ein inzwischen ausgereiftes Gestaltungsmittel seien. Danke für deine Antwort, aber ich befürchte, dass ich mich auf die Suche nach anderen Lösungen machen muss :-( Gruß aus Hamburg! FRANK


als Antwort auf: [#72243]

iFrame-Problem

SabineP
Beiträge gesamt: 7586

26. Feb 2004, 17:26
Beitrag # 6 von 8
Beitrag ID: #72268
Bewertung:
(2189 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Frank,
die Breiten- und Höhenangaben für iframes sind nur beim Doctype xhtml nicht erlaubt.
Der Validator ist jetzt mit Deiner Seite recht zufrieden.

Mit dem DOCTYPE HTML 4.01 darfst Du auch die Breiten- und Höhenangaben wieder einsetzen.
zum Beispiel
<IFRAME src="http://www.example.com" width="100%" height="100%" scrolling="auto">Link einsetzen für Browser, die iframe nicht darstellen können</IFRAME>

Vielleicht verschwinden ja dann auch die Darstellungsprobleme mit dem IE 6.

Alternativ kannst Du auch mit dem <object> Tag Seiten einbinden.
In der W3C-Spezifikation wird das auch so vorgeschlagen
(ganz unten grüner Hinweis):
http://www.w3.org/...mes.html#edef-IFRAME

Allerdings halte ich auch eine Lösung ganz ohne <iframe> und <object> für die bessere.

Gruß Sabine


als Antwort auf: [#72243]
(Dieser Beitrag wurde von SabineP am 26. Feb 2004, 17:30 geändert)

iFrame-Problem

Frank Walensky-Schweppe
Beiträge gesamt: 227

26. Feb 2004, 18:01
Beitrag # 7 von 8
Beitrag ID: #72278
Bewertung:
(2189 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Sabine, dein letzter Satz: Warum? Da versteht davon mehr als ich. Danke für deine Antwort! FRANK


als Antwort auf: [#72243]

iFrame-Problem

SabineP
Beiträge gesamt: 7586

26. Feb 2004, 18:12
Beitrag # 8 von 8
Beitrag ID: #72281
Bewertung:
(2189 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Frank, weil <iframe> und <object> nicht in allen Browser unterstütz wird.
Suchmaschinen werden 2 Seiten in den Index aufnehmen,
die Seite die den <iframe>-Tag enthält und die Seite die per <iframe> eingebunden ist.

Ich nehme an, Du möchtest einen scrollbaren Bereich in Deiner Seite.
Vielleicht verstehst Du dieses Beispiel, eine Lösung mit CSS:
http://www.hilfdirselbst.ch/...1&topic_id=12502

Gruß Sabine


als Antwort auf: [#72243]
X