[GastForen Archiv Adobe GoLive vom Formular zu sendmail (wo geht's lang?)

  • Suche
  • Hilfe
  • Lesezeichen
  • Benutzerliste
Archiv - Archivierte Foren
Themen
Beiträge
Moderatoren
Letzter Beitrag

vom Formular zu sendmail (wo geht's lang?)

r a c
Beiträge gesamt: 955

12. Jun 2002, 14:27
Beitrag # 1 von 17
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo zusammen,
ich krieg mein Formular nicht hin. Internal Server err.....

Meist soll das ja am Hochladen liegen.

Nun meine Frage: ich soll das Scribt im ASCI-Modus hochladen. Ist das jetzt Text oder Binär?

Meine anfängliche Vermutung, dass GL das schon von selbst richtig macht ist möglicherweise falsch.
X

vom Formular zu sendmail (wo geht's lang?)

Anonym
Beiträge gesamt: 22827

12. Jun 2002, 14:47
Beitrag # 2 von 17
Beitrag ID: #5007
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
hallo r a c,

wenn du zugriff auf #!perl\bin\cgi oder ähnlich deines host hast,dann solltest du scripte immer im ASCII mode hochladen.

falls nicht, stellen die host ein formular script zur verfügung. einfach mal bei jeweiligen host nachschauen.

greetz


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

Anonym
Beiträge gesamt: 22827

12. Jun 2002, 14:49
Beitrag # 3 von 17
Beitrag ID: #5008
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
nachtrag:
ASCII ist text soweit mir bekannt.


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

r a c
Beiträge gesamt: 955

12. Jun 2002, 14:53
Beitrag # 4 von 17
Beitrag ID: #5009
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
mein Problem ist:

ASCI steht nicht drauf. Ich will ja. Aber ich hab die Wahl:

Text oder Binär?

Wenn ASCI keinem von beiden entspricht, also etwas drittes ist. wo kann ich es dann in GL6 einstellen?


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

Kusi
Beiträge gesamt: 1398

12. Jun 2002, 15:11
Beitrag # 5 von 17
Beitrag ID: #5012
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo
überprüf auch die Rechte für das Script. Die sollten auf 755 oder 775 gesetzt sein.

Gruss Kusi


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

Anonym
Beiträge gesamt: 22827

12. Jun 2002, 15:29
Beitrag # 6 von 17
Beitrag ID: #5016
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
hi r a c,
ich hoffe das hilft dir weiter.

"Eine reine Textdatei wie z. B. .txt, .html, .htm, .cgi sollte immer im ASCII-Modus übertragen werden.
Achtung: Eine binäre Datei im ASCII-Format zu übertragen, kann die Datei beschädigen.

Bild-Dateien, ausführbare Dateien oder auch ZIP-Archive (.bmp, .jpg, .exe, .zip) sollten immer im Binär-Modus übertragen werden. Dieser Modus sollte auch dann verwendet werden, wenn der Dateityp unbekannt oder nicht in Windows registriert ist."

ist aus der hilfe von wise-ftp.

greetz mAx


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

r a c
Beiträge gesamt: 955

12. Jun 2002, 17:48
Beitrag # 7 von 17
Beitrag ID: #5035
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Danke erst mal. Doch noch ist mir nicht geholfen

Die böse Dateien die (vielleicht?!?) falsch hochgeladen wurde sind vom Typ .pl und .pm

Ich habe jetzt doch an den Einstellungen herumgepröbelt (ich mach das nicht gerne, wenn ich überhaupt keine Ahnung habe, wass ich da tue). Defaut ist Text, ich habe es jetzt binär hochgeladen. Hat mich aber auch nicht weiter gebracht.

Was es erschwert ist: der Fehler kann auch ganz woanders liegen.
Die Rechte sind bei 755, die Pfade sollten auch stimmen. Das scribt wird ganz am Anfang abgewürgt. Alle die hübschen Fehlermeldungen, die im Scribt eingebaut sind kommen also gar nicht.


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

Kusi
Beiträge gesamt: 1398

12. Jun 2002, 23:36
Beitrag # 8 von 17
Beitrag ID: #5065
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Kannst du mir mal dein Script zu senden,dann sehe ichs mir an. Gruss Kusi


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

r a c
Beiträge gesamt: 955

13. Jun 2002, 01:32
Beitrag # 9 von 17
Beitrag ID: #5067
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Danke Kusi
Das Sribt habe ich von
http://cgi.xwolf.de/cgi/allform.shtml
Es geht um allform.pl und web.pm.
Ich denke ich habe die pfade drin OK angepasst.

Unsicher bin ich alleine beim hochladen.
Scribt OK, Rechte OK. Trotzdem gehts nicht.

[ Diese Nachricht wurde geändert von: r a c am 2002-06-13 01:34 ]


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

Kusi
Beiträge gesamt: 1398

13. Jun 2002, 08:16
Beitrag # 10 von 17
Beitrag ID: #5074
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hi
Ich hab mir das Scrip angesehen und es könnte dort schon ein paar Sachen drin haben, die speziell auf deinen Hoster angepast werden sollten.

Kontrollier doch mal die Einstellungen zum aufladen: Bearbeiten -> Webeinstellungen ->Dateizuordnung -> Text ->cgi (oder pl) anwählen dann siehst du unter Typ was eingestellt ist. Hier sollte Text (für Ascii) gewählt sein, im Inspektor kannst du das allenfalls ändern.

Gruss Kusi


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

r a c
Beiträge gesamt: 955

13. Jun 2002, 14:43
Beitrag # 11 von 17
Beitrag ID: #5106
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo Kussi,
Die Einstellungen waren ursprünglich auf text, habe sie dann in der Panik auf binär geändert, und bin jetzt wieder auf text.
Das ist es nicht.
Zeilenumbrüche sind auf UNIX. Das dürfte auch passen auf den Apache.
Weiter ratlos


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

SabineP
Beiträge gesamt: 7586

13. Jun 2002, 15:11
Beitrag # 12 von 17
Beitrag ID: #5109
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo rac,

ich hab mal die allform.pl und web.pm auf den Webserver geladen (mit WS-FTP). Habe keine Änderungen vorgenommen, nur in der allform.pl den Pfad zu Perl angepaßt (erste Zeile!).

http://snow.prohosting.com/sperner/formular/allform.pl

Probier mal aus, ob das so bei Dir auch geht.

Wenn nicht, dann benenne mal die allform.pl in allform.txt um und lege die Datei in ein Verzeichnis das lesbar ist. Mit URL kann man dann direkt nachsehen in welcher Form die Datei auf Deinem Webserver liegt.

Das Test-Formular ist hier zu finden:
http://snow.prohosting.com/sperner/formular/allform.html

Die Formulardaten werden in diese Datei geschrieben:
(sieht aus wie eine Umfrage)
http://snow.prohosting.com/sperner/formular/allform

Die allform.pl hab ich inzwischen so angepaßt:
http://snow.prohosting.com/sperner/formular/allform.txt

[ Diese Nachricht wurde geändert von: SabineP am 2002-06-13 16:52 ]


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

r a c
Beiträge gesamt: 955

13. Jun 2002, 18:50
Beitrag # 13 von 17
Beitrag ID: #5131
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Hallo SabineP,
Ganz vielen Dank.
Jetzt bin ich einen Schritt weiter. Ich habe beide Dateien ins selbe Verzeichniss gelegt, wo meine .html's liegen.
Jetzt krieg ich "Kann die Datei /tmp/submit1.tmp nicht öffnen!"
Diese Fehlermeldung kommt eindeutig vom Skribt. Keine Ahnung, wieso es im cgi-bin unglücklich war.

Jetzt zu submit1. Ich habe keinen Ordner /tmp.
Was kann ich tun?


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

r a c
Beiträge gesamt: 955

13. Jun 2002, 19:04
Beitrag # 14 von 17
Beitrag ID: #5134
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Nachtrag,
wenn ich Abschicken drücke kommt obige Felermeldung. Gehe ich dann zurück und drücke nochmals Abschicken kommt eine neue Meldung
"Sie haben mehrmals commitet!"
Woher will das Scribt das wissen, wenn es die submit1.tmp nicht aufbringt?


als Antwort auf: [#5002]

vom Formular zu sendmail (wo geht's lang?)

r a c
Beiträge gesamt: 955

13. Jun 2002, 19:55
Beitrag # 15 von 17
Beitrag ID: #5138
Bewertung:
(2219 mal gelesen)
URL zum Beitrag
Beitrag als Lesezeichen
Nachtrag 2
Es funktioniert.
Die Datei, die mehrmals eingeben verhindert wird angelegt und geht. Eine zweite Datei, die die Daten aufnehmen soll geht nicht. Ich habe den dazugehörenden hiddentag im Formular weggelassen. Jetzt werden die Daten gemailt, der User auf eine Danke-Seite weitergeleitet und ich bin zufrieden.

Irgendwie hätte ich doch gene gewusst, wieso es im cgi-bin so gar nicht geklappt hat. Ein "richtiger" webmaster hätte das Scribt doch dahin gepackt!?!
Aber man soll nicht zuviel wollen.
Es funktioniert

Danke an Kusi und Sabine


als Antwort auf: [#5002]
X

Aktuell

Veranstaltungskalender

Hier können Sie Ihre Anlässe eintragen, welche einen Zusammenhang mit den Angeboten von HilfDirSelbst.ch wie z.B. Adobe InDesign, Photoshop, Illustrator, PDF, Pitstop, Affinity, Marketing, SEO, Büro- und Rechtsthemen etc. haben. Die Einträge werden moderiert freigeschaltet. Dies wird werktags üblicherweise innert 24 Stunden erfolgen.

pdf-icon Hier eine kleine Anleitung hinsichtlich Bedeutung der auszufüllenden Formularfelder.

Veranstaltungen
01.03.2023 - 09.03.2023

Online
Mittwoch, 01. März 2023, 00.00 Uhr - Donnerstag, 09. März 2023, 00.00 Uhr

Online Webinar

Wie gehen wir mit diesen Veränderungen um? Was ist notwendig, damit wir die Digitalisierung im Unternehmen klappt? Veränderungsprozesse verstehen und entsprechend handeln Mitarbeiter als Botschafter Webseite mit WordPress erstellen SEA /SEO (Ads aufschalten)

Ja

Organisator: B. Isik - SNF Academy

Kontaktinformation: B. Isik, E-Mailinfo AT snfa DOT ch

https://www.fernstudiumfitness.ch/digitalisierung-schweiz/